Skip to content

Commit

Permalink
dev-php/PHPMailer: new package to construct and send email using PHP.
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.20.1
  • Loading branch information
orlitzky committed Nov 6, 2015
1 parent 9516529 commit a16b160
Show file tree
Hide file tree
Showing 3 changed files with 67 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-php/PHPMailer/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST PHPMailer-5.2.14.tar.gz 192100 SHA256 54acc99a6cdd807c5646e712e4499308d885bc76a3dc27679388fe0359bd3a93 SHA512 f3cacbdea4b008e6f0bddbc06fc08c8afebe64f74dded5fe87022a6ccf36db19bf4cf4f303399373c250afec32f87645eab6acd8adbcfbed3af349edd51f9e49 WHIRLPOOL c202ad61a6380b23f3e7460f333e396ef9be16f097a798f048a806d184a8ed2f50a32183d7420e7e1439865367177df0d352246928a67b315a89ed339534ad6c
57 changes: 57 additions & 0 deletions dev-php/PHPMailer/PHPMailer-5.2.14.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,57 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

DESCRIPTION="Full-featured email creation and transfer class for PHP"
HOMEPAGE="https://github.com/PHPMailer/PHPMailer"
SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc +examples test"

RDEPEND="dev-lang/php:*"
DEPEND="${RDEPEND}
doc? ( dev-php/phpDocumentor )
test? ( dev-php/phpunit )"

# The test suite requires network access.
RESTRICT=test

src_compile(){
if use doc; then
phpdoc --filename="class.*.php" \
--target="./html" \
--title="${PN}" \
--sourcecode \
--force \
--progressbar \
|| die "failed to generate API documentation"
fi
}

src_install(){
insinto "/usr/share/php/${PN}"
doins -r *.php language extras

dodoc README.md changelog.md
dodoc docs/*
use examples && dodoc -r examples

use doc && dohtml -r html/*
}

src_test(){
cd test/ || die
phpunit . || die "test suite failed"
}

pkg_postinst(){
elog "${PN} has been installed in /usr/share/php/${PN}/."
elog "To use it in a script, require('${PN}/${PN}Autoload.php'),"
elog "and then use the ${PN} class normally. Most of the examples in"
elog "the documentation should work without further modification."
}
9 changes: 9 additions & 0 deletions dev-php/PHPMailer/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>php</herd>
<maintainer>
<email>[email protected]</email>
<name>Michael Orlitzky</name>
</maintainer>
</pkgmetadata>

0 comments on commit a16b160

Please sign in to comment.