forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: portage-2.3.0
- Loading branch information
Showing
3 changed files
with
65 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST calcurse-4.0.0.tar.gz 611593 SHA256 621b0019907618bd468f9c4dc1ce2186ee86254d3c9ade47dd2d7ab8e6656334 SHA512 42a1b317bfd38974cbe4a4d3d1c848b8cd09233fc71f1f3ce36daf33352d9caffd7926c75d5e7ae6dd1138b8735a5244d5411fa1875a3262f1dc37c0a101d38c WHIRLPOOL dd5e938f2536e079d4cc2437fea057c5ad4d450dc7d2cc7763101192c9f9abf3800d2c08edea8163645e525eaf8e1fdcc5199c91e78a2c8933f66139dafdba3a | ||
DIST calcurse-4.1.0.tar.gz 611105 SHA256 ca423f8c8dfbb92cd63281305fa23c2909a6aefcee9e86317584fff7619b42c4 SHA512 74312995e398edf0bc30bdf6c28e5894f21358d5b85bdff403425685905dd7f511a3244acd3983bc28d8d3bc90a79a2e83fc76554d7e5c9ef9dc16d18832e09a WHIRLPOOL 2a3c86f5f79903911f0aa38e3f32350770d5f839cbf460b288e64b20b315422a95bd64caec5fb9f5c9f366e9b3b5031f235ddaf89b40183360886b9f066c58d3 | ||
DIST calcurse-4.2.0.tar.gz 612242 SHA256 a68e0e6984ec632180a9fdc496785b406fedc1d5af77dfe4fcd483b0cec84a77 SHA512 daba2db0b15dbaf400568ace700d06e6165dc9275e35cb3c31ee49963802234ee3fc4b91faa3c7a675452aac5bbcff2f26d7f0d76fc2a0e094e584ed10c8ad11 WHIRLPOOL 9652639ca19dc7990f616abd933f08c08ec1b607cf153f17fd0345736f29adb77dc8b4181ca6801684c918f523dd9e387000ec2c134e997aa9cffda3082896dd |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,43 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
|
||
inherit eutils autotools multilib-minimal | ||
|
||
DESCRIPTION="a text-based calendar and scheduling application" | ||
HOMEPAGE="http://calcurse.org/" | ||
SRC_URI="http://calcurse.org/files/${P}.tar.gz" | ||
|
||
LICENSE="BSD-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86 ~ppc ~ppc64" | ||
|
||
RDEPEND="sys-libs/ncurses:0=" | ||
DEPEND="${RDEPEND}" | ||
|
||
DOCS=( AUTHORS NEWS README ) | ||
|
||
src_prepare() { | ||
default | ||
|
||
epatch "${FILESDIR}"/"${P}-tinfo.patch" | ||
|
||
# Dubious tests. | ||
rm -v "${S}/test"/ical-00{2,4,6}.sh || die | ||
|
||
eautoreconf | ||
} | ||
|
||
multilib_src_configure() { | ||
ECONF_SOURCE="${S}" econf | ||
} | ||
|
||
src_compile() { | ||
multilib-minimal_src_compile | ||
} | ||
|
||
src_install() { | ||
multilib-minimal_src_install | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,21 @@ | ||
--- a/configure.ac | ||
+++ b/configure.ac | ||
@@ -3,7 +3,7 @@ | ||
#------------------------------------------------------------------------------- | ||
AC_PREREQ(2.59) | ||
AC_INIT([calcurse], | ||
- m4_esyscmd([build-aux/git-version-gen .version]), | ||
+ m4_esyscmd_s([cat .version]), | ||
[[email protected]]) | ||
AM_INIT_AUTOMAKE | ||
#m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])]) | ||
@@ -51,6 +51,9 @@ | ||
LIBS="$LIBS -l$available_ncurses" | ||
]) | ||
|
||
+AC_SEARCH_LIBS([cbreak], [tinfow tinfo],, | ||
+ AC_MSG_ERROR([Cannot find a library providing cbreak])) | ||
+ | ||
AC_CHECK_HEADERS([pthread.h], [ | ||
AC_CHECK_LIB(pthread, pthread_create, [ | ||
LIBS="$LIBS -pthread" |