Skip to content

Commit

Permalink
dev-perl/GeoIP2: Add w/ v=2.6.2
Browse files Browse the repository at this point in the history
Provides access to GeoIP2 databases used for example by
SpamAssasssin to map IP addresses to geo locations.

Suggested by Tomáš Mózes

Closes: gentoo#13973
Closes: https://bugs.gentoo.org/675494
Package-Manager: Portage-2.3.86, Repoman-2.3.20
Signed-off-by: Kent Fredric <[email protected]>
  • Loading branch information
kentfredric committed Feb 5, 2020
1 parent 839fa6f commit a1a45dc
Show file tree
Hide file tree
Showing 3 changed files with 100 additions and 0 deletions.
48 changes: 48 additions & 0 deletions dev-perl/GeoIP2/GeoIP2-2.6.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
# Copyright 2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

DIST_AUTHOR=MAXMIND
DIST_VERSION=2.006002
inherit perl-module

DESCRIPTION="API for MaxMind's GeoIP2 web services and databases"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
RESTRICT="!test? ( test )"

RDEPEND="
virtual/perl-Data-Dumper
>=dev-perl/Data-Validate-IP-0.250.0
virtual/perl-Exporter
virtual/perl-Getopt-Long
dev-perl/HTTP-Message
dev-perl/JSON-MaybeXS
dev-perl/LWP-Protocol-https
dev-perl/libwww-perl
dev-perl/List-SomeUtils
virtual/perl-MIME-Base64
>=dev-perl/MaxMind-DB-Reader-1.0.0
dev-perl/Moo
dev-perl/Params-Validate
virtual/perl-Scalar-List-Utils
dev-perl/Sub-Quote
dev-perl/Throwable
dev-perl/Try-Tiny
dev-perl/URI
dev-perl/namespace-clean
"
BDEPEND="${RDEPEND}
virtual/perl-ExtUtils-MakeMaker
test? (
virtual/perl-File-Spec
virtual/perl-IO-Compress
dev-perl/MaxMind-DB-Common
dev-perl/Path-Class
dev-perl/Test-Fatal
dev-perl/Test-Number-Delta
>=virtual/perl-Test-Simple-0.960.0
)
"
1 change: 1 addition & 0 deletions dev-perl/GeoIP2/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST GeoIP2-2.006002.tar.gz 249915 BLAKE2B c1635de576e0c7f0ebad85bb3d850d6fbc979108777c494ec1685b4ce68b87c895e46df904b9cde5712b9d6aa9f6b341b66c024459f6cf88546f2e6ef6732c0f SHA512 a552c6487b340aa928cfc6ce037724cf0fa98332b731388734bc2b25e7d1a31e2c45c0cd12b6c962b5b483172837587254d742fb04cbcec67586d92dae71e356
51 changes: 51 additions & 0 deletions dev-perl/GeoIP2/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>[email protected]</email>
<name>Gentoo Perl Project</name>
</maintainer>
<maintainer type="person">
<email>[email protected]</email>
<name>Tomáš Mózes</name>
</maintainer>
<upstream>
<remote-id type="cpan">GeoIP2</remote-id>
<remote-id type="cpan-module">GeoIP2</remote-id>
<remote-id type="cpan-module">GeoIP2::Database::Reader</remote-id>
<remote-id type="cpan-module">GeoIP2::Error::Generic</remote-id>
<remote-id type="cpan-module">GeoIP2::Error::HTTP</remote-id>
<remote-id type="cpan-module">GeoIP2::Error::IPAddressNotFound</remote-id>
<remote-id type="cpan-module">GeoIP2::Error::Type</remote-id>
<remote-id type="cpan-module">GeoIP2::Error::WebService</remote-id>
<remote-id type="cpan-module">GeoIP2::Model::ASN</remote-id>
<remote-id type="cpan-module">GeoIP2::Model::AnonymousIP</remote-id>
<remote-id type="cpan-module">GeoIP2::Model::City</remote-id>
<remote-id type="cpan-module">GeoIP2::Model::ConnectionType</remote-id>
<remote-id type="cpan-module">GeoIP2::Model::Country</remote-id>
<remote-id type="cpan-module">GeoIP2::Model::Domain</remote-id>
<remote-id type="cpan-module">GeoIP2::Model::Enterprise</remote-id>
<remote-id type="cpan-module">GeoIP2::Model::ISP</remote-id>
<remote-id type="cpan-module">GeoIP2::Model::Insights</remote-id>
<remote-id type="cpan-module">GeoIP2::Record::City</remote-id>
<remote-id type="cpan-module">GeoIP2::Record::Continent</remote-id>
<remote-id type="cpan-module">GeoIP2::Record::Country</remote-id>
<remote-id type="cpan-module">GeoIP2::Record::Location</remote-id>
<remote-id type="cpan-module">GeoIP2::Record::MaxMind</remote-id>
<remote-id type="cpan-module">GeoIP2::Record::Postal</remote-id>
<remote-id type="cpan-module">GeoIP2::Record::RepresentedCountry</remote-id>
<remote-id type="cpan-module">GeoIP2::Record::Subdivision</remote-id>
<remote-id type="cpan-module">GeoIP2::Record::Traits</remote-id>
<remote-id type="cpan-module">GeoIP2::Role::Error::HTTP</remote-id>
<remote-id type="cpan-module">GeoIP2::Role::HasIPAddress</remote-id>
<remote-id type="cpan-module">GeoIP2::Role::HasLocales</remote-id>
<remote-id type="cpan-module">GeoIP2::Role::Model</remote-id>
<remote-id type="cpan-module">GeoIP2::Role::Model::Flat</remote-id>
<remote-id type="cpan-module">GeoIP2::Role::Model::HasSubdivisions</remote-id>
<remote-id type="cpan-module">GeoIP2::Role::Model::Location</remote-id>
<remote-id type="cpan-module">GeoIP2::Role::Record::Country</remote-id>
<remote-id type="cpan-module">GeoIP2::Role::Record::HasNames</remote-id>
<remote-id type="cpan-module">GeoIP2::Types</remote-id>
<remote-id type="cpan-module">GeoIP2::WebService::Client</remote-id>
</upstream>
</pkgmetadata>

0 comments on commit a1a45dc

Please sign in to comment.