Skip to content

Commit

Permalink
media-libs/dav1d: Version bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Luca Barbato <[email protected]>
  • Loading branch information
lu-zero committed Mar 19, 2019
1 parent f5d2c73 commit a1bbe9f
Show file tree
Hide file tree
Showing 2 changed files with 59 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-libs/dav1d/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST dav1d-0.1.0.tar.bz2 351745 BLAKE2B 302680ddfdc8d5a3eff90541ed156e820c3322bfb93316da1b2deabeac40062103af19e99dfa810678e62ad668c4aed944ac9bf8160afb301b100063919ed2a1 SHA512 5893ad40af7c4f5c3678ecc604ad360b5d1cd3fadaa16f7183d638745097fed091aeb3456540db61a2f4f0fc8bb93f2a20f428c76a7976d3fd186cc8b8baed53
DIST dav1d-0.2.0.tar.bz2 408361 BLAKE2B 2c5f4d7777d85ab1453a744335ee5047b2e108a70e884c5116d8d1a56b81c1f852c93666bd0bb3f4d5105f2220bbc6c92f893848f0cf1bfc0bce1ee1f551287c SHA512 378060ed6762f9f6baf7addfa7382cb0873bbc606f0389eee4ed7537dcfc851f5b159a34af0f15d9f8d345a9b2a950f38078a419144b0458aa3464e54ea5d490
DIST dav1d-0.2.1.tar.bz2 412003 BLAKE2B 51520f355f51f7fdc8c6e7981fd29f8d5339c2c72058ea05dff6bf0c3b191cf3c077fee1b46813f229d1bee16d1b884e834a5d61bf78459d83113aafe63bca89 SHA512 38d0a9e639579bf2046d3afd7ba0d4205081d8e26955be0216acc84ee2adcc81c790c858932009965b61a66fc3df66ed6b14da9d0e61e2505418c17bc4b75004
58 changes: 58 additions & 0 deletions media-libs/dav1d/dav1d-0.2.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,58 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

SCM=""
if [[ "${PV}" == "9999" ]]; then
SCM="git-r3"
EGIT_REPO_URI="https://code.videolan.org/videolan/dav1d"
else
KEYWORDS="~amd64"
SRC_URI="https://code.videolan.org/videolan/dav1d/-/archive/${PV}/${P}.tar.bz2"
fi

inherit ${SCM} meson ninja-utils multilib-minimal

DESCRIPTION="dav1d is an AV1 Decoder :)"
HOMEPAGE="https://code.videolan.org/videolan/dav1d"

LICENSE="BSD-2"
SLOT="0"
IUSE="+8bit +10bit +asm"

ASM_DEPEND=">=dev-lang/nasm-2.13"
RDEPEND=""
DEPEND="${RDEPEND}
asm? (
abi_x86_32? ( ${ASM_DEPEND} )
abi_x86_64? ( ${ASM_DEPEND} )
)"

DOCS=( README.md doc/PATENTS )

multilib_src_configure() {
local -a bits=()
use 8bit && bits+=( 8 )
use 10bit && bits+=( 16 )

if [[ ${MULTILIB_ABI_FLAG} == abi_x86_x32 ]]; then
build_asm=false
else
build_asm=$(usex asm true false)
fi

local emesonargs=(
-D bitdepths=$(IFS=,; echo "${bits[*]}")
-D build_asm=$build_asm
)
meson_src_configure
}

multilib_src_compile() {
eninja
}

multilib_src_install() {
DESTDIR="${D}" eninja install
}

0 comments on commit a1bbe9f

Please sign in to comment.