Skip to content

Commit

Permalink
app-emacs/auctex: Version bump.
Browse files Browse the repository at this point in the history
Bug: 605388

Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
ulm committed Jan 11, 2017
1 parent 39be8db commit a1ce8c3
Show file tree
Hide file tree
Showing 2 changed files with 61 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-emacs/auctex/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST auctex-11.88.tar.gz 1302836 SHA256 716867d5fbcc5c67cca781d7c1984e6a3a6d5da056ec3b4f35170805bf4dc83f SHA512 30c422b52b3fc698e453ada9643038dd30978f6b1a99f5118a53ae5b939d63246adcb1937f0e5c4cf166477dca78fa17d721402a90c833c9e91d75072ae0f67d WHIRLPOOL fa348913637bf6062184873f50c6988aa1afdd7e4a456acfb139d704de9769480503e796716a632e9769f7d3f68d70e6e42a739ae8742857fcf6390baec156d6
DIST auctex-11.89.tar.gz 1332904 SHA256 98af296907b371083289a8b35bd6ff24cfd8fafb013033b724aacb5fe774c9b1 SHA512 a78ddefb46c1eb271646f3c4e723f49a913e391eb58263df3d3de272bc1ad5b70c0a9de682f28124aa5a48b36c030b3e83425667ee1a1973a054ff03ef1d8be9 WHIRLPOOL 6d8614961ddf95c764ac5f4dc8ce63bc265ddf2b8a33ee827594930b6239217f8818fffa4b30a204f8c2cf16d127c3ae97bd8d24421ce1f5254deb3f833e9e8a
DIST auctex-11.90.tar.gz 1437331 SHA256 3c232fd8e57780edea28cd3035afcc2b6ed965b5954e96b34a258cacfcaaf18f SHA512 b90b246a6193570897102d8f95396b35c8b899fc594446f2455469b9c58ca8fd1dafbb852c6f167fd8500261f007c8a66531bb04582d7a5c4a50a15933b70c83 WHIRLPOOL a8f42017cfa80ec3b21127068338f89526e584ea3cce0a92214fb40386fa82d4465f9514da62fc55edefa7ff3914d5dd5ee77d0cf7e4b0cecf93716f5f94f2f6
60 changes: 60 additions & 0 deletions app-emacs/auctex/auctex-11.90.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,60 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit elisp

DESCRIPTION="Extended support for (La)TeX, Texinfo and BibTeX files"
HOMEPAGE="https://www.gnu.org/software/auctex/"
SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"

LICENSE="GPL-3+ FDL-1.3+"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
IUSE="preview-latex"

DEPEND="virtual/latex-base
preview-latex? (
app-text/dvipng
app-text/ghostscript-gpl
)"
RDEPEND="${DEPEND}"

TEXMF="/usr/share/texmf-site"

src_configure() {
EMACS_NAME=emacs EMACS_FLAVOR=emacs econf --disable-build-dir-test \
--with-auto-dir="${EPREFIX}/var/lib/auctex" \
--with-lispdir="${EPREFIX}${SITELISP}/${PN}" \
--with-packagelispdir="${EPREFIX}${SITELISP}/${PN}" \
--with-packagedatadir="${EPREFIX}${SITEETC}/${PN}" \
--with-texmf-dir="${EPREFIX}${TEXMF}" \
--docdir="${EPREFIX}/usr/share/doc/${PF}" \
$(use_enable preview-latex preview)
}

src_compile() {
export VARTEXFONTS="${T}"/fonts
emake
}

src_install() {
emake -j1 DESTDIR="${D}" install
elisp-site-file-install "${FILESDIR}/50${PN}-gentoo.el"
if use preview-latex; then
elisp-site-file-install "${FILESDIR}/60${PN}-gentoo.el"
fi
dodoc ChangeLog* CHANGES FAQ INSTALL PROBLEMS.preview README RELEASE TODO
}

pkg_postinst() {
use preview-latex && texmf-update
elisp-site-regen
}

pkg_postrm(){
use preview-latex && texmf-update
elisp-site-regen
}

0 comments on commit a1ce8c3

Please sign in to comment.