Skip to content

Commit

Permalink
dev-cpp/nlohmann_json: version bump to 3.6.1
Browse files Browse the repository at this point in the history
Signed-off-by: Tim Harder <[email protected]>
  • Loading branch information
radhermit committed Apr 11, 2019
1 parent 66eaaa2 commit a1de934
Show file tree
Hide file tree
Showing 2 changed files with 36 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-cpp/nlohmann_json/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST nlohmann_json-3.5.0.tar.gz 114796008 BLAKE2B 94caa0374be1d38230cb13b8cd9deb3da04e4b81d361ce6baf54c1bad231945a94df74683a31660dc98413dbf23ea7596c6ed1da9cda9e02add7d7c6568973e3 SHA512 e2874e10e12070e8e1b9c01f41ce24002a3859c4aca8bf46083ea08e68f44ed6725bdcdf8e592b1e50d69975d506836c62a8e10fc6da00f0844c149dd6676996
DIST nlohmann_json-3.6.1.tar.gz 118862808 BLAKE2B 257508b33480741bd4438fe928869c0744a5e84806fa4e068b048bfc0e665802a45f31bc740c14f74e7a0384df18b9bba58a0e001750b1a800ea00cd1712b280 SHA512 e0565ccdee34e89a6836a97f039c04a0bac445b44f6f323918ea424b34e4577688a4f4f72d5ef1ec0b53d159bfe87e8e9c97b70ef98231ea463f59f05e16eb2a
35 changes: 35 additions & 0 deletions dev-cpp/nlohmann_json/nlohmann_json-3.6.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit meson

DESCRIPTION="JSON for Modern C++"
HOMEPAGE="https://github.com/nlohmann/json https://nlohmann.github.io/json/"
SRC_URI="https://github.com/nlohmann/json/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
IUSE="doc"

DEPEND="doc? ( app-doc/doxygen )"

DOCS=( ChangeLog.md README.md )

S=${WORKDIR}/json-${PV}

src_compile() {
meson_src_compile
use doc && emake -C doc
}

src_test() {
emake check
}

src_install() {
meson_src_install
use doc && dodoc -r doc/html
}

0 comments on commit a1de934

Please sign in to comment.