Skip to content

Commit

Permalink
games-arcade/blobby: EAPI-7 bump, switch to cmake, fix dependencies
Browse files Browse the repository at this point in the history
Package depends on media-libs/libsdl2, not media-libs/libsdl.

Dropping media-libs/libsdl2[X] USE-dep on request of games proj.

Closes: https://bugs.gentoo.org/606780
Package-Manager: Portage-3.0.0, Repoman-2.3.23
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Jul 22, 2020
1 parent bab757c commit a2047e6
Showing 1 changed file with 41 additions and 0 deletions.
41 changes: 41 additions & 0 deletions games-arcade/blobby/blobby-1.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit cmake desktop

DESCRIPTION="Beach ball game with blobs of goo"
HOMEPAGE="https://sourceforge.net/projects/blobby/"
SRC_URI="mirror://sourceforge/${PN}/${PN}2-linux-${PV}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

RDEPEND="
>=dev-games/physfs-2[zip]
media-libs/libsdl2[sound,joystick,opengl,video]
virtual/opengl
"
DEPEND="${RDEPEND}
dev-libs/boost
"
BDEPEND="
app-arch/zip
virtual/pkgconfig
"

PATCHES=(
"${FILESDIR}"/${P}-compile.patch
"${FILESDIR}"/${P}-paths.patch
"${FILESDIR}"/${P}-install.patch
)

src_install() {
cmake_src_install

newicon data/Icon.bmp ${PN}.bmp
make_desktop_entry ${PN} "Blobby Volley" /usr/share/pixmaps/${PN}.bmp
}

0 comments on commit a2047e6

Please sign in to comment.