forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-python/arrow: Bump to 0.15.5, py3.8
Signed-off-by: Michał Górny <[email protected]>
- Loading branch information
Showing
3 changed files
with
70 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST arrow-0.13.1.tar.gz 148509 BLAKE2B 7a47f8886cc2f50f6dda682daab37c599aad15c7e4a0c76b1324f9fe3a1b8168e3a2b29352bdc9c4daf0fa3b3843fa919d5256997c673bcb24ca033312242b60 SHA512 4933e02fe4ef7a632d55e5c6d2cbcefe6840467c809e0377be92f02d0dc10b5b2421cea2be7ddd5158236ec80f44848125253bfeef5a2ae635a3b9c5761fa105 | ||
DIST arrow-0.15.5.tar.gz 82264 BLAKE2B 2091e16921a5f9f944de3f25ce853b50973d970d982b880fafa75ee37f98110dde05bfd02bb8ce27518ed17600e5bcfb8602c353d7e3af249aa4bfc4b642356d SHA512 cb147a1f2976e6cedddbf2d2d0d5ce69a4a609d4c0c3d68f96b317fc2af334552cb0c1a94aa5bb38e6d74ca7e1beab1ae8a325920a15efd79c35835c92df2409 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,30 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
PYTHON_COMPAT=( python3_{6,7,8} ) | ||
|
||
inherit distutils-r1 | ||
|
||
DESCRIPTION="Better dates and times for Python" | ||
HOMEPAGE="https://github.com/crsmithdev/arrow/" | ||
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~arm64 ~x86" | ||
|
||
RDEPEND=" | ||
dev-python/python-dateutil[${PYTHON_USEDEP}]" | ||
|
||
BDEPEND=" | ||
test? ( | ||
dev-python/chai[${PYTHON_USEDEP}] | ||
dev-python/simplejson[${PYTHON_USEDEP}] | ||
)" | ||
|
||
distutils_enable_tests setup.py | ||
|
||
PATCHES=( | ||
"${FILESDIR}"/arrow-0.15.5-remove-dateparser.patch | ||
) |
39 changes: 39 additions & 0 deletions
39
dev-python/arrow/files/arrow-0.15.5-remove-dateparser.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,39 @@ | ||
From 00b34547e99259eda92d7bd1ca406e74693d6861 Mon Sep 17 00:00:00 2001 | ||
From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <[email protected]> | ||
Date: Sun, 19 Apr 2020 18:30:20 +0200 | ||
Subject: [PATCH] Remove test requiring dateparser | ||
|
||
--- | ||
tests/factory_tests.py | 9 --------- | ||
1 file changed, 9 deletions(-) | ||
|
||
diff --git a/tests/factory_tests.py b/tests/factory_tests.py | ||
index abdd0d0..65fa1bb 100644 | ||
--- a/tests/factory_tests.py | ||
+++ b/tests/factory_tests.py | ||
@@ -2,7 +2,6 @@ | ||
import time | ||
from datetime import date, datetime | ||
|
||
-import dateparser | ||
from chai import Chai | ||
from dateutil import tz | ||
|
||
@@ -113,14 +112,6 @@ class GetTests(Chai): | ||
|
||
assertDtEqual(self.factory.get(tz.gettz("US/Pacific")), self.expected) | ||
|
||
- # regression test for issue #658 | ||
- def test_one_arg_dateparser_datetime(self): | ||
- expected = datetime(1990, 1, 1).replace(tzinfo=tz.tzutc()) | ||
- # dateparser outputs: datetime.datetime(1990, 1, 1, 0, 0, tzinfo=<StaticTzInfo 'UTC\+00:00'>) | ||
- parsed_date = dateparser.parse("1990-01-01T00:00:00+00:00") | ||
- dt_output = self.factory.get(parsed_date)._datetime.replace(tzinfo=tz.tzutc()) | ||
- self.assertEqual(dt_output, expected) | ||
- | ||
def test_kwarg_tzinfo(self): | ||
|
||
self.expected = ( | ||
-- | ||
2.26.1 | ||
|