Skip to content

Commit

Permalink
dev-php/pecl-haru: Revbump to drop php 5.5 dependencies
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.2
  • Loading branch information
Brian Evans committed Nov 28, 2016
1 parent 197a185 commit a241f29
Showing 1 changed file with 29 additions and 0 deletions.
29 changes: 29 additions & 0 deletions dev-php/pecl-haru/pecl-haru-1.0.4-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,29 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

USE_PHP="php5-6"

inherit php-ext-pecl-r3

DESCRIPTION="An interface to libharu, a PDF generator"

LICENSE="PHP-3.01"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="png zlib"

DEPEND="media-libs/libharu[png?,zlib?]"
RDEPEND="${DEPEND}"

src_configure() {
# config.m4 is broken checking paths, so we need to override it
local PHP_EXT_ECONF_ARGS=(
$(usex png '--with-png-dir=/usr' '')
$(usex zlib '--with-zlib-dir=/usr' '')
)

php-ext-source-r3_src_configure
}

0 comments on commit a241f29

Please sign in to comment.