Skip to content

Commit

Permalink
Revert "dev-ml/*: Remove := slot ops from || deps, #586304"
Browse files Browse the repository at this point in the history
This reverts commit 2d4ac68.

This commit is wrong in several aspects:
- Such changes should come with a revbump
- Removing := deps causes packages not to be rebuilt on upgrades, causing
  barely understandable build failures when upgrading, later on.
  Thanks to this commit, people that have installed those packages
  will likely experience those failures with the upcoming ocaml 4.03 unmask.
- This is a non maintainer commit where no discussion at all happened with the
  maintainers during the 3 days between bug report and mass commit.
  Such discussion could have prevented the above mentioned breakage.

Proper fix is to drop the backward compatibility part of the || () dep. This fix
was slowly moving forward whenever possible and noticed. Main blocker for this is
bug #463018 which requires taking extra care for not breaking the stable tree
nor needlessly preventing future stabilization of packages.
  • Loading branch information
aballier committed Jun 23, 2016
1 parent 62f1e5e commit a254987
Show file tree
Hide file tree
Showing 35 changed files with 67 additions and 67 deletions.
4 changes: 2 additions & 2 deletions dev-ml/camomile/camomile-0.8.4.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand All @@ -17,7 +17,7 @@ IUSE="debug +ocamlopt"

RDEPEND="
>=dev-lang/ocaml-3.10.2:=[ocamlopt?]
|| ( dev-ml/camlp4 <dev-lang/ocaml-4.02.0 )
|| ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )
"
DEPEND="${RDEPEND}"

Expand Down
4 changes: 2 additions & 2 deletions dev-ml/camomile/camomile-0.8.5.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand All @@ -17,7 +17,7 @@ IUSE="debug +ocamlopt"

RDEPEND="
>=dev-lang/ocaml-3.10.2:=[ocamlopt?]
|| ( dev-ml/camlp4 <dev-lang/ocaml-4.02.0 )
|| ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )
"
DEPEND="${RDEPEND}"

Expand Down
4 changes: 2 additions & 2 deletions dev-ml/comparelib/comparelib-109.60.00.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand All @@ -17,7 +17,7 @@ KEYWORDS="~amd64"
IUSE=""

DEPEND=">=dev-ml/type-conv-109.20.00:=
|| ( dev-ml/camlp4 <dev-lang/ocaml-4.02.0 )"
|| ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )"
RDEPEND="${DEPEND}"

DOCS=( "README.txt" )
4 changes: 2 additions & 2 deletions dev-ml/comparelib/comparelib-113.00.00.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand All @@ -16,7 +16,7 @@ KEYWORDS="~amd64"
IUSE=""

DEPEND=">=dev-ml/type-conv-109.20.00:=
|| ( dev-ml/camlp4 <dev-lang/ocaml-4.02.0 )"
|| ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )"
RDEPEND="${DEPEND}"

DOCS=( "README.txt" )
4 changes: 2 additions & 2 deletions dev-ml/deriving-ocsigen/deriving-ocsigen-0.3c.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand All @@ -16,7 +16,7 @@ KEYWORDS="~amd64"
IUSE="+ocamlopt type-conv"

DEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt?]
|| ( dev-ml/camlp4 <dev-lang/ocaml-4.02.0 )
|| ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )
type-conv? ( >=dev-ml/type-conv-108:= )"
RDEPEND="${DEPEND}"

Expand Down
4 changes: 2 additions & 2 deletions dev-ml/enumerate/enumerate-111.08.00.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand All @@ -19,7 +19,7 @@ IUSE=""

DEPEND="
>=dev-ml/type-conv-111.13:=
|| ( dev-ml/camlp4 <dev-lang/ocaml-4.02.0 )"
|| ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )"

RDEPEND="${DEPEND}"

Expand Down
4 changes: 2 additions & 2 deletions dev-ml/extlib/extlib-1.6.1.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand All @@ -12,7 +12,7 @@ SRC_URI="https://ocaml-extlib.googlecode.com/files/${P}.tar.gz"
LICENSE="LGPL-2.1"
DEPEND="
>=dev-lang/ocaml-3.10.2:=[ocamlopt?]
|| ( dev-ml/camlp4 <dev-lang/ocaml-4.02.0 )
|| ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )
"
RDEPEND="${DEPEND}"
SLOT="0/${PV}"
Expand Down
4 changes: 2 additions & 2 deletions dev-ml/faillib/faillib-111.17.00.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand All @@ -18,7 +18,7 @@ IUSE=""

DEPEND="
dev-ml/herelib:=
|| ( dev-ml/camlp4 <dev-lang/ocaml-4.02.0 )
|| ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )
"
RDEPEND="${DEPEND}"

Expand Down
4 changes: 2 additions & 2 deletions dev-ml/fieldslib/fieldslib-109.20.03.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand All @@ -20,7 +20,7 @@ KEYWORDS="~amd64"
IUSE=""

DEPEND=">=dev-ml/type-conv-${PV}:=
|| ( dev-ml/camlp4 <dev-lang/ocaml-4.02.0 )"
|| ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )"
RDEPEND="${DEPEND}"

DOCS=( "README.txt" )
Expand Down
4 changes: 2 additions & 2 deletions dev-ml/fieldslib/fieldslib-113.00.00.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand All @@ -19,7 +19,7 @@ KEYWORDS="~amd64"
IUSE=""

DEPEND=">=dev-ml/type-conv-${PV}:=
|| ( dev-ml/camlp4 <dev-lang/ocaml-4.02.0 )"
|| ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )"
RDEPEND="${DEPEND}"

DOCS=( "README.txt" )
Expand Down
4 changes: 2 additions & 2 deletions dev-ml/lablgl/lablgl-1.05.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand All @@ -19,7 +19,7 @@ RDEPEND="
x11-libs/libX11
virtual/opengl
virtual/glu
|| ( dev-ml/camlp4 <dev-lang/ocaml-4.02.0 )
|| ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )
glut? ( media-libs/freeglut )
tk? (
>=dev-lang/tcl-8.3:0=
Expand Down
4 changes: 2 additions & 2 deletions dev-ml/lablgtk/lablgtk-2.18.3.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand All @@ -22,7 +22,7 @@ RDEPEND=">=x11-libs/gtk+-2.10:2
>=x11-libs/gtkglarea-1.9:2 )
spell? ( app-text/gtkspell:2 )
sourceview? ( x11-libs/gtksourceview:2.0 )
|| ( dev-ml/camlp4 <dev-lang/ocaml-4.02.0 )
|| ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )
"
DEPEND="${RDEPEND}
virtual/pkgconfig"
Expand Down
4 changes: 2 additions & 2 deletions dev-ml/lablgtk/lablgtk-2.18.4.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand All @@ -22,7 +22,7 @@ RDEPEND=">=x11-libs/gtk+-2.10:2
>=x11-libs/gtkglarea-1.9:2 )
spell? ( app-text/gtkspell:2 )
sourceview? ( x11-libs/gtksourceview:2.0 )
|| ( dev-ml/camlp4 <dev-lang/ocaml-4.02.0 )
|| ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )
"
DEPEND="${RDEPEND}
virtual/pkgconfig"
Expand Down
4 changes: 2 additions & 2 deletions dev-ml/lwt/lwt-2.5.1.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand All @@ -21,7 +21,7 @@ DEPEND="react? ( >=dev-ml/react-1.2:= )
ssl? ( >=dev-ml/ocaml-ssl-0.4.0:= )
gtk? ( dev-ml/lablgtk:= dev-libs/glib:2 )
ppx? ( dev-ml/ppx_tools:= )
|| ( dev-ml/camlp4 <dev-lang/ocaml-4.02.0 )"
|| ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )"

RDEPEND="${DEPEND}
!<www-servers/ocsigen-1.1"
Expand Down
4 changes: 2 additions & 2 deletions dev-ml/lwt/lwt-2.5.2.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand All @@ -21,7 +21,7 @@ DEPEND="react? ( >=dev-ml/react-1.2:= )
ssl? ( >=dev-ml/ocaml-ssl-0.4.0:= )
gtk? ( dev-ml/lablgtk:= dev-libs/glib:2 )
ppx? ( dev-ml/ppx_tools:= )
|| ( dev-ml/camlp4 <dev-lang/ocaml-4.02.0 )"
|| ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )"

RDEPEND="${DEPEND}
!<www-servers/ocsigen-1.1"
Expand Down
4 changes: 2 additions & 2 deletions dev-ml/macaque/macaque-0.7.2.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand All @@ -16,6 +16,6 @@ KEYWORDS="~amd64"
IUSE=""

DEPEND=">=dev-ml/pgocaml-2.1:=
|| ( dev-ml/camlp4 <dev-lang/ocaml-4.02.0 )"
|| ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )"
RDEPEND="${DEPEND}"
DOCS=( Changelog README.md )
4 changes: 2 additions & 2 deletions dev-ml/ocaml-data-notation/ocaml-data-notation-0.0.11.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand All @@ -18,7 +18,7 @@ KEYWORDS="~amd64"
IUSE=""

RDEPEND=">=dev-ml/type-conv-108.07.01:=
|| ( dev-ml/camlp4 <dev-lang/ocaml-4.02.0 )"
|| ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )"
DEPEND="${RDEPEND}
test? ( >=dev-ml/ounit-2.0.0[ocamlopt?] dev-ml/ocaml-fileutils[ocamlopt?] )"

Expand Down
4 changes: 2 additions & 2 deletions dev-ml/ocaml-gettext/ocaml-gettext-0.3.5.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand All @@ -19,7 +19,7 @@ RDEPEND=">=dev-lang/ocaml-3.12.1:=
>=dev-ml/ocaml-fileutils-0.4.0:=
>=dev-ml/camomile-0.8.3:=
sys-devel/gettext
|| ( dev-ml/camlp4 <dev-lang/ocaml-4.02.0 )
|| ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )
"
DEPEND="${RDEPEND}
doc? ( app-text/docbook-xsl-stylesheets dev-libs/libxslt )
Expand Down
4 changes: 2 additions & 2 deletions dev-ml/ocamldsort/ocamldsort-0.16.0.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand All @@ -14,7 +14,7 @@ KEYWORDS="~amd64 ppc x86"
IUSE=""

DEPEND=">=dev-lang/ocaml-3.12:=
|| ( dev-ml/camlp4 <dev-lang/ocaml-4.02.0 )"
|| ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )"
RDEPEND="${DEPEND}"

src_compile() {
Expand Down
2 changes: 1 addition & 1 deletion dev-ml/ocamlnet/ocamlnet-3.7.7.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand Down
2 changes: 1 addition & 1 deletion dev-ml/ocamlnet/ocamlnet-4.0.4.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand Down
2 changes: 1 addition & 1 deletion dev-ml/ocamlnet/ocamlnet-4.1.1.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand Down
4 changes: 2 additions & 2 deletions dev-ml/optcomp/optcomp-1.6.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand All @@ -17,7 +17,7 @@ SLOT="0/${PV}"
KEYWORDS="~amd64"
IUSE=""

DEPEND="|| ( dev-ml/camlp4 <dev-lang/ocaml-4.02.0 )"
DEPEND="|| ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )"
RDEPEND="${DEPEND}"

DOCS=( CHANGES.md README.md )
4 changes: 2 additions & 2 deletions dev-ml/pa_bench/pa_bench-111.28.00.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand All @@ -19,7 +19,7 @@ IUSE=""

DEPEND=">=dev-ml/type-conv-109:=
dev-ml/pa_ounit:=
|| ( dev-ml/camlp4 <dev-lang/ocaml-4.02.0 )"
|| ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )"
RDEPEND="${DEPEND}"

S="${WORKDIR}/${MY_P}"
4 changes: 2 additions & 2 deletions dev-ml/pipebang/pipebang-110.01.00.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand All @@ -17,5 +17,5 @@ KEYWORDS="~amd64"
IUSE=""

DEPEND=">=dev-ml/type-conv-109.60:=
|| ( dev-ml/camlp4 <dev-lang/ocaml-4.02.0 )"
|| ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )"
RDEPEND="${DEPEND}"
4 changes: 2 additions & 2 deletions dev-ml/pomap/pomap-3.0.3.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand All @@ -13,7 +13,7 @@ HOMEPAGE="https://bitbucket.org/mmottl/pomap"
SRC_URI="https://bitbucket.org/mmottl/pomap/downloads/${P}.tar.gz"
LICENSE="LGPL-2.1-with-linking-exception"

DEPEND="|| ( dev-ml/camlp4 <dev-lang/ocaml-4.02.0 )"
DEPEND="|| ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )"
RDEPEND="${DEPEND}"
SLOT="0/${PV}"
KEYWORDS="amd64 ppc x86"
Expand Down
4 changes: 2 additions & 2 deletions dev-ml/pomap/pomap-3.0.5.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand All @@ -13,7 +13,7 @@ HOMEPAGE="http://mmottl.github.io/pomap/"
SRC_URI="https://github.com/mmottl/pomap/releases/download/v${PV}/${P}.tar.gz"
LICENSE="LGPL-2.1-with-linking-exception"

DEPEND="|| ( dev-ml/camlp4 <dev-lang/ocaml-4.02.0 )"
DEPEND="|| ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )"
RDEPEND="${DEPEND}"
SLOT="0/${PV}"
KEYWORDS="amd64 ppc x86"
Expand Down
4 changes: 2 additions & 2 deletions dev-ml/pxp/pxp-1.2.4.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand All @@ -20,7 +20,7 @@ DEPEND=">=dev-ml/pcre-ocaml-4.31:=
>=dev-ml/ulex-0.5:=
>=dev-ml/ocamlnet-0.98:=
>=dev-lang/ocaml-3.10.2:=[ocamlopt?]
|| ( dev-ml/camlp4 <dev-lang/ocaml-4.02.0 )"
|| ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )"
RDEPEND="${DEPEND}"

IUSE="examples +ocamlopt"
Expand Down
Loading

0 comments on commit a254987

Please sign in to comment.