forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: portage-2.2.26
- Loading branch information
Michael Sterrett
committed
Feb 11, 2016
1 parent
7d016a1
commit a26ed50
Showing
3 changed files
with
171 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST gcompris-14.12.tar.bz2 272767636 SHA256 bf0beafb03c0f4ffe05bbfcda54b91a5e8a034b5d813cb4492d6f59a21f9cdcf SHA512 b0948fcf303b335a231318dd57ef84d83cda7839e82542e5c4b9e794745561c24d64e7e76a96c63d1b0eb5a44377f2bf05b1d89f3bcab75dd2c32075e2ba5258 WHIRLPOOL 0d49a59e5fddd5e24e6e593ad53d99c7a8714b6b48dd2e3f776600366f61886c4ea15428f056cb8ae69e26024a88f3264814f80ce9e11e9d82d4f9d0adb8b056 | ||
DIST gcompris-15.02.tar.bz2 272847496 SHA256 c3e2f84f459d747b853b0424e366d0ce7b1f4ef00d660cdde5084712cf5c3ad4 SHA512 468ca9a3a4cfff78e34206c40e6aebfc79ba087dd1e87f96a8b9b2ae1149550791be16ca0776f11e6768dd4acb3caaae9e763ac9d941f1f09c7a3464e829e7af WHIRLPOOL 5b38bf16e061d9770e66573c81e4b3b0617d3cf2e0679919a06b628ff622d4b0e8585115b4084e51e674c57cf1f2a36472e3e66283a9ee3f78423eac998b5a24 | ||
DIST gcompris-15.10.tar.bz2 279959562 SHA256 6aba73e2a1db0f50d43a40ee1a4a2b9d62a96e68542971b555c9debd8f50fc38 SHA512 1915a6934f3111e871be2777ed88c8d15a3ddb85f0c16d92333b6ebcba0cbbe526e51e84ecc576021cd807a5d69bb9570dba481ddc925da9d4dd35a0075380fc WHIRLPOOL 3baeac6e632f621111d8db096ed1713df0297f7460902f23f52667d551b85da3b124c39af5977935f9c7d98e037faf168f51eae33d0063e4f8852bac190f9ebf |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,81 @@ | ||
--- gcompris-13.11.orig/Makefile.am | ||
+++ gcompris-13.11/Makefile.am | ||
@@ -7,7 +7,7 @@ | ||
# endif | ||
|
||
|
||
-icondir=$(datadir)/pixmaps | ||
+icondir=/usr/share/pixmaps | ||
icon_DATA = gcompris.png gcompris-edit.png | ||
|
||
if BUILD_MINGW32 | ||
@@ -15,7 +15,7 @@ | ||
Applications_in_files = | ||
Applications_DATA = | ||
else | ||
-Applicationsdir = $(datadir)/applications/ | ||
+Applicationsdir = /usr/share/applications/ | ||
Applications_in_files = gcompris.desktop.in gcompris-edit.desktop.in | ||
Applications_DATA = gcompris.desktop gcompris-edit.desktop | ||
endif | ||
--- gcompris-13.11.orig/configure.ac | ||
+++ gcompris-13.11/configure.ac | ||
@@ -57,7 +57,8 @@ | ||
gtk+-2.0 >= $GTK_REQUIRED \ | ||
librsvg-2.0 >= $LIBRSVG_REQUIRED \ | ||
libxml-2.0 >= $LIBXML_REQUIRED \ | ||
- gthread-2.0 ) | ||
+ gthread-2.0 \ | ||
+ gmodule-2.0 ) | ||
|
||
AC_SUBST(GCOMPRIS_CFLAGS) | ||
AC_SUBST(GCOMPRIS_LIBS) | ||
@@ -204,10 +205,8 @@ | ||
USE_DEBUG="$enableval", USE_DEBUG="no") | ||
if test "x$USE_DEBUG" == "xyes" ; then | ||
AC_DEFINE_UNQUOTED(DEBUG, 1, "Enable debug messages.") | ||
- CFLAGS="$CFLAGS $OSX_CFLAGS -Wall -g" | ||
-else | ||
- CFLAGS="$CFLAGS $OSX_CFLAGS -Wall -O2" | ||
fi | ||
+CFLAGS="$CFLAGS $OSX_CFLAGS -Wall" | ||
|
||
dnl disable activation code | ||
AC_ARG_ENABLE(disable-activation-code, | ||
@@ -336,21 +335,21 @@ | ||
fi | ||
else | ||
dnl Set PACKAGE_LOCALE_DIR in config.h. | ||
- AC_DEFINE_UNQUOTED(PACKAGE_LOCALE_DIR, "${myprefix}/${DATADIRNAME}/locale", [GCompris locale directory]) | ||
+ AC_DEFINE_UNQUOTED(PACKAGE_LOCALE_DIR, "/usr/share/locale", [GCompris locale directory]) | ||
|
||
dnl Set PACKAGE_DATA_DIR | ||
PACKAGE_DATA_DIR="boards" | ||
AC_SUBST(PACKAGE_DATA_DIR) | ||
- AC_DEFINE_UNQUOTED(PACKAGE_DATA_DIR, "${myprefix}/${DATADIRNAME}", [GCompris data directory]) | ||
+ AC_DEFINE_UNQUOTED(PACKAGE_DATA_DIR, "${datadir}", [GCompris data directory]) | ||
|
||
dnl Plugin Directory | ||
my_libdir=`eval echo "${libdir}"` | ||
- AC_DEFINE_UNQUOTED(PACKAGE_CLIB_DIR, "${my_libdir}", [Gcompris plugins directory]) | ||
+ AC_DEFINE_UNQUOTED(PACKAGE_CLIB_DIR, "${libdir}", [Gcompris plugins directory]) | ||
plugindir=$libdir/gcompris | ||
AC_SUBST(plugindir) | ||
|
||
dnl Python plugin Directory | ||
- PYTHON_PLUGIN_DIR="${myprefix}/${DATADIRNAME}/${PACKAGE}/python" | ||
+ PYTHON_PLUGIN_DIR="${datadir}/${PACKAGE}/python" | ||
AC_SUBST(PYTHON_PLUGIN_DIR) | ||
|
||
dnl System GCompris config directory | ||
--- gcompris-13.11.orig/src/gcompris/gcompris.c | ||
+++ gcompris-13.11/src/gcompris/gcompris.c | ||
@@ -1322,7 +1322,7 @@ | ||
properties->package_plugin_dir = g_strconcat(pkg_clib_dir, "/gcompris", NULL); | ||
properties->package_python_plugin_dir = g_strconcat(pkg_data_dir, "/gcompris/python", | ||
NULL); | ||
- properties->system_icon_dir = g_strconcat(pkg_data_dir, "/pixmaps", NULL); | ||
+ properties->system_icon_dir = g_strconcat("/usr/share", "/pixmaps", NULL); | ||
properties->menu_dir = g_strdup(properties->package_data_dir); | ||
g_free(pkg_data_dir); | ||
g_free(pkg_clib_dir); |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,89 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
PYTHON_COMPAT=( python2_7 ) | ||
PYTHON_REQ_USE="sqlite,threads" | ||
|
||
inherit autotools eutils python-single-r1 games | ||
|
||
DESCRIPTION="full featured educational application for children from 2 to 10" | ||
HOMEPAGE="http://gcompris.net/" | ||
SRC_URI="http://gcompris.net/download/${P}.tar.bz2" | ||
|
||
LICENSE="GPL-3+" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~ppc ~x86" | ||
IUSE="gstreamer" | ||
REQUIRED_USE="${PYTHON_REQUIRED_USE}" | ||
|
||
RDEPEND="x11-libs/gtk+:2 | ||
gnome-base/librsvg[gtk(+)] | ||
gstreamer? ( | ||
media-libs/gstreamer:0.10 | ||
media-libs/gst-plugins-good:0.10 | ||
media-plugins/gst-plugins-ogg:0.10 | ||
media-plugins/gst-plugins-alsa:0.10 | ||
media-plugins/gst-plugins-vorbis:0.10 ) | ||
!gstreamer? ( | ||
media-libs/sdl-mixer | ||
media-libs/libsdl:0 ) | ||
dev-libs/libxml2 | ||
dev-libs/popt | ||
virtual/libintl | ||
dev-db/sqlite:3 | ||
dev-python/pygtk[${PYTHON_USEDEP}]" | ||
DEPEND="${RDEPEND} | ||
gnome-base/gnome-common | ||
dev-perl/XML-Parser | ||
sys-devel/gettext | ||
sys-apps/texinfo | ||
app-text/texi2html | ||
virtual/pkgconfig" | ||
RDEPEND="${RDEPEND} | ||
media-gfx/tuxpaint | ||
sci-electronics/gnucap" | ||
|
||
pkg_setup() { | ||
python-single-r1_pkg_setup | ||
games_pkg_setup | ||
} | ||
|
||
src_prepare() { | ||
# Drop DEPRECATED flags, bug #387817 | ||
sed -i -e 's:-D[A-Z_]*DISABLE_DEPRECATED:$(NULL):g' \ | ||
src/gcompris/Makefile.am || die | ||
|
||
epatch "${FILESDIR}"/${P}-build.patch | ||
cp /usr/share/gettext/config.rpath . | ||
eautoreconf | ||
sed -i \ | ||
-e 's#^itlocaledir =.*$#itlocaledir = @localedir@#' \ | ||
po/Makefile.in.in || die | ||
|
||
# Fix desktop files | ||
sed -i \ | ||
-e '/Encoding/d' \ | ||
gcompris.desktop.in \ | ||
gcompris-edit.desktop.in || die | ||
} | ||
|
||
src_configure() { | ||
GNUCHESS="${GAMES_BINDIR}/gcompris-gnuchess" \ | ||
egamesconf \ | ||
--datarootdir="${GAMES_DATADIR}" \ | ||
--datadir="${GAMES_DATADIR}" \ | ||
--localedir=/usr/share/locale \ | ||
--infodir=/usr/share/info \ | ||
--with-python="${PYTHON}" \ | ||
$(use_enable !gstreamer sdlmixer) \ | ||
--enable-sqlite \ | ||
--enable-py-build-only | ||
} | ||
|
||
src_install() { | ||
default | ||
prune_libtool_files --modules | ||
prepgamesdirs | ||
} |