Skip to content

Commit

Permalink
app-i18n/zinnia: Fix gcc6 support, bug #594048 by milan hodoscek and …
Browse files Browse the repository at this point in the history
…Peter Levine.

Package-Manager: Portage-2.3.5, Repoman-2.3.2
  • Loading branch information
pacho2 committed Apr 4, 2017
1 parent 4f76169 commit a26ff10
Show file tree
Hide file tree
Showing 2 changed files with 15 additions and 1 deletion.
13 changes: 13 additions & 0 deletions app-i18n/zinnia/files/zinnia-0.06-gcc6.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,13 @@
diff --git a/old/trainer.cpp b/zinnia-0.06/trainer.cpp
index fdb044c..8b21e6c 100644
--- a/old/trainer.cpp
+++ b/zinnia-0.06/trainer.cpp
@@ -103,7 +103,7 @@ class TrainerImpl: public Trainer {
if (!fn) {
return false;
}
- x_.push_back(std::make_pair<std::string, FeatureNode *>(y, fn));
+ x_.push_back(std::make_pair(y, fn));
return true;
}

3 changes: 2 additions & 1 deletion app-i18n/zinnia/zinnia-0.06-r3.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2014 Gentoo Foundation
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5
Expand All @@ -18,6 +18,7 @@ DOCS=( AUTHORS ChangeLog NEWS README )
PATCHES=(
"${FILESDIR}/${P}-ricedown.patch"
"${FILESDIR}/${P}-perl.patch"
"${FILESDIR}/${P}-gcc6.patch"
)
AUTOTOOLS_AUTORECONF=yes

Expand Down

0 comments on commit a26ff10

Please sign in to comment.