Skip to content

Commit

Permalink
net-dns/nsd: Fixed build with USE="-ssl"
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/832213
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Jan 28, 2022
1 parent 9abd541 commit a27323c
Show file tree
Hide file tree
Showing 2 changed files with 25 additions and 1 deletion.
22 changes: 22 additions & 0 deletions net-dns/nsd/files/nsd-4.3.9-no_ssl.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,22 @@
From c5e6a8e5e566380c8c6731e9feb7ac686a1c0735 Mon Sep 17 00:00:00 2001
From: "W.C.A. Wijngaards" <[email protected]>
Date: Fri, 28 Jan 2022 16:38:53 +0100
Subject: [PATCH] - Fix #206: build with --without-ssl fails.

diff --git a/edns.c b/edns.c
index c7fc39d9..478ec681 100644
--- a/edns.c
+++ b/edns.c
@@ -21,6 +21,12 @@
#include "nsd.h"
#include "query.h"

+#if !defined(HAVE_SSL) || !defined(HAVE_CRYPTO_MEMCMP)
+/* we need fixed time compare, pull it in from tsig.c */
+#define CRYPTO_memcmp memcmp_fixedtime
+int memcmp_fixedtime(const void *s1, const void *s2, size_t n);
+#endif
+
void
edns_init_data(edns_data_type *data, uint16_t max_length)
{
4 changes: 3 additions & 1 deletion net-dns/nsd/nsd-4.3.9.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2021 Gentoo Authors
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
Expand Down Expand Up @@ -45,6 +45,8 @@ BDEPEND="
PATCHES=(
# Fix the paths in the munin plugin to match our install
"${FILESDIR}"/nsd_munin_.patch

"${FILESDIR}/${P}-no_ssl.patch" #832213
)

src_prepare() {
Expand Down

0 comments on commit a27323c

Please sign in to comment.