Skip to content

Commit

Permalink
app-misc/logiops: add 0.3.2
Browse files Browse the repository at this point in the history
Signed-off-by: Conrad Kostecki <[email protected]>
  • Loading branch information
ConiKost committed May 22, 2023
1 parent 605ffff commit a297435
Show file tree
Hide file tree
Showing 2 changed files with 78 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-misc/logiops/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST ipcgull-0.1.tar.gz 31909 BLAKE2B dc86ce909682e6683ed127eb0824c1dd031a2082879f02832005f4ee7157e89a584829d96d9656a984047fea27094f59591361b0a491cd07a9331a6fa9c2560b SHA512 04dc7305d0fc825fc701ff13bee44ed0606eaed29428d82e93c600efc8fba3cc47895ecd32d4ab9d045ca561161cce9f5bd30e87192e83916a433f4919454d76
DIST logiops-0.2.3.tar.gz 69321 BLAKE2B f188c39bcf4a9d386a34a97612fed45db1bf93858717d4c6fc4ba08a78acd1ae020cef875421d4131cdc3f0219c848c67b7793888ac13e064539ebea293b4afd SHA512 5a7b7e76a89759a30e25da6117992e96d0a1a0db25af3d524d725e753fb5ce5fc67c8a5bdeb8b707a81f99eadfc8f24035a3a5e4544b1153bdedd2373a65173d
DIST logiops-0.3.1.tar.gz 85535 BLAKE2B edef0ab57ee09d47cd6f0c214189c7b7afaa113ab882d7e3449a0818d4753250627671ad135748824de77680b63d113a64d8581571fdcaf2adbb5ed7c9a3885a SHA512 9b98b415fc3231066a51d3da780fd230f43a823316405eb4faba454b6fc5e3eb3b3b30cdeaf83126b848bfb267d4ff97ae8a19a9a76f48510f3af8fe3969bdab
DIST logiops-0.3.2.tar.gz 87067 BLAKE2B 0c938824c8c8f8e5a26fbdcb47a2f04ef0316e3750cb85425083e17d68ee23726d99ba6c811045201cebe1c1ef3e58f1bcec0512f599c487494841f2ac3aa9c0 SHA512 c69dbf6f220e57515a9641de83625b533943fc78197dc1abbd9767e22fe58e60a55eedb2e9510131cfcda4e9d4f304038be89a70c7c45238a1c7846047d8d59a
77 changes: 77 additions & 0 deletions app-misc/logiops/logiops-0.3.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,77 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

MY_PN_IPCGULL="ipcgull"
MY_PV_IPCGULL="0.1"

inherit cmake linux-info

DESCRIPTION="An unofficial userspace driver for HID++ Logitech devices"
HOMEPAGE="https://github.com/PixlOne/logiops"
SRC_URI="
https://github.com/PixlOne/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
https://github.com/PixlOne/${MY_PN_IPCGULL}/archive/refs/tags/v${MY_PV_IPCGULL}.tar.gz -> ${MY_PN_IPCGULL}-${MY_PV_IPCGULL}.tar.gz
"

LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="systemd"

DEPEND="
dev-libs/glib
dev-libs/libconfig:=[cxx]
dev-libs/libevdev
sys-apps/dbus
virtual/libudev
systemd? ( sys-apps/systemd )
"

RDEPEND="${DEPEND}"

BDEPEND="virtual/pkgconfig"

DOCS=( "README.md" "TESTED.md" )

PATCHES=( "${FILESDIR}/${MY_PN_IPCGULL}-0.1-gcc13.patch" )

pkg_pretend() {
local CHECK_CONFIG="~HID_LOGITECH ~HID_LOGITECH_HIDPP"

check_extra_config
}

src_unpack() {
default

# Submodule, which needs to be present for compilation
mv "${WORKDIR}/${MY_PN_IPCGULL}-${MY_PV_IPCGULL}" "${WORKDIR}/${MY_PN_IPCGULL}" || die
mv "${WORKDIR}/${MY_PN_IPCGULL}" "${S}/src" || die
}

src_configure() {
local mycmakeargs=( -DLOGIOPS_VERSION="${PV}" )

cmake_src_configure
}

src_install() {
default

cmake_src_install

# Install lib of submodule, as no install routine exist
dolib.so "${BUILD_DIR}/src/ipcgull/libipcgull.so"

insinto /etc
newins logid.example.cfg logid.cfg

newinitd "${FILESDIR}"/logid.initd logid
}

pkg_postinst() {
einfo "An example config file has been installed as /etc/logid.cfg."
einfo "See https://github.com/PixlOne/logiops/wiki/Configuration for more information."
}

0 comments on commit a297435

Please sign in to comment.