Skip to content

Commit

Permalink
media-gfx/arss: port to EAPI 7
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/707664
Package-Manager: Portage-3.0.9, Repoman-3.0.1
Signed-off-by: Jakov Smolic <[email protected]>
Signed-off-by: David Seifert <[email protected]>
  • Loading branch information
Jakov Smolic authored and SoapGentoo committed Nov 26, 2020
1 parent 7c1f5a1 commit a2e1a62
Show file tree
Hide file tree
Showing 2 changed files with 74 additions and 6 deletions.
13 changes: 7 additions & 6 deletions media-gfx/arss/arss-0.2.3-r1.ebuild
Original file line number Diff line number Diff line change
@@ -1,11 +1,11 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
EAPI=7
CMAKE_IN_SOURCE_BUILD="true"
MY_P=${P}-src
MY_P="${P}-src"

inherit cmake-utils
inherit cmake

DESCRIPTION="Analysis & Resynthesis Sound Spectrograph"
HOMEPAGE="http://arss.sourceforge.net"
Expand All @@ -14,11 +14,12 @@ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""

DEPEND="sci-libs/fftw:3.0="
RDEPEND="${DEPEND}"

S=${WORKDIR}/${MY_P}/src
S="${WORKDIR}/${MY_P}/src"

PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )

DOCS=( ../AUTHORS ../ChangeLog )
67 changes: 67 additions & 0 deletions media-gfx/arss/files/arss-0.2.3-fno-common.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,67 @@
--- a/arss.c
+++ b/arss.c
@@ -31,6 +31,7 @@ Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.*

char *version = "0.2.3";
char *date = "May 29th, 2008";
+extern int32_t quiet;

#define MSG_NUMBER_EXPECTED "A number is expected after %s\nExiting with error.\n"

--- a/dsp.c
+++ b/dsp.c
@@ -1,5 +1,12 @@
#include "dsp.h"

+double pi;
+double LOGBASE;
+double LOOP_SIZE_SEC;
+int32_t BMSQ_LUT_SIZE;
+int32_t clocka;
+
+
void fft(double *in, double *out, int32_t N, uint8_t method)
{
/* method :
--- a/dsp.h
+++ b/dsp.h
@@ -17,13 +17,13 @@
#define LOOP_SIZE_SEC_D 10.0
#define BMSQ_LUT_SIZE_D 16000

-double pi;
-double LOGBASE; // Base for log() operations. Anything other than 2 isn't really supported
+extern double pi;
+extern double LOGBASE; // Base for log() operations. Anything other than 2 isn't really supported
#define TRANSITION_BW_SYNT 16.0 // defines the transition bandwidth for the low-pass filter on the envelopes during synthesisation
-double LOOP_SIZE_SEC; // size of the noise loops in seconds
-int32_t BMSQ_LUT_SIZE; // defines the number of elements in the Blackman Square look-up table. It's best to make it small enough to be entirely cached
+extern double LOOP_SIZE_SEC; // size of the noise loops in seconds
+extern int32_t BMSQ_LUT_SIZE; // defines the number of elements in the Blackman Square look-up table. It's best to make it small enough to be entirely cached

-int32_t clocka;
+extern int32_t clocka;

extern void fft(double *in, double *out, int32_t N, uint8_t method);
extern void normi(double **s, int32_t xs, int32_t ys, double ratio);
--- a/util.c
+++ b/util.c
@@ -1,5 +1,7 @@
#include "util.h"

+int32_t quiet;
+
void win_return()
{
#ifdef WIN32
--- a/util.h
+++ b/util.h
@@ -11,7 +11,7 @@

#include "dsp.h"

-int32_t quiet;
+extern int32_t quiet;

extern void win_return();
extern int32_t gettime();

0 comments on commit a2e1a62

Please sign in to comment.