Skip to content

Commit

Permalink
media-gfx/argyllcms: version bump to 1.9.2, bug #597544
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.2
  • Loading branch information
voyageur committed Nov 2, 2016
1 parent 0a56796 commit a31d88c
Show file tree
Hide file tree
Showing 2 changed files with 95 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-gfx/argyllcms/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST Argyll_V1.7.0_src.zip 13935712 SHA256 dac51cf5d8f6d04bb02f2f5b119fa0e8b773a
DIST Argyll_V1.8.2_src.zip 13946428 SHA256 59bdfaeace35d2007c90fc53234ba33bf8a64cffc08f7b27a297fc5f85455377 SHA512 fb5a9fcfe558ce0593cc63d43751693dcaca8ed9dc202372bea5d8d54e19c004de0cb80382ffd2b570d9eeeb58584c7466b725d35377c72cbbde414625613d9c WHIRLPOOL 1a7f32f5ac203ae69773c8f40540aed4c2d36b1878ac7e7cc703df8809faa6ca086a249c1f20f5c2b8bb3db652add330b8a555dd34570c79b1da74cd5bb372ed
DIST Argyll_V1.8.3_src.zip 13933565 SHA256 60494176785f6c2e4e4daefb9452d83859880449040b2a843ed81de3bd0c558e SHA512 19bdba20313ec62b5b3c461d29a4f1eefbeb799ded06a1e0b568013b606547bf97b23c1b69f27d415e0052a7a2b747273131624e725ee21781b261568822b3a7 WHIRLPOOL d0f65bfdee48dcb29c887f371fe787aebac8c9577a1db0f386bb4a17e379ab99d2c0f94bc7474e753b3fd49548028928aeb48d9c0021b8ee5a76ab55575d5ce8
DIST Argyll_V1.9.1_src.zip 13497142 SHA256 5e910b1fafa53498747bee6128adfb1b4a2418801728ad466ebd65fa7fa29823 SHA512 28cc7f686a841a8ef6d6594b71a9a8c8be9370395fd1385abdc4b8388b699266966b21385056933670e233a085edbe9ee58cbe854f18c980408a89b45e807179 WHIRLPOOL 70592c405e584b186225a7c1427c94d73b45dfcfd1080f91b71583d044b77130d9531e3b30c7d9f24802539cc3a02ebba661c15af5229569183351134d29a7ef
DIST Argyll_V1.9.2_src.zip 13624924 SHA256 4d61ae0b91686dea721d34df2e44eaf36c88da87086fd50ccc4e999a58e9ce90 SHA512 f21fc2385b643dd6c32d1b1b0ab208a79ad8bc4319ac644d96e69ebc4c4e333d38b41e4516742816da9a91145e4f00bffb7f8b61a827859d5e14c1a8867b5a41 WHIRLPOOL 2b1bf8997a029bea711f42b7dec51c645834e7429430c6ad187a0b26f903ff58cfea27a072e28fb703be7ef2bcfa96d20f0f7ba6d1d809052eeb10d52013b430
94 changes: 94 additions & 0 deletions media-gfx/argyllcms/argyllcms-1.9.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,94 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit eutils flag-o-matic multiprocessing toolchain-funcs udev

MY_P="Argyll_V${PV}"

DESCRIPTION="Open source, ICC compatible color management system"
HOMEPAGE="http://www.argyllcms.com/"
SRC_URI="http://www.argyllcms.com/${MY_P}_src.zip"

LICENSE="AGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~x86"
IUSE="doc"

RDEPEND="
media-libs/tiff:0
sys-libs/zlib
virtual/jpeg:0
x11-libs/libX11
x11-libs/libXau
x11-libs/libXdmcp
x11-libs/libXext
x11-libs/libXinerama
x11-libs/libXrandr
x11-libs/libXxf86vm
x11-libs/libXScrnSaver"
DEPEND="${RDEPEND}
app-arch/unzip
dev-util/ftjam"

S="${WORKDIR}/${MY_P}"

PATCHES=(
"${FILESDIR}"/${PN}-1.8.0-gcc5.patch
)

src_compile() {
# Make it respect LDFLAGS
echo "LINKFLAGS += ${LDFLAGS} ;" >> Jamtop

# Evil hack to get --as-needed working. The build system unfortunately lists all
# the shared libraries by default on the command line _before_ the object to be built...
echo "STDLIBS += -ldl -lrt -lX11 -lXext -lXxf86vm -lXinerama -lXrandr -lXau -lXdmcp -lXss -ltiff -ljpeg ;" >> Jamtop

append-cflags -DUNIX -D_THREAD_SAFE

sed \
-e 's:CCFLAGS:CFLAGS:g' \
-e "s:ar rusc:$(tc-getAR) rusc:g" \
-i Jambase || die

tc-export CC RANLIB

jam -dx -fJambase "-j$(makeopts_jobs)" || die
}

src_install() {
jam -dx -fJambase install || die

rm bin/License.txt || die

pushd bin > /dev/null
local binname
for binname in * ; do
newbin ${binname} argyll-${binname}
done
popd > /dev/null

dodoc log.txt Readme.txt ttbd.txt notes.txt
if use doc; then
docinto html
dodoc doc/*html doc/*jpg doc/*gif
fi

insinto /usr/share/${PN}
doins -r ref

udev_dorules usb/55-Argyll.rules
}

pkg_postinst() {
elog "If you have a Spyder2 you need to extract the firmware"
elog "from the CVSpyder.dll of the windows driver package"
elog "and store it as /usr/share/color/spyd2PLD.bin"
echo
elog "For further info on setting up instrument access read"
elog "http://www.argyllcms.com/doc/Installing_Linux.html"
echo
}

0 comments on commit a31d88c

Please sign in to comment.