Skip to content

Commit

Permalink
media-libs/kcolorpicker: add 0.3.0
Browse files Browse the repository at this point in the history
Signed-off-by: Alexey Shvetsov <[email protected]>
  • Loading branch information
alexxy committed Feb 24, 2024
1 parent 8e99b60 commit a348750
Show file tree
Hide file tree
Showing 3 changed files with 48 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-libs/kcolorpicker/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST kColorPicker-0.2.0.tar.gz 12735 BLAKE2B 39b0c80ec5b498800dd251901b0bd57c839693f071185afacefa8d5a715ff18f2297c50486d98871471c40e0904a07ff40198b548d9368937b120a1eef07929f SHA512 44f9f317ebe5dd3131a9e44071f9f5b397b0d5cceece566f3ecf19932c8e36dafe1a434e623239421bead9413f0859bc3380174d7f14843770691e4d15a956eb
DIST kColorPicker-0.3.0.tar.gz 12998 BLAKE2B 18c8f36b3efe1fa3c4ae9fb0e9d7497393561d66287e7ce6b5139e0182ddc69866685a85f4794afb7c861fcb824bfebb4f3c4badf148b4c8aa8b88b7b3483db2 SHA512 9f370ad8de0f23116f513e14ca22cb368cb5eaea53484388ca5ca0b7abc81d5071379cb84f8128f806c9ffa051ad29a95e42d4c1d30ba93034c0ae9fd785bb8c
40 changes: 40 additions & 0 deletions media-libs/kcolorpicker/kcolorpicker-0.3.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,40 @@
# Copyright 2020-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

VIRTUALX_REQUIRED="test"
inherit cmake virtualx

MY_PN=kColorPicker
MY_P="${MY_PN}-${PV}"

DESCRIPTION="Qt based color picker with popup menu"
HOMEPAGE="https://github.com/ksnip/kColorPicker"
SRC_URI="https://github.com/ksnip/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"

LICENSE="LGPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
IUSE="test"

RDEPEND="
dev-qt/qtbase:6[gui,widgets]
"
DEPEND="${RDEPEND}
test? ( dev-qt/qtbase:6[test] )
"

S="${WORKDIR}/${MY_P}"

src_configure() {
local mycmakeargs=(
-DBUILD_TESTS=$(usex test)
-DBUILD_WITH_QT6=ON
)
cmake_src_configure
}

src_test() {
virtx cmake_src_test
}
7 changes: 7 additions & 0 deletions media-libs/kcolorpicker/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -9,8 +9,15 @@
<email>[email protected]</email>
<name>Proxy Maintainers</name>
</maintainer>
<maintainer type="project">
<email>[email protected]</email>
<name>Gentoo KDE Project</name>
</maintainer>
<longdescription lang="en">QToolButton with color popup menu with lets you
select a color. The popup features a color dialog button which can be
used to add custom colors to the popup menu.
</longdescription>
<upstream>
<remote-id type="github">ksnip/kColorPicker</remote-id>
</upstream>
</pkgmetadata>

0 comments on commit a348750

Please sign in to comment.