Skip to content

Commit

Permalink
app-metrics/snmp_exporter: Version bump to 0.11.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.40, Repoman-2.3.9
  • Loading branch information
mrueg committed Jun 13, 2018
1 parent ce46fc2 commit a36213c
Show file tree
Hide file tree
Showing 2 changed files with 51 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-metrics/snmp_exporter/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST snmp_exporter-0.10.0.tar.gz 3507371 BLAKE2B 8ad65ef8593e08fa1749013dcaf91e985df13ad12a988fb3691fed6436b979ce0edf668844240485437acbe5c19894dd52472e89dcff705a822dc633bde4d36a SHA512 70a1c6f1f3f89a68af71d6b1f2d6975c677e8c9470b9e1d5168c7fa9e60cacef808559b7d318c742704ab0358b7724e14d8583629747c118307381ba80d4bd6c
DIST snmp_exporter-0.11.0.tar.gz 3631252 BLAKE2B 9786a17d667f8e6d45691f9df099f67ce103fbb93c9069ca497e59ff9207de05335fe3fac56d3d3bc0617069eb26a9c5b5682a8ec65c78d7e44303002427e9fa SHA512 a5d671d1bf2a98bbdb6ff85ac84ca5fe8da8d075bb1133aae650e73c45770be0403bcfea93595b2f5bc75b2e50cf96ccada0407d6956b4b5d1dc5b7ff604254a
DIST snmp_exporter-0.9.0.tar.gz 3257207 BLAKE2B 3e7e91d7e66b32e3f84c9e53061f54ffc10116913b91598edfa011663daf2c67314661dbe6cd5b2c20b30968833bd64a48bdd5dd06694e76f1e787d59ad63933 SHA512 eb287f4519f2174a9ce80414c2b7a698bc50e1bcb2303a8190164002af088e0694e01233314cfe2bd89b2cd751f2fd6f8447eb641541701b7bd481373ce084b1
50 changes: 50 additions & 0 deletions app-metrics/snmp_exporter/snmp_exporter-0.11.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,50 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit user golang-build golang-vcs-snapshot

EGO_PN="github.com/prometheus/snmp_exporter"
EGIT_COMMIT="v${PV/_rc/-rc.}"
SNMP_EXPORTER_COMMIT="e459171"
ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"

DESCRIPTION="Prometheus exporter for snmp metrics"
HOMEPAGE="https://github.com/prometheus/snmp_exporter"
SRC_URI="${ARCHIVE_URI}"
LICENSE="Apache-2.0"
SLOT="0"
IUSE=""

DEPEND="dev-util/promu"

pkg_setup() {
enewgroup ${PN}
enewuser ${PN} -1 -1 -1 ${PN}
}

src_prepare() {
default
sed -i -e "s/{{.Revision}}/${SNMP_EXPORTER_COMMIT}/" src/${EGO_PN}/.promu.yml || die
}

src_compile() {
pushd src/${EGO_PN} || die
mkdir -p bin || die
GOPATH="${S}" promu build -v --prefix bin || die
popd || die
}

src_install() {
pushd src/${EGO_PN} || die
dobin bin/snmp_exporter
dodoc {README,CONTRIBUTING}.md
insinto /etc/snmp_exporter
newins snmp.yml snmp.yml.example
popd || die
keepdir /var/lib/snmp_exporter /var/log/snmp_exporter
fowners ${PN}:${PN} /var/lib/snmp_exporter /var/log/snmp_exporter
newinitd "${FILESDIR}"/${PN}.initd ${PN}
newconfd "${FILESDIR}"/${PN}.confd ${PN}
}

0 comments on commit a36213c

Please sign in to comment.