forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-util/include-what-you-use: version bump to match sys-devel/clang-3.7
* EAPI=6 * Fix typo in WEIRD_UPSTREAM_VERSION Package-Manager: portage-2.2.27
- Loading branch information
1 parent
accb30f
commit a37c771
Showing
2 changed files
with
33 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
32 changes: 32 additions & 0 deletions
32
dev-util/include-what-you-use/include-what-you-use-3.7.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,32 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
inherit cmake-utils flag-o-matic | ||
|
||
WEIRD_UPSTREAM_VERSION=0.5 | ||
|
||
DESCRIPTION="find unused include directives in C/C++ programs" | ||
HOMEPAGE="http://include-what-you-use.org/" | ||
SRC_URI="http://include-what-you-use.org/downloads/${PN}-${WEIRD_UPSTREAM_VERSION}.src.tar.gz -> ${P}.src.tar.gz" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
|
||
RDEPEND=">=sys-devel/llvm-3.7 | ||
>=sys-devel/clang-3.7 | ||
" | ||
DEPEND="${RDEPEND}" | ||
|
||
S=${WORKDIR}/${PN} | ||
|
||
src_configure() { | ||
append-libs -L$(llvm-config --libdir) | ||
|
||
local mycmakeargs=( | ||
-DLLVM_PATH=$(llvm-config --libdir) | ||
) | ||
cmake-utils_src_configure | ||
} |