Skip to content

Commit

Permalink
dev-python/certifi: bump to 2018.10.15
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.52, Repoman-2.3.12
Signed-off-by: Tomáš Mózes <[email protected]>
Signed-off-by: Thomas Deutschmann <[email protected]>
  • Loading branch information
hydrapolic authored and Whissi committed Dec 17, 2018
1 parent 6cec602 commit a3943d8
Show file tree
Hide file tree
Showing 2 changed files with 44 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/certifi/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST certifi-2018.10.15.tar.gz 145887 BLAKE2B 695b4236d67022f12639850fdcd169570330f9dd59aee165a39143d5dc5867b8685859bc48c8af07d41b7124970748ceb97cf1f7557563865e6b3293f668393b SHA512 3324ae6c4b99dda6f48aa9f0918fe045a19b19b26fcfdcca4be93ec967b9e4112d863c982686837b327f1663e308250d56ea337caeeeeb96579e08b20fca92df
DIST certifi-2018.4.16.tar.gz 149967 BLAKE2B 4a69ec495266d54032dfabc9c17d0b1e78ad1467214f9f981feb4fae279c1f4b5f0bc3f7a643c2229b17d19e32c1ea894dc16d73b036a0b32f17faa9ac55615c SHA512 96369b318df9592ed4ff48d79ae695f89d27d85e8f5de72548fccb19ac15b83a33fb8bc096a3092d7a7f5b201af08805576888418c7927cf48b892df56464682
DIST certifi-2018.8.24.tar.gz 146866 BLAKE2B 92a609bffd777a624d18e612e2fa504b1cd4f0764f979d22bf6785158fb928d30984fba16b839f6b4066395dadcca485e6215c6f0b6b550d891673a79ea77c08 SHA512 bb0af24570dd4806bc80cd438cae42db82f820de815a6148b184f58c19cd91a03f9275815559817a84220dcbd7c87a4a7d12e35cf4a95a1dbad286a1dfecf907
43 changes: 43 additions & 0 deletions dev-python/certifi/certifi-2018.10.15.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,43 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )

inherit distutils-r1 prefix readme.gentoo-r1

DESCRIPTION="Python package for providing Mozilla's CA Bundle"
HOMEPAGE="http://certifi.io/ https://pypi.org/project/certifi"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="MPL-2.0"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""

RDEPEND="app-misc/ca-certificates"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"

# Do not drop this patch -- this will affect system's security
PATCHES=( "${FILESDIR}"/certifi-2018.4.16-use-system-cacerts.patch )

python_prepare_all() {
distutils-r1_python_prepare_all

eprefixify certifi/core.py
}

python_install_all() {
distutils-r1_python_install_all

local DOC_CONTENTS="
In Gentoo, we don't use certifi's bundled CA certificates.
Instead we remove bundled cacert.pem and patch certifi
to return system's CA certificates.
"
readme.gentoo_create_doc

# Precaution -- nothing should use bundled CA certificates
find "${D}" -name 'cacert.pem' -delete || die "Failed to delete bundled CA certificates"
}

0 comments on commit a3943d8

Please sign in to comment.