Skip to content

Commit

Permalink
app-i18n/imhangul: call pkg-config via toolchain-funcs.eclass helper
Browse files Browse the repository at this point in the history
This ensures we call the correct pkg-config in e.g. cross.

Package-Manager: Portage-3.0.14-prefix, Repoman-3.0.2
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Apr 13, 2021
1 parent acc2679 commit a3955aa
Show file tree
Hide file tree
Showing 3 changed files with 9 additions and 9 deletions.
6 changes: 3 additions & 3 deletions app-i18n/imhangul/imhangul-2.1.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="6"

inherit gnome2-utils
inherit gnome2-utils toolchain-funcs

DESCRIPTION="GTK+ 2 Hangul Input Modules"
HOMEPAGE="https://github.com/libhangul/imhangul"
Expand All @@ -28,7 +28,7 @@ src_prepare() {
}

src_configure() {
econf --with-gtk-im-module-dir="${EPREFIX}"/usr/$(get_libdir)/gtk-2.0/$(pkg-config gtk+-2.0 --variable=gtk_binary_version)/immodules
econf --with-gtk-im-module-dir="${EPREFIX}"/usr/$(get_libdir)/gtk-2.0/$($(tc-getPKG_CONFIG) gtk+-2.0 --variable=gtk_binary_version)/immodules
}

src_install() {
Expand Down
6 changes: 3 additions & 3 deletions app-i18n/imhangul/imhangul-2.1.1.ebuild
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="6"

inherit gnome2-utils
inherit gnome2-utils toolchain-funcs

DESCRIPTION="GTK+ 2 Hangul Input Modules"
HOMEPAGE="https://github.com/libhangul/imhangul"
Expand All @@ -28,7 +28,7 @@ src_prepare() {
}

src_configure() {
econf --with-gtk-im-module-dir="${EPREFIX}"/usr/$(get_libdir)/gtk-2.0/$(pkg-config gtk+-2.0 --variable=gtk_binary_version)/immodules
econf --with-gtk-im-module-dir="${EPREFIX}"/usr/$(get_libdir)/gtk-2.0/$($(tc-getPKG_CONFIG) gtk+-2.0 --variable=gtk_binary_version)/immodules
}

src_install() {
Expand Down
6 changes: 3 additions & 3 deletions app-i18n/imhangul/imhangul-3.1.1.ebuild
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="6"

inherit gnome2-utils
inherit gnome2-utils toolchain-funcs

DESCRIPTION="GTK+ 3 Hangul Input Modules"
HOMEPAGE="https://github.com/libhangul/imhangul"
Expand All @@ -28,7 +28,7 @@ src_prepare() {
}

src_configure() {
econf --with-gtk-im-module-dir="${EPREFIX}"/usr/$(get_libdir)/gtk-3.0/$(pkg-config gtk+-3.0 --variable=gtk_binary_version)/immodules
econf --with-gtk-im-module-dir="${EPREFIX}"/usr/$(get_libdir)/gtk-3.0/$($(tc-getPKG_CONFIG) gtk+-3.0 --variable=gtk_binary_version)/immodules
}

src_install() {
Expand Down

0 comments on commit a3955aa

Please sign in to comment.