Skip to content

Commit

Permalink
dev-libs/light: bump to -r1; add dep on acct-group/video
Browse files Browse the repository at this point in the history
* Drop inherit on eutils and flag-o-matic

Closes: https://bugs.gentoo.org/757372
Signed-off-by: Aaron Bauman <[email protected]>
  • Loading branch information
FuzzyGophers committed Feb 14, 2021
1 parent e9cad09 commit a427ccc
Showing 1 changed file with 40 additions and 0 deletions.
40 changes: 40 additions & 0 deletions dev-libs/light/light-1.2.2-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,40 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit autotools udev

DESCRIPTION="A program to control backlights (and other hardware lights)"
HOMEPAGE="https://github.com/haikarainen/light"
SRC_URI="https://github.com/haikarainen/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"

IUSE="udev"

RDEPEND="acct-group/video"
DEPEND="udev? ( virtual/libudev:= )
${RDEPEND}"

src_prepare() {
eapply "${FILESDIR}/${P}-fcommon.patch"
eapply_user
eautoreconf
}

src_configure() {
local myeconfargs=(
$(usex udev --with-udev="/lib/udev/rules.d" "")
)

econf "${myeconfargs[@]}"
}

pkg_postinst() {
use udev && udev_reload

ewarn "To use light as a regular user you must be a part of the video group"
}

0 comments on commit a427ccc

Please sign in to comment.