forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: portage-2.2.18 Signed-off-by: Patrice Clement <[email protected]>
- Loading branch information
Showing
2 changed files
with
33 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST alien_8.89.tar.gz 64478 SHA256 35d237e3a08fb86ae83b1b6d941aa696e1dff5b5c8eb83fa818995f15527e4d8 SHA512 55e8b99900f7f940bb4e38469ca10f02be20a4fb097f3d66649e50ab4dfc11a3c8aeaacca862872c02c68c482e1967ea0b12302e9660fbc7d920591bcd4be9ca WHIRLPOOL 2d4025819c824ad1a218ae0b4ba5ed837f5c8d2b7b5aaf2e94c71b2ddb21c47e8054e3d1b83cdd30022123ffa2dea1e0d5423793617b812d14d9ffca99d37715 | ||
DIST alien_8.90.tar.gz 65014 SHA256 a520f0c6e1e0f8340712cc80a80b41d426b3034c41dfa256268f51beee3d75d7 SHA512 ca96a2b1039966f3bf5bc624cc9880d3426d9823ba8f8d8021c27bf1605b8072abbbf9befeb45e3210742cff51dff9beda9c636c592d230aac0e3c780ba2a83b WHIRLPOOL f88e2be871b04b98a4a495abd655ec09cb0c58c1aa5a7820da6986466ec61597bf243d42fbc871de6dd01cb29cb6f1a8a63798cf6ff8a6f8dd2eab0b7edc3ed3 | ||
DIST alien_8.93.tar.gz 65289 SHA256 deb4e0c590ea7c44f2bc806b2c4cde6abbef32017ae6d06ee30539ae28faf896 SHA512 bb38286b5b2000d0cceecc19a03ed65c40b31b48ce22d16ecf5f082883dac87822abdf2897edccd959429d45efb257d76d4f833c188e9f22b6f7cc526f80c0f9 WHIRLPOOL c6710d8582b882a0c963ad0dc6ee362c7e02a55384ddbe25ddc079d22878009c59274febeba4c038e4be707f2ea7f4d92a833eddb603bcde9da05cae5b804a09 | ||
DIST alien_8.94.tar.gz 65530 SHA256 c7a3a01f032107edf3428ccd44b895ffb5d607bccc885dc0da0aa278ccfe849c SHA512 dbc194ea19fdb28858efb5c55f66299d41c26d20235e941d98ee738c49200c2430ca382e8875850ca071598bc123a62519345678a6d9604c8ad5e0fd2a1922a7 WHIRLPOOL 4f1c441f06c7c0356ffb3851d22dea64e3001f5a6dc9563dbe2dac8de9ad1cf7c6b3f0c478b2369941378621ce524ea9d6c380afd08b0f2e0a0147c945271264 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,32 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
|
||
inherit perl-module | ||
|
||
DESCRIPTION="Converts between the rpm, dpkg, stampede slp, and slackware tgz file formats" | ||
HOMEPAGE="http://kitenet.net/programs/alien" | ||
SRC_URI="mirror://debian/pool/main/a/${PN}/${PN}_${PV}.tar.gz" | ||
|
||
LICENSE="LGPL-2.1" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~x86" | ||
IUSE="+bzip2" | ||
|
||
RDEPEND="app-arch/rpm | ||
app-arch/dpkg | ||
bzip2? ( | ||
app-arch/bzip2 | ||
) | ||
dev-util/debhelper | ||
>=app-arch/tar-1.14.91" | ||
DEPEND="${RDEPEND}" | ||
|
||
#S=${WORKDIR}/${PN} | ||
|
||
src_prepare() { | ||
sed -e s%'$(VARPREFIX)'%${D}% -e s%'$(PREFIX)'%${D}/usr%g \ | ||
-i "${S}"/Makefile.PL || die "sed failed." | ||
} |