Skip to content

Commit

Permalink
dev-python/awscli: bump to v1.16.300
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Thomas Deutschmann <[email protected]>
  • Loading branch information
Whissi committed Dec 11, 2019
1 parent 62ebf2d commit a4fb4e8
Show file tree
Hide file tree
Showing 2 changed files with 57 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/awscli/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -9,3 +9,4 @@ DIST awscli-1.16.261.tar.gz 1503153 BLAKE2B c507c37905e06d976b246f4636462d79184c
DIST awscli-1.16.278.tar.gz 1509613 BLAKE2B 71799c760f9396d18c86c1fd7da79a115ad8618cc7c0a7e7a57627d026f109c15023d35c743be38da816f30937ed8f43328f31cc61d1644200156aeb55799d2a SHA512 f84ba50ba7707007fc6c8af0eed2b152d20806632cb2b32d59e1a69812051a03aa4fd60c5a982439995d9f1ef746e50350d0129045e9305365ff957e74808e36
DIST awscli-1.16.283.tar.gz 1545412 BLAKE2B 98d72a103718def5d2678c36f7654bcb378a5e4df05d17bd545f8d981c571ae9c09412644e233848035041d3fc3fa7fff9dd5b2f98e92b1d1d0fe6897fb17c7e SHA512 5539a665c8997c1fa637bb9cc133888483becc9cd5fe424e8947a83d4448de376b0d7ee3a7a63d07f90c649c956a12f544646795cf4a8a12a09880a05da0d3d1
DIST awscli-1.16.292.tar.gz 1547260 BLAKE2B 3a1792f588b74826c847a78ee0e3db583d1932681256e36a78fe63b238e66e89a7f6cd4b2c8f7028ae3826506bca4d4e483adf48b7889c28732cbfd4d5640cc1 SHA512 f315ff5081865061168082ca74d87c9cbbd681f2b1d581a502f0b2bb3074e6cfa3eaaf9509d19986747677671b68bfbf4b48cb7a2ba1009e186bc85a7ff1664d
DIST awscli-1.16.300.tar.gz 1553269 BLAKE2B 7b22b58bc75bf522828b91b5d97872c9aedd35f3ee6ae29ccbdbfea7a3fc809b336f7abd7e512ab96e9d8ef9305c0ef6f32ae64d1d64920eee56d8f646b3d098 SHA512 78b398d1a19ac94ded67a1b2813cf16bd6b6e236e4207253884b228d7c16bd57b170a5262406bb57b4d17ac4610e9e5abdb5b68ceaed2c5bf094f445a757cd12
56 changes: 56 additions & 0 deletions dev-python/awscli/awscli-1.16.300.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,56 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"

PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )

inherit bash-completion-r1 distutils-r1

DESCRIPTION="Universal Command Line Environment for AWS"
HOMEPAGE="https://pypi.org/project/awscli/"
#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
SRC_URI="https://github.com/aws/aws-cli/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"
IUSE="test"

# requires network access
RESTRICT="test"

RDEPEND="
>=dev-python/botocore-1.13.36[${PYTHON_USEDEP}]
<dev-python/colorama-0.3.9.0[${PYTHON_USEDEP}]
dev-python/docutils[${PYTHON_USEDEP}]
<dev-python/rsa-3.5.0.0[${PYTHON_USEDEP}]
>=dev-python/s3transfer-0.2.0[${PYTHON_USEDEP}]
<dev-python/pyyaml-5.2.0[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}"

BDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
dev-python/mock[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
)
"

S="${WORKDIR}/aws-cli-${PV}"

python_test() {
nosetests -vv || die
}

python_install_all() {
newbashcomp bin/aws_bash_completer aws

insinto /usr/share/zsh/site-functions
newins bin/aws_zsh_completer.sh _aws

distutils-r1_python_install_all

rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
}

0 comments on commit a4fb4e8

Please sign in to comment.