Skip to content

Commit

Permalink
dev-libs/uriparser: 0.8.5
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.24, Repoman-2.3.6
  • Loading branch information
hartwork committed Feb 7, 2018
1 parent 2ebe49b commit a54c4e3
Show file tree
Hide file tree
Showing 2 changed files with 43 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/uriparser/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST uriparser-0.8.0.tar.bz2 433581 BLAKE2B 0f39f891634de86fe1696c5d000c6325203561347c83f3144fef2319c9dc58657d82b92bd8499efda15bfa966230f3c2ca4b9051caced0fe15c7e480e564ac86 SHA512 e80efc8484f0b67107cad317cef72db9de906a86020c3ab31178e06e958782f0a744fe257b1e6cd130dd25c6747e684ece93ce5f755864303df34c6b763d2e5b
DIST uriparser-0.8.4.tar.bz2 358408 BLAKE2B 1f270442a4812fa3e86a495109f95cfac6980c8145a701990dbe6f6396743de9ce0dfbce7b9cff2b331e8c9038a2b6c5281d2e562596543b660c168d3e678187 SHA512 b6238c6495eaa9f7178269d66dbea05a39c51c27137d8ebf39cd02d1c3fa96aa0d1608f5ccb36bf7b454f3238830dd46d7de8299b608f185b2520fc2c955aa1a
DIST uriparser-0.8.5.tar.bz2 359469 BLAKE2B 44fb7d8bd5dac8bb0dd68bfbc4fb2adec310a913a7ebb92850fb2b8833c159db7cb29fa4f8b5de3e3b3def018024d1e69a0814bcd12aa24b6a14deca6f6768fb SHA512 e9b0228092cf12b824975000b0a6dbe2e413d3642203666d77c5b42f04bc13e0ec3f61d6a2c44d9613bea15e8cf7ec42cc4c92c5bc4318ee3349c1b380409d5c
42 changes: 42 additions & 0 deletions dev-libs/uriparser/uriparser-0.8.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,42 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

DESCRIPTION="Uriparser is a strictly RFC 3986 compliant URI parsing library in C"
HOMEPAGE="https://uriparser.github.io/"
SRC_URI="https://github.com/${PN}/${PN}/releases/download/${P}/${P}.tar.bz2"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
IUSE="doc qt5 test unicode"

RDEPEND=""
DEPEND="virtual/pkgconfig
doc? ( >=app-doc/doxygen-1.5.8
qt5? ( dev-qt/qthelp:5 ) )
test? ( >=dev-util/cpptest-1.1.1 )"

REQUIRED_USE="test? ( unicode )"

DOCS=( AUTHORS ChangeLog THANKS )

src_configure() {
econf \
--disable-sizedown \
$(use_enable test) \
--enable-char \
$(use_enable unicode wchar_t) \
$(use_enable doc) \
--docdir=/usr/share/doc/${PF}/
}

src_install() {
default

if use doc && use qt5; then
dodoc doc/*.qch
docompress -x /usr/share/doc/${PF}/${P}.qch
fi
}

0 comments on commit a54c4e3

Please sign in to comment.