Skip to content

Commit

Permalink
dev-perl/Alien-Build: Bump to version 2.380.0
Browse files Browse the repository at this point in the history
Upstream:
- Add Alien::Build::Plugin::instance_id
- Add Alien::Build::plugin_instance_prop
- Add install properties: system_probe_class, system_probe_instance_id
- Add hook properties: probe_class, probe_instance_id
- Fix Probe/PkgConfig plugins accidentally providing compile/link flags
  when in mixed falure/success states.
- Fix tests that rely on an unset ALIEN_BUILD_PKG_CONFIG
- Avoid tripping array-dereference error in pkg-config CLI on windows
- Fix module name autogeneration for Test::Alien to avoid bugs with
  ExtUtils::CBuilder

Package-Manager: Portage-3.0.14, Repoman-3.0.2
Signed-off-by: Kent Fredric <[email protected]>
  • Loading branch information
kentfredric committed Jan 30, 2021
1 parent 8ff0e30 commit a55532c
Show file tree
Hide file tree
Showing 2 changed files with 52 additions and 0 deletions.
51 changes: 51 additions & 0 deletions dev-perl/Alien-Build/Alien-Build-2.380.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

DIST_AUTHOR=PLICEASE
DIST_VERSION=2.38
DIST_EXAMPLES=("example/*")
inherit perl-module

DESCRIPTION="Build external dependencies for use in CPAN"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
IUSE="minimal test zip"
RESTRICT="!test? ( test )"

# No, pkgconfig is not suspect, it actually uses it at runtime, and this module
# is somewhat a wrapper for pkgconfig :/
RDEPEND="
zip? ( dev-perl/Archive-Zip )
virtual/perl-Archive-Tar
>=dev-perl/Capture-Tiny-0.170.0
virtual/perl-Digest-SHA
virtual/perl-ExtUtils-CBuilder
>=virtual/perl-ExtUtils-MakeMaker-6.640.0
>=virtual/perl-ExtUtils-ParseXS-3.300.0
>=dev-perl/FFI-CheckLib-0.110.0
>=dev-perl/File-Which-1.100.0
dev-perl/File-chdir
virtual/perl-JSON-PP
>=dev-perl/Path-Tiny-0.77.0
>=virtual/perl-Scalar-List-Utils-1.330.0
>=virtual/perl-Test-Simple-1.302.96
>=virtual/perl-Text-ParseWords-3.260.0
virtual/pkgconfig
"
BDEPEND="${RDEPEND}
test? (
dev-perl/Devel-Hide
>=dev-perl/Test2-Suite-0.0.60
!minimal? (
dev-perl/Alien-Base-ModuleBuild
dev-perl/Sort-Versions
)
)
"
src_prepare() {
unset LD
[[ -n "${CCLD}" ]] && export LD="${CCLD}"
perl-module_src_prepare
}
1 change: 1 addition & 0 deletions dev-perl/Alien-Build/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST Alien-Build-2.23.tar.gz 310744 BLAKE2B 3bf3ce08be1e508a5eb695cc3ee71ccb70230c3fa0feb3e4378bbba35b7429ab3b852692ea4492e9aa80fdb962ef1fef7e82b654bbf8e8ca2428aa8f999944b8 SHA512 78a9b710dde488ce0852266340104f7b540e94ea58e8715d27e1e303a67956f862110bbd305119ac08fe9c5a20c0e5cc6fa5b6982abf830910f2d3a1ed9963fa
DIST Alien-Build-2.32.tar.gz 327696 BLAKE2B 9f0f2d31f6d3b2660ae4001ce1285bdf0a4eab6f542ad7e9165652302c645b5444e75aae65de2c24d79eb293615fd00fc61691d4db76be13dc8d48466a93a7ba SHA512 5c9c66076c7c6f30535401aea588a85ca51282df74f1bb4f4b21bff1aaea0d74220b278a123a00adc74c21a1aa528966db01a77f4783bd8aeea894fe97349d43
DIST Alien-Build-2.33.tar.gz 328283 BLAKE2B 2b793a65fdf08bb767cf96fd4e8eac2d56a7db46d15c87815c30247e26a2ce9bc44f5cf0f3ccf3c335e43b58182539a2b9858013fa32b37fc53c7c7a789e1219 SHA512 a3ce1f15480ef3bec902d7833651d618f0e8676b36ab65f034eb0699a44cc8376aeb2e32f1dac97f7c499aacd2f6464f21d3edc4b00301e8bef4235f9f4fd572
DIST Alien-Build-2.38.tar.gz 331770 BLAKE2B 13a688073ad6840e04a2c2191ae5974048e53127bcd7f15bfd658ef8c047fd0ecd990bd2f787dca0bf02fde48cc451a39ad5e41bd737f4ac36a64aae49aca226 SHA512 a77b27894c74e9b73fd479f3efb67c748bf9f32931a75471f6e5e0ccbb65d2e5617abfef28f71a7e461f4e1a4216fa8968564aa8ae52ff1bbeae570743fbab81

0 comments on commit a55532c

Please sign in to comment.