Skip to content

Commit

Permalink
dev-cpp/websocketpp: Fix cmake install path
Browse files Browse the repository at this point in the history
Revision bump adds patch by me to fix install paths.

Reported-by: Balint SZENTE <[email protected]>
Closes: https://bugs.gentoo.org/658096
Package-Manager: Portage-2.3.41, Repoman-2.3.9
  • Loading branch information
johu committed Jun 27, 2018
1 parent 5f2c980 commit a55bc34
Show file tree
Hide file tree
Showing 2 changed files with 67 additions and 0 deletions.
28 changes: 28 additions & 0 deletions dev-cpp/websocketpp/files/websocketpp-0.7.0-cmake-install.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,28 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f60caa1..9ff2211 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,13 +15,20 @@ set (WEBSOCKETPP_VERSION ${WEBSOCKETPP_MAJOR_VERSION}.${WEBSOCKETPP_MINOR_VERSIO

set_property(GLOBAL PROPERTY USE_FOLDERS ON)

+get_property(LIB64 GLOBAL PROPERTY FIND_LIBRARY_USE_LIB64_PATHS)
+if ("${LIB64}" STREQUAL "TRUE")
+ set(LIBSUFFIX 64)
+else()
+ set(LIBSUFFIX "")
+endif()
+
set(INSTALL_INCLUDE_DIR include CACHE PATH "Installation directory for header files")
+set(LIB_INSTALL_DIR "lib${LIB_SUFFIX}")
if (WIN32 AND NOT CYGWIN)
- set (DEF_INSTALL_CMAKE_DIR cmake)
+ set (INSTALL_CMAKE_DIR cmake)
else ()
- set (DEF_INSTALL_CMAKE_DIR lib/cmake/websocketpp)
+ set (INSTALL_CMAKE_DIR ${LIB_INSTALL_DIR}/cmake/websocketpp)
endif ()
-set (INSTALL_CMAKE_DIR ${DEF_INSTALL_CMAKE_DIR} CACHE PATH "Installation directory for CMake files")

# Make relative paths absolute (needed later on)
foreach (p INCLUDE CMAKE)
39 changes: 39 additions & 0 deletions dev-cpp/websocketpp/websocketpp-0.7.0-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,39 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit cmake-utils

DESCRIPTION="C++/Boost Asio based websocket client/server library"
HOMEPAGE="http://www.zaphoyd.com/websocketpp"
SRC_URI="https://github.com/zaphoyd/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc64 ~x86"
LICENSE="BSD"
SLOT="0"
IUSE="boost examples test"

DEPEND=""
RDEPEND="${DEPEND}
boost? ( dev-libs/boost )
"

# bug 630450
RESTRICT="test"

PATCHES=( "${FILESDIR}/${P}-cmake-install.patch" )

src_configure() {
local mycmakeargs=(
-DENABLE_CPP11="$(usex !boost)"
-DBUILD_TESTS="$(usex test)"
)

cmake-utils_src_configure
}

src_install() {
use examples && DOCS=( examples/ )
cmake-utils_src_install
}

0 comments on commit a55bc34

Please sign in to comment.