Skip to content

Commit

Permalink
dev-ada/libgpr: add 24.0.0
Browse files Browse the repository at this point in the history
Signed-off-by: Alfredo Tupone <[email protected]>
  • Loading branch information
atupone committed Feb 29, 2024
1 parent f9f2807 commit a594555
Show file tree
Hide file tree
Showing 2 changed files with 69 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ada/libgpr/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST gprbuild-23.0.0.tar.gz 952887 BLAKE2B a0de49e838dd41ca927d728dc2e7f23298bb3e7f865146ed6807e1da0f20fe9ce345d972ef93340f1a1fec91082ce14b575ad4e6642d759cb9d696602f291508 SHA512 d3b1af5295c0216eaa93e52b63ca51ceeaea324a3a3f40644e294f9048170f9294335e7e8ee2d77d99d4d9bb359267921632a01d43485d841b6e771143fb47a5
DIST gprbuild-24.0.0.tar.gz 959615 BLAKE2B c432b1f13a1aecb8f664aeb06694d86123268f29b43a50f5c7a48d7428c0b1c16f397e5a84c097aba04c7ee34011df119b154fd546ce156c999a54d159a84afb SHA512 09da4d54f2f151e9f9453e1a459533e2373eb5d4c51831be2bf90964ebcf653752de2f8b271c77f7b599f62146516fc60258ec3c96779fa2b52cd52979c6bd03
68 changes: 68 additions & 0 deletions dev-ada/libgpr/libgpr-24.0.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,68 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

ADA_COMPAT=( gnat_2021 gcc_12 gcc_13 )
inherit ada multiprocessing

MYPN=gprbuild
MYP=${MYPN}-${PV}

DESCRIPTION="Ada library to handle GPRbuild project files"
HOMEPAGE="http://libre.adacore.com/"
SRC_URI="https://github.com/AdaCore/${MYPN}/archive/refs/tags/v${PV}.tar.gz
-> ${MYP}.tar.gz"
LICENSE="GPL-3"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE="+shared static-libs static-pic"

RDEPEND="dev-ada/xmlada:=[shared?,static-libs?,static-pic?,${ADA_USEDEP}]"
DEPEND="${RDEPEND}
dev-ada/gprbuild[${ADA_USEDEP}]"
REQUIRED_USE="${ADA_REQUIRED_USE}
|| ( shared static-libs static-pic )"

S="${WORKDIR}"/${MYP}

PATCHES=( "${FILESDIR}"/${PN}-2020-gentoo.patch )

src_prepare() {
default
sed -i -e '/Library_Name/s|gpr|gnatgpr|' gpr/gpr.gpr || die
}

src_configure() {
emake setup
}

src_compile() {
build () {
gprbuild -p -m -j$(makeopts_jobs) -XBUILD=production -v \
-XLIBRARY_TYPE=$1 -XXMLADA_BUILD=$1 \
gpr/gpr.gpr -cargs:C ${CFLAGS} -cargs:Ada ${ADAFLAGS} || die
}
if use shared; then
build relocatable
fi
if use static-libs; then
build static
fi
if use static-pic; then
build static-pic
fi
}

src_install() {
if use static-libs; then
emake prefix="${D}"/usr libgpr.install.static
fi
for kind in shared static-pic; do
if use ${kind}; then
emake prefix="${D}"/usr libgpr.install.${kind}
fi
done
rm -r "${D}"/usr/share/gpr/manifests || die
einstalldocs
}

0 comments on commit a594555

Please sign in to comment.