Skip to content

Commit

Permalink
games-emulation/melonds: use system teakra
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/834984
Signed-off-by: Maciej Barć <[email protected]>
  • Loading branch information
xgqt committed Mar 13, 2022
1 parent b2b2659 commit a5a2748
Show file tree
Hide file tree
Showing 4 changed files with 38 additions and 24 deletions.
23 changes: 23 additions & 0 deletions games-emulation/melonds/files/melonds-system-teakra.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,23 @@
index 7288b54..6525f11 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -110,7 +110,6 @@ if (ENABLE_JIT)
endif()
endif()

-add_subdirectory(teakra EXCLUDE_FROM_ALL)
target_link_libraries(core teakra)


index c889aff..a6339d9 100644
--- a/src/DSi_DSP.cpp
+++ b/src/DSi_DSP.cpp
@@ -16,7 +16,7 @@
with melonDS. If not, see http://www.gnu.org/licenses/.
*/

-#include "teakra/include/teakra/teakra.h"
+#include "teakra/teakra.h"

#include "DSi.h"
#include "DSi_DSP.h"
Original file line number Diff line number Diff line change
@@ -1,9 +1,6 @@
# Copyright 2019-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

# NOTICE:
# melonds bundles teakra, its upstream haven't had a release since 2020

EAPI=8

MY_PN="melonDS"
Expand Down Expand Up @@ -32,6 +29,7 @@ SLOT="0"

DEPEND="
app-arch/libarchive
dev-libs/teakra
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtnetwork:5
Expand All @@ -55,7 +53,11 @@ DOC_CONTENTS="You need the following files in order to run melonDS:
Place them in ~/.config/melonDS
Those files can be found somewhere on the Internet ;-)"

PATCHES=( "${FILESDIR}"/melonds-system-teakra.patch )

src_prepare() {
rm -r ./src/teakra || die

cmake_src_prepare
}

Expand All @@ -73,16 +75,11 @@ src_compile() {
}

src_install() {
# install teakra
dolib.so "${BUILD_DIR}/src/teakra/src/libteakra.so"

cmake_src_install

readme.gentoo_create_doc
}

pkg_postinst() {
xdg_pkg_postinst

readme.gentoo_print_elog
}
Original file line number Diff line number Diff line change
@@ -1,9 +1,6 @@
# Copyright 2019-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

# NOTICE:
# melonds bundles teakra, its upstream haven't had a release since 2020

EAPI=8

MY_PN="melonDS"
Expand Down Expand Up @@ -32,6 +29,7 @@ SLOT="0"

DEPEND="
app-arch/libarchive
dev-libs/teakra
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtnetwork:5
Expand All @@ -55,7 +53,11 @@ DOC_CONTENTS="You need the following files in order to run melonDS:
Place them in ~/.config/melonDS
Those files can be found somewhere on the Internet ;-)"

PATCHES=( "${FILESDIR}"/melonds-system-teakra.patch )

src_prepare() {
rm -r ./src/teakra || die

cmake_src_prepare
}

Expand All @@ -73,16 +75,11 @@ src_compile() {
}

src_install() {
# install teakra
dolib.so "${BUILD_DIR}/src/teakra/src/libteakra.so"

cmake_src_install

readme.gentoo_create_doc
}

pkg_postinst() {
xdg_pkg_postinst

readme.gentoo_print_elog
}
13 changes: 5 additions & 8 deletions games-emulation/melonds/melonds-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,9 +1,6 @@
# Copyright 2019-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

# NOTICE:
# melonds bundles teakra, its upstream haven't had a release since 2020

EAPI=8

MY_PN="melonDS"
Expand Down Expand Up @@ -32,6 +29,7 @@ SLOT="0"

DEPEND="
app-arch/libarchive
dev-libs/teakra
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtnetwork:5
Expand All @@ -55,7 +53,11 @@ DOC_CONTENTS="You need the following files in order to run melonDS:
Place them in ~/.config/melonDS
Those files can be found somewhere on the Internet ;-)"

PATCHES=( "${FILESDIR}"/melonds-system-teakra.patch )

src_prepare() {
rm -r ./src/teakra || die

cmake_src_prepare
}

Expand All @@ -73,16 +75,11 @@ src_compile() {
}

src_install() {
# install teakra
dolib.so "${BUILD_DIR}/src/teakra/src/libteakra.so"

cmake_src_install

readme.gentoo_create_doc
}

pkg_postinst() {
xdg_pkg_postinst

readme.gentoo_print_elog
}

0 comments on commit a5a2748

Please sign in to comment.