forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
gnome-extra/gnome-shell-extension-dash-to-panel: Bump to v39
Package-Manager: Portage-3.0.3, Repoman-3.0.0 Signed-off-by: Pacho Ramos <[email protected]>
- Loading branch information
Showing
2 changed files
with
75 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST gnome-shell-extension-dash-to-panel-37.tar.gz 21116028 BLAKE2B 3e35f1f4b809f17e3971b708cdbed9f35a04cccbe651d804f101b70d1067310def60a7c8f6b2ebcf09087ed76a0214ce31e5560c8b8b4ef211bfa1f5befdbf79 SHA512 3f76ffc9e05ece7a96807815b229b6fb3fc391ec1b7ab35fb5db9fd61899f3c626a979f3d286f7f5ffb39890f9c99242c702d84d7690d0c9ee20b35a17e3303b | ||
DIST gnome-shell-extension-dash-to-panel-38.tar.gz 21122697 BLAKE2B 3db2de6ed6716996552ed4aa62e41d59fb94870ddb6415f891b99eed9c8caeb8cd8cd2eb7fa600af055b6a21f6ea457e27a507bf1518c25c0c7666fb4143fcb2 SHA512 f4c353e9557db173c37fdaf59246875f4ddcc08ce2a8963845df6718b13889cd4f2c0b66d1b0d5037591229f61bf99dedfca310688ada741a7dd6cc5bb20ffda | ||
DIST gnome-shell-extension-dash-to-panel-39.tar.gz 21123453 BLAKE2B 6cc5bc56368d1e65d601894251642fad1a28508b475a8abcd9566c0a5bd9e48677a98401fa1b263b4df6a0650442d253ab297bdfce5409feec96933fa1d3a67b SHA512 37ff633b3ab04024d65c25e42885e6e9f8b11f5d2e7516fefe7b8ae791b7beac62d7c7a2d5f88fbb8e69e28688f90e4b41cd4d330f381aa7b351e5603a14c007 | ||
DIST tango-gentoo-v1.1.tar.gz 29322 BLAKE2B 83fa2bf37727e60851dd679054fe1b153ebfea58c9a9a40f891f7d68d3b047b02e8effa1d1b4e08d64500a2072ce7200f159c92a352da7124de27e1b05bb6027 SHA512 87d47ddab68361db6d99866c51705dcb3e198f8345a1096859acf2c6cca5099dd23c7fb30d124f52c4933ea38fd45fadffbbe6ecbdfa84f5b60938a4824f9045 |
74 changes: 74 additions & 0 deletions
74
...e-extra/gnome-shell-extension-dash-to-panel/gnome-shell-extension-dash-to-panel-39.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,74 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
inherit gnome2-utils | ||
|
||
MY_PN="${PN/gnome-shell-extension-/}" | ||
MY_P="${MY_PN}-${PV}" | ||
DESCRIPTION="An icon taskbar for the Gnome Shell" | ||
HOMEPAGE="https://github.com/home-sweet-gnome/dash-to-panel" | ||
SRC_URI=" | ||
https://github.com/home-sweet-gnome/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz | ||
branding? ( https://www.mail-archive.com/[email protected]/msg00043/tango-gentoo-v1.1.tar.gz ) | ||
" | ||
|
||
LICENSE="GPL-2+" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="branding" | ||
|
||
COMMON_DEPEND="dev-libs/glib:2" | ||
RDEPEND="${COMMON_DEPEND} | ||
app-eselect/eselect-gnome-shell-extensions | ||
>=gnome-base/gnome-shell-3.18.0 | ||
" | ||
DEPEND="${COMMON_DEPEND}" | ||
BDEPEND=" | ||
dev-util/intltool | ||
sys-devel/gettext | ||
" | ||
|
||
S="${WORKDIR}/${MY_P}" | ||
|
||
PATCHES=( | ||
# Enable by default custom opacity to get panel slightly transparent | ||
# as was done in older Gnome versions | ||
"${FILESDIR}"/${PN}-26-opacity.patch | ||
) | ||
|
||
src_prepare() { | ||
default | ||
|
||
# Set correct version | ||
export VERSION="${PV}" | ||
|
||
# Don't install README and COPYING in unwanted locations | ||
sed -i -e 's/COPYING//g' -e 's/README.md//g' Makefile || die | ||
|
||
# Provide fancy Gentoo icon when requested | ||
use branding && eapply "${FILESDIR}"/${PN}-26-branding.patch | ||
} | ||
|
||
src_install() { | ||
default | ||
if use branding; then | ||
insinto /usr/share/gnome-shell/extensions/[email protected]/img | ||
doins "${WORKDIR}/tango-gentoo-v1.1/scalable/gentoo.svg" | ||
fi | ||
} | ||
|
||
pkg_preinst() { | ||
gnome2_schemas_savelist | ||
} | ||
|
||
pkg_postinst() { | ||
gnome2_schemas_update | ||
ebegin "Updating list of installed extensions" | ||
eselect gnome-shell-extensions update | ||
eend $? | ||
} | ||
|
||
pkg_postrm() { | ||
gnome2_schemas_update | ||
} |