Skip to content

Commit

Permalink
app-benchmarks/stress-ng: fix automagic
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/824050
Package-Manager: Portage-3.0.28, Repoman-3.0.3
Signed-off-by: Conrad Kostecki <[email protected]>
  • Loading branch information
ConiKost committed Nov 16, 2021
1 parent 4c1348e commit a5aca55
Show file tree
Hide file tree
Showing 2 changed files with 58 additions and 0 deletions.
3 changes: 3 additions & 0 deletions app-benchmarks/stress-ng/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -13,6 +13,9 @@
that exercise floating point, integer, bit manipulation and control flow
and over 20 virtual memory stress tests.
</longdescription>
<use>
<flag name="apparmor">Add support for AppArmor.</flag>
</use>
<upstream>
<bugs-to>https://github.com/ColinIanKing/stress-ng/issues</bugs-to>
<remote-id type="github">ColinIanKing/stress-ng</remote-id>
Expand Down
55 changes: 55 additions & 0 deletions app-benchmarks/stress-ng/stress-ng-0.13.06-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,55 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit linux-info toolchain-funcs

DESCRIPTION="Stress test for a computer system with various selectable ways"
HOMEPAGE="https://github.com/ColinIanKing/stress-ng"
SRC_URI="https://github.com/ColinIanKing/${PN}/archive/refs/tags/V${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
IUSE="apparmor sctp"

DEPEND="
dev-libs/libaio
dev-libs/libbsd
dev-libs/libgcrypt:0=
sys-apps/attr
sys-apps/keyutils:=
sys-libs/libcap
sys-libs/zlib
virtual/libcrypt:=
apparmor? (
sys-apps/apparmor-utils
sys-libs/libapparmor
)
sctp? ( net-misc/lksctp-tools )
"

RDEPEND="${DEPEND}"

DOCS=( "README.md" "README.Android" "TODO" "syscalls.txt" )

pkg_pretend() {
if use apparmor; then
CONFIG_CHECK="SECURITY_APPARMOR"
check_extra_config
fi
}

src_compile() {
tc-export CC

local myemakeopts=(
HAVE_APPARMOR="$(usex apparmor 1 0)"
HAVE_LIB_SCTP="$(usex sctp 1 0)"
MAN_COMPRESS="0"
VERBOSE="1"
)

emake "${myemakeopts[@]}"
}

0 comments on commit a5aca55

Please sign in to comment.