forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-sound/abcmidi: version bump to 2017.07.11
- Loading branch information
Showing
2 changed files
with
41 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST abcMIDI-2017.04.10.zip 549926 SHA256 7984ab285721fe9e822490bf19d428ccd267e4b88dd4364e26a89e1a2286e622 SHA512 899b0c8f57cbb2cd45461ab86511e4be4f8d8c2016b1c4da5096c1e5ad578bade83998ec2bee2b466ba08c364fb9fec2b7d762397525139e7aeada9410cc0dd5 WHIRLPOOL d122b8437cd36d100acd6195a2e71d47a767b6233d9eadcb5551231e4bef4d569289fcd51dd8fc84c0f877ecbc72d0b6fea04ce4f8f8945c3fef89cd74808f59 | ||
DIST abcMIDI-2017.04.19.zip 550879 SHA256 ed5c0e0cffb55a56fcf6cdbe037d819ad7028bc0822983f6988b5f78716447cc SHA512 e58ea0b859a9e9e93fedfc5ab64a040c1e4afa0c37fabca0a0f7f5bdb7e0f92276f689b5342b893ba05772a33a7235458d31605c4a2bd36402a8cfcda746cf28 WHIRLPOOL 004ff61954ffaa790380281ffe42ef3a1d3f0a9efb05f01df10273895f824bcba7bcf439a783adad071503453f12da208127c2ec03d73343aff695a2b462f212 | ||
DIST abcMIDI-2017.07.11.zip 552232 SHA256 7546606a7476e2016b45f449cf47588cc9223ef7010d083df5c09b92e987a6c5 SHA512 19e68eb6a4b7ce1845ccae2557ce55481bb5380d537d931a51cd298a35089eb96544e5837b1224e8bdff7d4dbcb187cfff4cc54e1c952b2b370807f15f002d5f WHIRLPOOL 545f7d1ca710db46d7c8c429632fe9f5cdf7e54b39bf222e195dc984c62a24d996cf37761d4f415554caeb6b373769452bbf720bf6641d06a8fbbbb301988b34 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,40 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
inherit autotools | ||
|
||
MY_P="abcMIDI-${PV}" | ||
DESCRIPTION="Programs for processing ABC music notation files" | ||
HOMEPAGE="http://ifdo.ca/~seymour/runabc/top.html" | ||
SRC_URI="http://ifdo.ca/~seymour/runabc/${MY_P}.zip" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="examples" | ||
|
||
DEPEND="app-arch/unzip" | ||
|
||
S=${WORKDIR}/${PN} | ||
|
||
src_prepare() { | ||
local PATCHES=( "${FILESDIR}"/${PN}-2016.05.05-docs.patch ) | ||
default | ||
|
||
rm configure makefile || die | ||
sed -i "s:-O2::" configure.ac || die | ||
|
||
eautoreconf | ||
} | ||
|
||
src_install() { | ||
default | ||
dodoc doc/{AUTHORS,CHANGES,abcguide.txt,abcmatch.txt,history.txt,readme.txt,yapshelp.txt} | ||
|
||
if use examples ; then | ||
docinto examples | ||
dodoc samples/*.abc | ||
fi | ||
} |