Skip to content

Commit

Permalink
games-arcade/emilia-pinball: port to EAPI 7, games.eclass--
Browse files Browse the repository at this point in the history
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Apr 5, 2021
1 parent 6fefd5c commit a5bc702
Show file tree
Hide file tree
Showing 5 changed files with 58 additions and 45 deletions.
Original file line number Diff line number Diff line change
@@ -1,43 +1,57 @@
# Copyright 1999-2018 Gentoo Foundation
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=5
inherit autotools eutils games
EAPI=7

inherit autotools desktop

MY_PN=${PN/emilia-/}
MY_P=${MY_PN}-${PV}
DESCRIPTION="SDL OpenGL pinball game"
HOMEPAGE="http://pinball.sourceforge.net/"
SRC_URI="mirror://sourceforge/pinball/${MY_P}.tar.gz"
S="${WORKDIR}"/${MY_P}

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

RDEPEND="virtual/opengl
x11-libs/libSM
RDEPEND="
dev-libs/libltdl:0
media-libs/libsdl[joystick,opengl,video,X]
media-libs/sdl-image[png]
media-libs/sdl-mixer[vorbis]
dev-libs/libltdl:0"
DEPEND="${RDEPEND}
x11-libs/libXt"
x11-libs/libICE
x11-libs/libSM
virtual/opengl
virtual/glu
"
DEPEND="
${DEPEND}
x11-libs/libXt
"

S=${WORKDIR}/${MY_P}
RDEPEND+=" acct-group/gamestat"

PATCHES=(
"${FILESDIR}"/${P}-glibc210.patch
"${FILESDIR}"/${P}-libtool.patch
"${FILESDIR}"/${P}-gcc46.patch
"${FILESDIR}"/${P}-parallel.patch
)

src_prepare() {
sed -i -e '/dnl/d' {src,test}/Makefile.am || die #334899
epatch "${FILESDIR}"/${P}-glibc210.patch \
"${FILESDIR}"/${P}-libtool.patch \
"${FILESDIR}"/${P}-gcc46.patch \
"${FILESDIR}"/${P}-parallel.patch
rm -rf libltdl
# bug #334899
sed -i -e '/dnl/d' {src,test}/Makefile.am || die

default

rm -rf libltdl || die
eautoreconf
}

src_configure() {
egamesconf --with-x
econf --with-x
}

src_compile() {
Expand All @@ -46,14 +60,17 @@ src_compile() {

src_install() {
default
dosym "${GAMES_BINDIR}"/pinball "${GAMES_BINDIR}"/emilia-pinball
mv "${D}/${GAMES_PREFIX}/include" "${D}/usr/" || die
dodir /usr/bin
mv "${D}/${GAMES_BINDIR}/pinball-config" "${D}/usr/bin/" || die

dosym pinball /usr/bin/emilia-pinball

sed -i \
-e 's:-I${prefix}/include/pinball:-I/usr/include/pinball:' \
"${D}"/usr/bin/pinball-config || die
"${ED}"/usr/bin/pinball-config || die

newicon data/pinball.xpm ${PN}.xpm
make_desktop_entry emilia-pinball "Emilia pinball"
prepgamesdirs

fperms -R 660 /var/games/pinball
fowners -R root:gamestat /var/games/pinball
fperms g+s /usr/bin/pinball
}
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- base/SignalSender.cpp.old 2011-04-26 09:39:24.303339444 +0200
+++ base/SignalSender.cpp 2011-04-26 09:39:51.261063162 +0200
--- a/base/SignalSender.cpp
+++ b/base/SignalSender.cpp
@@ -11,6 +11,7 @@
#include "SignalSender.h"
#include "Group.h"
Expand All @@ -8,8 +8,8 @@

SignalSender * SignalSender::p_SignalSender = NULL;

--- base/Behavior.cpp.old 2011-04-26 09:36:27.129006665 +0200
+++ base/Behavior.cpp 2011-04-26 09:36:48.855396752 +0200
--- a/base/Behavior.cpp
+++ b/base/Behavior.cpp
@@ -9,6 +9,7 @@
#include "Private.h"
#include "Behavior.h"
Expand All @@ -18,8 +18,8 @@

Behavior::Behavior() {
//EM_COUT("Behavior::Behavior", 1);
--- base/BehaviorVisitor.cpp.old 2011-04-26 09:37:39.759653248 +0200
+++ base/BehaviorVisitor.cpp 2011-04-26 09:37:54.481594952 +0200
--- a/base/BehaviorVisitor.cpp
+++ b/base/BehaviorVisitor.cpp
@@ -9,6 +9,7 @@
#include "BehaviorVisitor.h"
#include "Behavior.h"
Expand Down
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- base/Config.cpp
+++ base/Config.cpp
--- a/base/Config.cpp
+++ b/base/Config.cpp
@@ -423,8 +423,8 @@
m_sDataDir = string(EM_DATADIR) + "/";
m_sExeDir = "./";
Expand Down
Original file line number Diff line number Diff line change
@@ -1,6 +1,5 @@
diff -ur pinball-0.3.1.orig/configure.ac pinball-0.3.1/configure.ac
--- pinball-0.3.1.orig/configure.ac 2003-11-21 09:40:18.000000000 +0200
+++ pinball-0.3.1/configure.ac 2010-03-05 20:41:24.000000000 +0200
--- a/configure.ac
+++ b/configure.ac
@@ -14,18 +14,13 @@
CFLAGS="-g -W -Wall -O2"
CXXFLAGS="-g -W -Wall -O2"
Expand All @@ -22,9 +21,8 @@ diff -ur pinball-0.3.1.orig/configure.ac pinball-0.3.1/configure.ac

dnl *******************************************
dnl PATHS AND DIRS ****************************
diff -ur pinball-0.3.1.orig/Makefile.am pinball-0.3.1/Makefile.am
--- pinball-0.3.1.orig/Makefile.am 2003-12-10 12:15:35.000000000 +0200
+++ pinball-0.3.1/Makefile.am 2010-03-05 20:36:48.000000000 +0200
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,6 @@
AUTOMAKE_OPTIONS = gnu

Expand All @@ -33,9 +31,8 @@ diff -ur pinball-0.3.1.orig/Makefile.am pinball-0.3.1/Makefile.am

EXTRA_DIST = bootstrap pinball.spec clean pinball.desktop

diff -ur pinball-0.3.1.orig/src/Makefile.am pinball-0.3.1/src/Makefile.am
--- pinball-0.3.1.orig/src/Makefile.am 2003-11-20 18:46:17.000000000 +0200
+++ pinball-0.3.1/src/Makefile.am 2010-03-05 20:37:08.000000000 +0200
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -7,9 +7,9 @@

pinlib_LIBRARIES = libemilia_pin.a
Expand All @@ -48,9 +45,8 @@ diff -ur pinball-0.3.1.orig/src/Makefile.am pinball-0.3.1/src/Makefile.am
pinball_LDFLAGS = -export-dynamic

pinball_SOURCES = Pinball.cpp
diff -ur pinball-0.3.1.orig/test/Makefile.am pinball-0.3.1/test/Makefile.am
--- pinball-0.3.1.orig/test/Makefile.am 2003-11-20 18:46:17.000000000 +0200
+++ pinball-0.3.1/test/Makefile.am 2010-03-05 20:36:38.000000000 +0200
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -6,8 +6,8 @@
noinst_PROGRAMS = scale simple light texture load explode collision signal billboard font thread menu joy sound trans math misc varray unittest
dnl noinst_PROGRAMS = unittest
Expand Down
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- src/Makefile.am.old 2011-04-26 10:46:05.102070461 +0200
+++ src/Makefile.am 2011-04-26 10:46:16.872813136 +0200
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -9,7 +9,7 @@

INCLUDES = -I../base -I../addon
Expand Down

0 comments on commit a5bc702

Please sign in to comment.