forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
kde-frameworks: Add KDE Frameworks 5.67.0
Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <[email protected]>
- Loading branch information
Showing
166 changed files
with
3,199 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST attica-5.64.0.tar.xz 63756 BLAKE2B 85647959b8c4a908f272b619ba0f880e71f4eae170dad0d631df3ddca0574b266e7651a8514201d2a053cf789692e728c4a68edb3a68b65736075c51af5156f2 SHA512 a85f9bf62496b8878e77e40f101ae58371b09731d7be86eab0e5adbc0fac9c076d7f740b2dd4471e03105eadc16fc2de663a69f48caf3f5f96040789e6cd64bb | ||
DIST attica-5.66.0.tar.xz 64464 BLAKE2B fde12c546bb67ef3c888729cb51048fcde6424f0d0223f81b00cf6400d83235ac64b0378a112f515ed05cd2cfff0fa3e0ab4a2dd75396a62e2d7fd0640d93259 SHA512 817a996cfd0a39584e38f8beb50ddcf891ad48d03d28691c256b3c632b22a1f9c4a0a32fb422147118e5ab5a468bf7ed721baff4ed212418a1b3447b5611845c | ||
DIST attica-5.67.0.tar.xz 64580 BLAKE2B 8add0188c07192eb9dd0597c31410cc7f81f73ad588927622f5320dbeb0f5e8cabb88fef5cd854b75c8d0f45639804327d2f5ab2c617cb53b2601d936f0dc0ca SHA512 59965df4eea792563cb46fd6d6ae8604dff5547917ea22a0ae00659d692ec05851768f66860de15c37631f918c1b54fc07264e9df123da3235c5a43576105cd7 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,26 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
QTMIN=5.12.3 | ||
inherit ecm kde.org | ||
|
||
DESCRIPTION="Framework providing access to Open Collaboration Services" | ||
LICENSE="LGPL-2.1+" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86" | ||
IUSE="" | ||
|
||
RDEPEND=" | ||
>=dev-qt/qtnetwork-${QTMIN}:5 | ||
" | ||
DEPEND="${RDEPEND}" | ||
|
||
src_test() { | ||
# requires network access, bug #661230 | ||
local myctestargs=( | ||
-E "(providertest)" | ||
) | ||
|
||
ecm_src_test | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST baloo-5.64.0.tar.xz 277132 BLAKE2B d37a14721053f3396834d76e3855d9606af0bba042dd8b01933d1e004f659c9b739852c7e33eb2ca0abadf6ec99c4369a26d3c61047ac06f5d7d8d05079fb210 SHA512 c01fec2e01ed3b979a9309a5745822e8632e5034882fd62d0a16c2ff61b88351724d078257a2b7faf7ce306a658e9df6780cd18ceeda3e2c70cd7e4523f3d5f1 | ||
DIST baloo-5.66.0.tar.xz 271812 BLAKE2B b09c59da2e7611ec75a7cbe2d1c1fcf612cb40f20fe5530f97f29b55705369f0c70792839057c765cb42a90e39e97032c6fb9165d83835141e1cb25e434b6db2 SHA512 b402dda13e7b1972e32d673e837280745a57b39cd0bd54efff9ef20252f0114dae86816f7cb81c1e62bd5b324c9b539543e235cc8ef59080fd67d79cd024981a | ||
DIST baloo-5.67.0.tar.xz 273900 BLAKE2B 059ae680e887b5fcdbeb6d68c6760f035660919d727f2d46cf838e6426b0f83625faecbc754518e6968262ef3efb2fb9ea9852ab652e0d80629de9dc59db781f SHA512 065fb29c86e29a848c0bcac68851eb6b02b46e9f32269175a6d8cae80325dc619e020ac1c1f564998381a678d8918c1d7ddb81697e475663816eecb127831d5c |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,35 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
ECM_TEST="forceoptional" | ||
PVCUT=$(ver_cut 1-2) | ||
QTMIN=5.12.3 | ||
VIRTUALX_REQUIRED="test" | ||
inherit ecm kde.org | ||
|
||
DESCRIPTION="Framework for searching and managing metadata" | ||
LICENSE="LGPL-2+" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86" | ||
IUSE="" | ||
|
||
DEPEND=" | ||
>=dev-db/lmdb-0.9.17 | ||
>=dev-qt/qtdbus-${QTMIN}:5 | ||
>=dev-qt/qtdeclarative-${QTMIN}:5 | ||
>=dev-qt/qtgui-${QTMIN}:5 | ||
>=dev-qt/qtwidgets-${QTMIN}:5 | ||
=kde-frameworks/kconfig-${PVCUT}*:5 | ||
=kde-frameworks/kcoreaddons-${PVCUT}*:5 | ||
=kde-frameworks/kcrash-${PVCUT}*:5 | ||
=kde-frameworks/kdbusaddons-${PVCUT}*:5 | ||
=kde-frameworks/kfilemetadata-${PVCUT}*:5 | ||
=kde-frameworks/ki18n-${PVCUT}*:5 | ||
=kde-frameworks/kidletime-${PVCUT}*:5 | ||
=kde-frameworks/kio-${PVCUT}*:5 | ||
=kde-frameworks/solid-${PVCUT}*:5 | ||
" | ||
RDEPEND="${DEPEND}" | ||
|
||
RESTRICT+=" test" # bug 624250 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST bluez-qt-5.64.0.tar.xz 99428 BLAKE2B cb9f45ea6d9cbab8771ceb3bb000f1b6a0bd27d2593ff58ca3521ec4fd0a033fd9e65272fe88db13df93dd30f09bb69077b9b16ad35506868b9a44b2fae5c61f SHA512 87af161f863c4acda338f7ed44612204743f7d65fd1a58b9dc1bb009de63b79583ebc6c28ed867b8da0ec87261d3bd0f39dbb034425bdb19fd20c9c80f6fe27a | ||
DIST bluez-qt-5.66.0.tar.xz 100760 BLAKE2B b433a22f24e71324f35ea2ef447188a06088e0c0de025a4052ccf1f826b2b3328c498df013880069351c582c38674ffe4d665d8a408f2347c65e23561849ed8d SHA512 5ad94a860297ef785aa04c471ff9a56ed6238081ac4a0fad87a9439b93344d5196cb9e1df8a0c27293e59d6d48503a408826e5f00dadcf4880af00b94cb07fb5 | ||
DIST bluez-qt-5.67.0.tar.xz 100760 BLAKE2B 67420b4ed6e8109071caf4f5f350fcd83234e6f2ac91f73702027346c418d638eb3a26031646ac626ea97d59d10ece6ea16a0215e66ba76dd7c778edb87dec44 SHA512 a90f79960d22ff3fb939d09df226bb5ae8a66e93963b0ff73f6eafcf4d21d003b2e690843527bcfca66208f1e4c1da04d2bf368ce09ba2112a35c2af5cde2787 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,38 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
QTMIN=5.12.3 | ||
VIRTUALX_REQUIRED="test" | ||
inherit ecm kde.org udev | ||
|
||
DESCRIPTION="Qt wrapper for Bluez 5 DBus API" | ||
LICENSE="LGPL-2" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86" | ||
IUSE="" | ||
|
||
DEPEND=" | ||
>=dev-qt/qtdbus-${QTMIN}:5 | ||
>=dev-qt/qtdeclarative-${QTMIN}:5 | ||
>=dev-qt/qtnetwork-${QTMIN}:5 | ||
" | ||
RDEPEND="${DEPEND}" | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DUDEV_RULES_INSTALL_DIR="$(get_udevdir)/rules.d" | ||
) | ||
|
||
ecm_src_configure | ||
} | ||
|
||
src_test() { | ||
# parallel tests fail, bug 609248; managertest hangs, bug 668196 | ||
local myctestargs=( | ||
-j1 | ||
-E "(managertest)" | ||
) | ||
|
||
ecm_src_test | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST breeze-icons-5.64.0.tar.xz 2716900 BLAKE2B f12cfb9b505b010c0fb1cbba53f2f19a5eb5537f1393e1cb8ac6278763ae8c7dd2e67b7a888f924a315aa556aa2b58cd107f25fbda33765df78ffb3e071882bc SHA512 aa463370c330b4ff5f0b8de5f623de8b04de61bfc595e5bc227c1c323d264ab0b43dfa73b99ed356bef36b71ece9bac255f2bb1a39a8717f936dea8032645b2e | ||
DIST breeze-icons-5.66.0.tar.xz 2739092 BLAKE2B 4d1dacbff61bb53f7eacc2940d55bbe27ee60240205079c6599d7c7d54095b66e15e88c87e0d56f356df210761bd73e284c404d9e757540f97796d6ff8d43325 SHA512 3113dafe338b18a234b8b520d768b8d3e9d5773757f19abe2edda03353e44803cbaff54a67176dcf4b69658d7741dddd6300e3c660980b6d0b52725d862d725f | ||
DIST breeze-icons-5.67.0.tar.xz 2731080 BLAKE2B 9e8333c17ffc31d2ebd0b7f1b08712125f6904182ced3588bf97232ce93c1f4a96a7a1516666526ebeddb7ed9dec57e6657cb07da6939b3c1dd6b83f08a329ee SHA512 2b35f780888f21600230ed29b4e7d1f3b06981fb5f899f267a895d0d8a3aa3b85c915b3a262bf2864989202d0130fb7f79df76c1c856fdf7e97170b5a7ced9af |
35 changes: 35 additions & 0 deletions
35
kde-frameworks/breeze-icons-rcc/breeze-icons-rcc-5.67.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,35 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
KDE_ORG_NAME="breeze-icons" | ||
PVCUT=$(ver_cut 1-2) | ||
inherit cmake kde.org | ||
|
||
DESCRIPTION="Breeze SVG icon theme binary resource" | ||
LICENSE="LGPL-3" | ||
KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86" | ||
IUSE="test" | ||
|
||
BDEPEND=" | ||
dev-qt/qtcore:5 | ||
>=kde-frameworks/extra-cmake-modules-${PVCUT}:5 | ||
test? ( app-misc/fdupes ) | ||
" | ||
DEPEND="test? ( dev-qt/qttest:5 )" | ||
|
||
RESTRICT+=" !test? ( test )" | ||
|
||
src_prepare() { | ||
cmake_src_prepare | ||
use test || cmake_comment_add_subdirectory autotests | ||
} | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DBINARY_ICONS_RESOURCE=ON | ||
-DSKIP_INSTALL_ICONS=ON | ||
) | ||
cmake_src_configure | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST breeze-icons-5.64.0.tar.xz 2716900 BLAKE2B f12cfb9b505b010c0fb1cbba53f2f19a5eb5537f1393e1cb8ac6278763ae8c7dd2e67b7a888f924a315aa556aa2b58cd107f25fbda33765df78ffb3e071882bc SHA512 aa463370c330b4ff5f0b8de5f623de8b04de61bfc595e5bc227c1c323d264ab0b43dfa73b99ed356bef36b71ece9bac255f2bb1a39a8717f936dea8032645b2e | ||
DIST breeze-icons-5.66.0.tar.xz 2739092 BLAKE2B 4d1dacbff61bb53f7eacc2940d55bbe27ee60240205079c6599d7c7d54095b66e15e88c87e0d56f356df210761bd73e284c404d9e757540f97796d6ff8d43325 SHA512 3113dafe338b18a234b8b520d768b8d3e9d5773757f19abe2edda03353e44803cbaff54a67176dcf4b69658d7741dddd6300e3c660980b6d0b52725d862d725f | ||
DIST breeze-icons-5.67.0.tar.xz 2731080 BLAKE2B 9e8333c17ffc31d2ebd0b7f1b08712125f6904182ced3588bf97232ce93c1f4a96a7a1516666526ebeddb7ed9dec57e6657cb07da6939b3c1dd6b83f08a329ee SHA512 2b35f780888f21600230ed29b4e7d1f3b06981fb5f899f267a895d0d8a3aa3b85c915b3a262bf2864989202d0130fb7f79df76c1c856fdf7e97170b5a7ced9af |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,33 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
PVCUT=$(ver_cut 1-2) | ||
inherit cmake kde.org | ||
|
||
DESCRIPTION="Breeze SVG icon theme" | ||
LICENSE="LGPL-3" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86" | ||
IUSE="test" | ||
|
||
BDEPEND=" | ||
dev-qt/qtcore:5 | ||
>=kde-frameworks/extra-cmake-modules-${PVCUT}:5 | ||
test? ( app-misc/fdupes ) | ||
" | ||
DEPEND="test? ( dev-qt/qttest:5 )" | ||
|
||
RESTRICT+=" !test? ( test )" | ||
|
||
src_prepare() { | ||
cmake_src_prepare | ||
use test || cmake_comment_add_subdirectory autotests | ||
} | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DBINARY_ICONS_RESOURCE=OFF | ||
) | ||
cmake_src_configure | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST extra-cmake-modules-5.64.0.tar.xz 339444 BLAKE2B 361689b58ee5b681afd0ff1dfe4ec8fa96f8ba4b1b559be1045c4551e4f874086130fd90a87327b967c9ec48cf532356e675954ceff5fd51f258dd26907110f9 SHA512 81649a1fbe148eab56ff9147b412303112376343c84767139908b9f39e77debcbbf6b8fe2c1edf3151d3556ab9a826eef9b893cc1ef679d0b5cb37096f23fa44 | ||
DIST extra-cmake-modules-5.66.0.tar.xz 340388 BLAKE2B 0d53ef47bf07aa2546b422b2b1b9f3bd96ffa275e6062fa23656f8a268dfed998eed09e39c1d360e7f6b802007b09825ffa8ded00761a0e75186c18c1f93aec5 SHA512 d0fdf658b636ad7b0cc70d87cb695010969d51f83c62a3b59ffc880c4b2db179170124e4baf185b6261801bad6207c4776536581c5152aeb174784af3b5236a4 | ||
DIST extra-cmake-modules-5.67.0.tar.xz 339812 BLAKE2B 9fa1c93e512341f6ae91dd2bb7126bdc55b5d1df6390a54f1fa7506f1f903a005103d1259f7962e94c0f2e27bf82d8d4c5320053b197c18305d32ba870ced67e SHA512 1a0e185ea4eac16d57c34f140a4709c0bcd9baaa7e0727ab5c1bfee88fe08efe23dc3634d8f73abade98ad6f2dbf529563e0778f0fbeddaa50b435e12b674229 |
74 changes: 74 additions & 0 deletions
74
kde-frameworks/extra-cmake-modules/extra-cmake-modules-5.67.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,74 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
PYTHON_COMPAT=( python3_{6,7,8} ) | ||
QTMIN=5.12.3 | ||
inherit cmake kde.org python-any-r1 | ||
|
||
DESCRIPTION="Extra modules and scripts for CMake" | ||
HOMEPAGE="https://cgit.kde.org/extra-cmake-modules.git" | ||
|
||
LICENSE="BSD" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86" | ||
IUSE="doc test" | ||
|
||
BDEPEND=" | ||
doc? ( | ||
${PYTHON_DEPS} | ||
$(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]') | ||
>=dev-qt/qthelp-${QTMIN}:5 | ||
) | ||
test? ( | ||
>=dev-qt/linguist-tools-${QTMIN}:5 | ||
>=dev-qt/qtcore-${QTMIN}:5 | ||
) | ||
" | ||
RDEPEND=" | ||
app-arch/libarchive[bzip2] | ||
" | ||
|
||
RESTRICT+=" !test? ( test )" | ||
|
||
PATCHES=( | ||
"${FILESDIR}/${PN}-5.49.0-no-fatal-warnings.patch" | ||
"${FILESDIR}/${PN}-5.65.0-disable-qmlplugindump.patch" | ||
) | ||
|
||
python_check_deps() { | ||
has_version "dev-python/sphinx[${PYTHON_USEDEP}]" | ||
} | ||
|
||
pkg_setup() { | ||
use doc && python-any-r1_pkg_setup | ||
} | ||
|
||
src_prepare() { | ||
cmake_src_prepare | ||
# Requires PyQt5, bug #680256 | ||
sed -i -e "/^if(NOT SIP_Qt5Core_Mod_FILE)/s/NOT SIP_Qt5Core_Mod_FILE/TRUE/" \ | ||
tests/CMakeLists.txt || die "failed to disable GenerateSipBindings tests" | ||
} | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DDOC_INSTALL_DIR=/usr/share/doc/"${PF}" | ||
-DBUILD_QTHELP_DOCS=$(usex doc) | ||
-DBUILD_HTML_DOCS=$(usex doc) | ||
-DBUILD_MAN_DOCS=$(usex doc) | ||
-DBUILD_TESTING=$(usex test) | ||
) | ||
|
||
cmake_src_configure | ||
} | ||
|
||
src_test() { | ||
# ECMToolchainAndroidTest passes but then breaks src_install | ||
# ECMPoQmToolsTest is broken, bug #627806 | ||
local myctestargs=( | ||
-E "(ECMToolchainAndroidTest|ECMPoQmToolsTest)" | ||
) | ||
|
||
cmake_src_test | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST frameworkintegration-5.64.0.tar.xz 1754716 BLAKE2B a9812b62c8973b5286b06388a5a9bb2f65bed49684b72c56696ab8e5ea7a03b24ba9d8b58b210cfbd06d46a695106d81f22b5fbd6440bc68dc639c5385dbce62 SHA512 7288578fcec9c1fe1d768692380acff00267513e0092361b0c0739e669a86ffde1df96f20e0ce91685df440ae7fcd7786d96fc18c1faa00e5e82d7fc9b8d60df | ||
DIST frameworkintegration-5.66.0.tar.xz 1753696 BLAKE2B e365fac7c3ea7e6583edc94fcfe68cdc3f020e887c1383cba0792a19f4e5aebd29098071fd10b8cb70efd322ce5923159e1126ef7dae74521a8ec505fc5af77a SHA512 d22cc4a2f5552705c0b863d2b73dfffd70a0020bf31dcf17874ac5a8c05de8bbbc88c7e12d455d1a98bc64916cb174a7fdb9677833cb5404c0b7c8f1c9bea2f2 | ||
DIST frameworkintegration-5.67.0.tar.xz 1753624 BLAKE2B cf70bed5acf65240568aafe7b025db339550abc0226d1f560d24636e4368955028148d9dbdf47afbe2e0f98850c9112aaf7ffc02966ffb48e27814adfc7cb65c SHA512 47ec7ebc2b1067074620a5a9e39f5aa664595569fc2d4a1c591e34e9ac52502fffd51f7707a522bf4028f50064f82dfafe2c6b46faa3b0f212b766e6f2ac2186 |
48 changes: 48 additions & 0 deletions
48
kde-frameworks/frameworkintegration/frameworkintegration-5.67.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,48 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
ECM_QTHELP="false" | ||
PVCUT=$(ver_cut 1-2) | ||
QTMIN=5.12.3 | ||
VIRTUALX_REQUIRED="test" | ||
inherit ecm kde.org | ||
|
||
DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces" | ||
|
||
LICENSE="LGPL-2+" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86" | ||
IUSE="appstream" | ||
|
||
# drop qtwidgets subslot operator when QT_MINIMAL >= 5.14.0 | ||
RDEPEND=" | ||
>=dev-qt/qtgui-${QTMIN}:5 | ||
>=dev-qt/qtwidgets-${QTMIN}:5= | ||
=kde-frameworks/kconfig-${PVCUT}*:5 | ||
=kde-frameworks/kconfigwidgets-${PVCUT}*:5 | ||
=kde-frameworks/ki18n-${PVCUT}*:5 | ||
=kde-frameworks/kiconthemes-${PVCUT}*:5 | ||
=kde-frameworks/knewstuff-${PVCUT}*:5 | ||
=kde-frameworks/knotifications-${PVCUT}*:5 | ||
appstream? ( | ||
app-admin/packagekit-qt | ||
dev-libs/appstream[qt5] | ||
) | ||
" | ||
DEPEND="${RDEPEND} | ||
=kde-frameworks/kpackage-${PVCUT}*:5 | ||
=kde-frameworks/kwidgetsaddons-${PVCUT}*:5 | ||
" | ||
|
||
# requires running kde environment | ||
RESTRICT+=" test" | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
$(cmake_use_find_package appstream AppStreamQt) | ||
$(cmake_use_find_package appstream packagekitqt5) | ||
) | ||
|
||
ecm_src_configure | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST kactivities-stats-5.64.0.tar.xz 63020 BLAKE2B ae99e6473d4491520ef8eb748f9a06a7da3300e051d0eb642956920986979460dfc8afebdc01e0a6efd4a8fc554d6fb6ab2f535cc0fa0bae876fe1a6f95cb1a9 SHA512 d94698fc755780c49bf9d4521afd1d7ef75a3393965946a9868f6b429d7e6fed5bd808591f9d8037c2d6a8dc6a7f67ed0e823681114b9bb33fe3f4838da14cd1 | ||
DIST kactivities-stats-5.66.0.tar.xz 63196 BLAKE2B 71f419122f24ee0877266b0d8096641d5c648fdf903ecc97547c0b4d08d48deade4d3928ac44e703e388e27dbd35c9cd21b876114c69ceb0b8c1a6a8a02b0bca SHA512 649dbabbad4b6e50363c938f4bf8a881b1b7476c67c638884ee44d879d9ccbdf7e998c59233069bb44fcebcac166750efc8805288dff9b5ec7af808e0dea22b6 | ||
DIST kactivities-stats-5.67.0.tar.xz 63124 BLAKE2B 4645d4bdd5e9cc4b17105f3dee61993441aee849ff31392f3e53db4a0ba1685d1d28fdaa69f2a1882869c46ac0ad7d7a5641ac0a801d7846289fa63a9a66fe2f SHA512 ccd66e179efb5ecc4569ac7fb6897793b6b172cc2b6a458d8610fc1fb35fc1a817a56de8e27b290beb2f941847a0da568c9bf213029cb0dd0a4f0fa5d03c9c55 |
23 changes: 23 additions & 0 deletions
23
kde-frameworks/kactivities-stats/kactivities-stats-5.67.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,23 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
PVCUT=$(ver_cut 1-2) | ||
QTMIN=5.12.3 | ||
inherit ecm kde.org | ||
|
||
DESCRIPTION="Framework for getting the usage statistics collected by the activities service" | ||
LICENSE="LGPL-2+" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86" | ||
IUSE="" | ||
|
||
RDEPEND=" | ||
>=dev-qt/qtdbus-${QTMIN}:5 | ||
>=dev-qt/qtsql-${QTMIN}:5 | ||
=kde-frameworks/kactivities-${PVCUT}*:5 | ||
=kde-frameworks/kconfig-${PVCUT}*:5 | ||
" | ||
DEPEND="${RDEPEND} | ||
>=dev-libs/boost-1.54 | ||
" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST kactivities-5.64.0.tar.xz 61556 BLAKE2B 617eea15f83c4d55122964f6adcc1d9e4fe6b00ab772cb8e7488a4ee7e030816bd08d734b45e80ddbf99678c4ebc01028d196fb85c55bec0f83a787f6d05bbe1 SHA512 283f2f3f45acfbb54e1b7b592fb6e61ac03ad711dd72d76fe5681bfc88f283e92f7e817ff10014604564f7a5c6c888ed9e745b18c6b9b66359bb29d7f5fbf6c3 | ||
DIST kactivities-5.66.0.tar.xz 61552 BLAKE2B 57833ae0937d2086d1b9f59707a632661a90db102b90ce2b1586972ff71f8aa35e434c23dd267f88913c4888e027d528033ab3a73b7b98f00146120472eabf8b SHA512 5acd604b0eb7bc465243cba77adc549e77749801a218bf497ca29b8bf5e948348cf6d35aaaa8101e37fd3bb989718e5a1216db2648d0036a76eed9b311ff7f23 | ||
DIST kactivities-5.67.0.tar.xz 61204 BLAKE2B 6d9d25126317e763da4fa572ed0495fa1d8f1b5c6a675892753278d55479e0db55e1aa288bc4bb289488199f0857fe72cc206b79edf33e7e6e3676af568227d5 SHA512 d66413643b04bf10941db0fb61e106f0153eb23afdb7cb33814d4000e64ce5973c0f2b9098fe89d95168f4058dcfa9d2f6031d319692fd3aba46b671da8a4df7 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,29 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
PVCUT=$(ver_cut 1-2) | ||
PLASMA_MINIMAL=5.16.5 | ||
QTMIN=5.12.3 | ||
inherit ecm kde.org | ||
|
||
DESCRIPTION="Framework for working with KDE activities" | ||
LICENSE="|| ( LGPL-2.1 LGPL-3 )" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86" | ||
IUSE="" | ||
|
||
COMMON_DEPEND=" | ||
=kde-frameworks/kconfig-${PVCUT}*:5 | ||
=kde-frameworks/kcoreaddons-${PVCUT}*:5 | ||
>=dev-qt/qtdbus-${QTMIN}:5 | ||
>=dev-qt/qtdeclarative-${QTMIN}:5[widgets] | ||
>=dev-qt/qtgui-${QTMIN}:5 | ||
>=dev-qt/qtsql-${QTMIN}:5 | ||
" | ||
RDEPEND="${COMMON_DEPEND} | ||
>=kde-plasma/kactivitymanagerd-${PLASMA_MINIMAL}:5 | ||
" | ||
DEPEND="${COMMON_DEPEND} | ||
>=dev-libs/boost-1.54 | ||
" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST kapidox-5.64.0.tar.xz 397092 BLAKE2B 6dc26a911e45476c69385066e7c501db0e2f1236f4ea1e589e822b7bb515a8908f02e456b482bd4b1ddd5f2dbf7ddec902327f49749a7c71e266b10a35e289e5 SHA512 b32cc42e75cfff6f137970af2aff746016e470229694c5e6c095ef50c725760ad24a6fd3b4ba08af885c5609e70f8f7440b8923d229fc77bbc492498abc7e17e | ||
DIST kapidox-5.66.0.tar.xz 397472 BLAKE2B 0106a8bd88d828e46c9d0c8c7bbb86bf00d639aacbea9e782f0bb19f0c3e4ab241b5051863fe4a898b974ca344017085798da9ff15e9fe3126d8d55487b06267 SHA512 e6c75780ca4de1c96f9b0874aec00d338e4f8d5d6825d5699b296077bc029419ccc3f0b757a76bb22612f47f377df9fb7f089d464d049b605faa3c917b838238 | ||
DIST kapidox-5.67.0.tar.xz 396744 BLAKE2B ab7fe4609199182dff558f339010ef13ac8ce927fc2c57bf84734b39b2a5253dc1432eed2ab5affd9d1b9648f25919fa112786f8e4b2b5b8cadc9112ecdf41f6 SHA512 2ca39fb6413b4c6fa8026f67b3e46ccfd65043c07d6a3ac678bc0ad6b4855a2e370fe51105d4d07bfe9ca6c10936650848ef2d2d5e91c5445d8cf575fcc84121 |
Oops, something went wrong.