forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-python/python-cinderclient: bup for liberty
- Loading branch information
1 parent
b30243d
commit a602cad
Showing
3 changed files
with
60 additions
and
1 deletion.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST python-cinderclient-1.0.9.tar.gz 136309 SHA256 e146e370c9a6e4aa44e8f0662fd33aec532f3965bae9fd564360c279bee03f97 SHA512 102e0ffec8aab143349f51e29b1265ea564b4cb8eeb9a546e353d6a9ee1ce08f8c258776ea96975be1d55f53ebaaa1b0fc01d7b7a12cde7baf5df8142368ed43 WHIRLPOOL 2360f4efcee62286cc1e45ca28013ded25b473d9a13e6e19ac53d811c2285e0031732077fae60d83b59a6abbe637406bd5a539348168f1884739381379b44bdf | ||
DIST python-cinderclient-1.1.2.tar.gz 153104 SHA256 d364b627fbcbd049b2cedf125fb6aa06e2ca6213208f92b7ea393a7e1d7ecbe2 SHA512 84dc5bc89c547b05b9f305f6779ea2a47f2f964f985580d1555d0183da89c7e617433bacb11f2af23a1791a549de045e55d021bdb65f06def01062349a8cbc7e WHIRLPOOL 12082f19db2a583f9576396f20bf81f44b9769e9e9dd8e07ba54fb3cfce70a061f2e657949cf082abfd2a7f091387463e4e29065b9457d02051f27eb20cb173b | ||
DIST python-cinderclient-1.2.1.tar.gz 176466 SHA256 c9ccb89960b936ee261a9d6aac3895fde9b5c68e8c8e87d66ad3298a13bfd460 SHA512 ad27a7e32fc9da3c38abd5ca9f72f771229b00ab8a9f9f52c4001997afec194bda5270307ed2506747070f07e804952fef374fdb14ac75b646fb3dc6548aaea7 WHIRLPOOL afc4e2a6f5fa2917be408752f56215e5ee1c47dc6a952d5f6d294505a3c0843254136e5afd5370b9554bf6dfb97a47855e7b42122bdef0528d80a08f2feca6f6 | ||
DIST python-cinderclient-1.3.1.tar.gz 178094 SHA256 59ae1fbeeda7a12ac8635a7cce9bdc5e8bd080707e2dc12d858857713db1d233 SHA512 01b090e782318a6971f73ca0e6b5b8056d038db3073e93fdcb81c35c876d039782361b1ab1048b0ae51dbf0fdabc3b7a3b655241b8cd46418f0aff900c33f5bf WHIRLPOOL e35fbd323ef5be8dfc9bda1863c7521319517df5b57abb2492e6b06bf7248b940f9f62107e044737ab179bb69553d6bb464718cb55e8fa773e76f0207b887710 |
58 changes: 58 additions & 0 deletions
58
dev-python/python-cinderclient/python-cinderclient-1.3.1.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,58 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
PYTHON_COMPAT=( python2_7 python3_3 python3_4 ) | ||
|
||
inherit distutils-r1 | ||
|
||
DESCRIPTION="A client for the OpenStack Cinder API" | ||
HOMEPAGE="https://launchpad.net/python-cinderclient" | ||
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux" | ||
IUSE="test" | ||
|
||
CDEPEND=" | ||
>=dev-python/pbr-0.11[${PYTHON_USEDEP}] | ||
<dev-python/pbr-2.0[${PYTHON_USEDEP}]" | ||
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}] | ||
${CDEPEND} | ||
test? ( | ||
>=dev-python/coverage-3.6[${PYTHON_USEDEP}] | ||
>=dev-python/fixtures-1.3.1[${PYTHON_USEDEP}] | ||
>=dev-python/mock-1.0[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}] | ||
>=dev-python/subunit-0.0.18[${PYTHON_USEDEP}] | ||
>=dev-python/requests-mock-0.6.0[${PYTHON_USEDEP}] | ||
>=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}] | ||
!~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}] | ||
<dev-python/sphinx-1.3[${PYTHON_USEDEP}] | ||
>=dev-python/tempest-lib-0.6.1[${PYTHON_USEDEP}] | ||
>=dev-python/testtools-1.4.0[${PYTHON_USEDEP}] | ||
>=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}] | ||
)" | ||
RDEPEND=" | ||
${CDEPEND} | ||
>=dev-python/prettytable-0.7[${PYTHON_USEDEP}] | ||
<dev-python/prettytable-0.8[${PYTHON_USEDEP}] | ||
>=dev-python/python-keystoneclient-1.6.0[${PYTHON_USEDEP}] | ||
>=dev-python/requests-2.5.2[${PYTHON_USEDEP}] | ||
>=dev-python/simplejson-2.2.0[${PYTHON_USEDEP}] | ||
>=dev-python/Babel-1.3[${PYTHON_USEDEP}] | ||
>=dev-python/six-1.9.0[${PYTHON_USEDEP}]" | ||
|
||
src_prepare() { | ||
sed -i '/^argparse/d' requirements.txt || die | ||
sed -i '/^hacking/d' test-requirements.txt || die | ||
distutils-r1_python_prepare_all | ||
} | ||
|
||
python_test() { | ||
testr init | ||
testr run --parallel || die "tests failed under python2.7" | ||
flake8 cinderclient/tests || die "run by flake8 over tests folder yielded error" | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters