Skip to content

Commit

Permalink
dev-python/pyproj: bump to 2.4.2
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.79, Repoman-2.3.16
Signed-off-by: Chris Mayo <[email protected]>
Closes: gentoo#13924
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
cjmayo authored and a17r committed Dec 8, 2019
1 parent 7996675 commit a61a895
Show file tree
Hide file tree
Showing 3 changed files with 74 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/pyproj/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST pyproj-1.9.5.1.tar.gz 4424543 BLAKE2B cdf954ec0fe794f354b246fcd5afeac01b796f84cc2456efce3e289fcfb12074d7352c9fa7e9d74356199135dfa9814c07da9379f85771dbb7130b8b9b7ecc34 SHA512 b0e0f85be01a3399cb41c4bf29d1a63ecb519fd45d6092a3558060d93c715afafd12f7532c8665839225ad7243e739a117677f6747bf34a0ccbde5e75c85f324
DIST pyproj-2.4.1.tar.gz 462332 BLAKE2B bd5f8f34bd1e4f928cbbba8736ede96425f1823171b1e4da0ecd6ccf9f105d4f5d4c9f953f353382412883c70803421b4d9a5175aba5cabcb689fafb19484a89 SHA512 c8bc987991b8136951f038f504cb6ffa5f69663b9ba447b586ab29d30e91b05661c46726132ac2cbfd756d92842606b1d5a5167b84c66878688e5ac4e5259353
DIST pyproj-2.4.2.tar.gz 463252 BLAKE2B aa80ee3052f42f0d49d02b1dfa3d1790e02fe6aa4092319ff8e827b0a341cff2cb4779891f74919c2b14781d841b3662154882b5f218a22b55ad79397f3eb4a7 SHA512 20f0a742ea5699a6d7a621e93157512478de69ba740bb7b0df46b6d5668f6db93b07e1fc0bf4d089362275ea8edddf3100a972a533ed8b6a0bc56a04a20d4ef9
31 changes: 31 additions & 0 deletions dev-python/pyproj/files/pyproj-2.4.2-conftest.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,31 @@
--- a/test/conftest.py
+++ b/test/conftest.py
@@ -0,0 +1,28 @@
+import os
+import shutil
+import tempfile
+
+import pytest
+
+import pyproj
+
+
+@pytest.fixture(scope="session")
+def aoi_data_directory():
+ """
+ This is to ensure that the ntv2_0.gsb file is actually
+ missing for the AOI tests.
+ """
+ data_dir = pyproj.datadir.get_data_dir()
+ with tempfile.TemporaryDirectory() as tmpdir:
+ tmp_data_dir = os.path.join(tmpdir, "proj")
+ shutil.copytree(data_dir, tmp_data_dir)
+ try:
+ os.remove(os.path.join(str(tmp_data_dir), "ntv2_0.gsb"))
+ except OSError:
+ pass
+ try:
+ pyproj.datadir.set_data_dir(str(tmp_data_dir))
+ yield
+ finally:
+ pyproj.datadir.set_data_dir(data_dir)
42 changes: 42 additions & 0 deletions dev-python/pyproj/pyproj-2.4.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,42 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

# Python < 3.6 requires https://pypi.org/project/aenum/
PYTHON_COMPAT=( python3_{6,7,8} )

inherit distutils-r1 flag-o-matic

DESCRIPTION="Python interface to the PROJ library"
HOMEPAGE="https://github.com/jswhit/pyproj"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux"
IUSE="doc"

RDEPEND=">=sci-libs/proj-6.2.0"
DEPEND="${RDEPEND}
dev-python/cython[${PYTHON_USEDEP}]"
BDEPEND="
test? (
dev-python/mock[${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]
sci-libs/Shapely[${PYTHON_USEDEP}]
)"

PATCHES=( "${FILESDIR}"/${P}-conftest.patch )

distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
distutils_enable_tests pytest

python_prepare_all() {
distutils-r1_python_prepare_all
append-cflags -fno-strict-aliasing
}

python_test() {
PROJ_LIB="${EPREFIX}/usr/share/proj" pytest -ra || die
}

0 comments on commit a61a895

Please sign in to comment.