Skip to content

Commit

Permalink
dev-haskell/idiii: tweak for ghc-8.8
Browse files Browse the repository at this point in the history
Reported-by: Toralf Förster
Closes: https://bugs.gentoo.org/736280
Package-Manager: Portage-3.0.1, Repoman-2.3.23
Signed-off-by: Sergei Trofimovich <[email protected]>
  • Loading branch information
Sergei Trofimovich committed Aug 7, 2020
1 parent 5986e66 commit a61cae6
Show file tree
Hide file tree
Showing 2 changed files with 11 additions and 3 deletions.
7 changes: 7 additions & 0 deletions dev-haskell/idiii/files/idiii-0.1.3.3-fold.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,7 @@
--- a/src/ID3/Type/Tag.hs
+++ b/src/ID3/Type/Tag.hs
@@ -89,3 +89,3 @@ getActualSize t = (footerSize t) + (framesSize (t^.frames)) + (extHSize t)
framesSize :: Map FrameID ID3Frame -> FrameSize
-framesSize fs = Map.fold (\fr x -> fr^.frHeader^.frSize + 10 + x) 0 fs
+framesSize fs = Map.foldr (\fr x -> fr^.frHeader^.frSize + 10 + x) 0 fs
footerSize :: ID3Tag -> Integer
7 changes: 4 additions & 3 deletions dev-haskell/idiii/idiii-0.1.3.3.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -5,11 +5,11 @@ EAPI=6

# ebuild generated by hackport 0.5.9999

CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
CABAL_FEATURES="bin lib profile haddock hoogle hscolour" # Broken test-suite: missing files
inherit haskell-cabal

DESCRIPTION="ID3v2 (tagging standard for MP3 files) library"
HOMEPAGE="https://hackage.haskell.org/package/idiii"
HOMEPAGE="http://hackage.haskell.org/package/idiii"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"

LICENSE="BSD"
Expand All @@ -28,5 +28,6 @@ RDEPEND="dev-haskell/data-accessor:=[profile?]
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.8
test? ( dev-haskell/hunit )
"

PATCHES=("${FILESDIR}"/${P}-fold.patch)

0 comments on commit a61cae6

Please sign in to comment.