Skip to content

Commit

Permalink
x11-libs/libva-vdpau-driver: drop nouveau support
Browse files Browse the repository at this point in the history
>=mesa-12 now has native VAAPI support for nouveau

Bug: https://bugs.gentoo.org/show_bug.cgi?id=588392

Package-Manager: portage-2.2.28
  • Loading branch information
chithanh committed Jul 9, 2016
1 parent 10549d6 commit a63b196
Showing 1 changed file with 44 additions and 0 deletions.
44 changes: 44 additions & 0 deletions x11-libs/libva-vdpau-driver/libva-vdpau-driver-0.7.4-r4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

AUTOTOOLS_AUTORECONF="yes"
inherit autotools-multilib eutils

DESCRIPTION="VDPAU Backend for Video Acceleration (VA) API"
HOMEPAGE="https://www.freedesktop.org/wiki/Software/vaapi"
SRC_URI="https://www.freedesktop.org/software/vaapi/releases/libva-vdpau-driver/${P}.tar.bz2"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug opengl"

RDEPEND=">=x11-libs/libva-1.2.1-r1[X,opengl?,${MULTILIB_USEDEP}]
opengl? ( >=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}] )
>=x11-libs/libvdpau-0.8[${MULTILIB_USEDEP}]
!x11-libs/vdpau-video"

DEPEND="${DEPEND}
virtual/pkgconfig"

DOCS=( NEWS README AUTHORS )

src_prepare() {
epatch \
"${FILESDIR}"/${P}-glext-missing-definition.patch \
"${FILESDIR}"/${P}-VAEncH264VUIBufferType.patch \
"${FILESDIR}"/${P}-libvdpau-0.8.patch
sed -i 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.ac || die
autotools-multilib_src_prepare
}

multilib_src_configure() {
local myeconfargs=(
$(use_enable debug)
$(use_enable opengl glx)
)
autotools-utils_src_configure
}

0 comments on commit a63b196

Please sign in to comment.