Skip to content

Commit

Permalink
app-i18n/scim: Fix automagic dependencies on Qt 4.
Browse files Browse the repository at this point in the history
  • Loading branch information
Arfrever Frehtes Taifersar Arahesis authored and floppym committed Mar 8, 2018
1 parent 4d8730f commit a680b7f
Show file tree
Hide file tree
Showing 3 changed files with 30 additions and 9 deletions.
13 changes: 10 additions & 3 deletions app-i18n/scim/scim-1.4.14.ebuild
Original file line number Diff line number Diff line change
@@ -1,8 +1,8 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="4"
inherit eutils flag-o-matic multilib gnome2-utils autotools-utils
inherit eutils flag-o-matic multilib gnome2-utils autotools-utils qmake-utils

DESCRIPTION="Smart Common Input Method (SCIM) is an Input Method (IM) development platform"
HOMEPAGE="http://www.scim-im.org/"
Expand All @@ -11,12 +11,16 @@ SRC_URI="mirror://sourceforge/scim/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ppc ppc64 sparc x86 ~x86-fbsd"
IUSE="doc gtk3"
IUSE="doc gtk3 qt4"

RDEPEND="x11-libs/libX11
dev-libs/glib:2
gtk3? ( x11-libs/gtk+:3 )
!gtk3? ( x11-libs/gtk+:2 )
qt4? (
dev-qt/qtcore:4
dev-qt/qtgui:4
)
>=dev-libs/atk-1
>=x11-libs/pango-1
!app-i18n/scim-cvs"
Expand Down Expand Up @@ -50,6 +54,9 @@ src_configure() {
$(use_with doc doxygen)
--enable-ld-version-script
$gtk_version
--disable-qt3-immodule
$(use_enable qt4 qt4-immodule)
--with-qt4-moc="$(qt4_get_bindir)/moc"
)
autotools-utils_src_configure
}
Expand Down
13 changes: 10 additions & 3 deletions app-i18n/scim/scim-1.4.17.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit eutils flag-o-matic multilib gnome2-utils autotools
inherit eutils flag-o-matic multilib gnome2-utils autotools qmake-utils

DESCRIPTION="Smart Common Input Method (SCIM) is an Input Method (IM) development platform"
HOMEPAGE="https://sourceforge.net/projects/scim"
Expand All @@ -11,12 +11,16 @@ SRC_URI="mirror://sourceforge/scim/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 ~arm hppa ppc ppc64 sparc x86 ~x86-fbsd"
IUSE="doc gtk3"
IUSE="doc gtk3 qt4"

RDEPEND="x11-libs/libX11
dev-libs/glib:2
gtk3? ( x11-libs/gtk+:3 )
!gtk3? ( x11-libs/gtk+:2 )
qt4? (
dev-qt/qtcore:4
dev-qt/qtgui:4
)
>=dev-libs/atk-1
>=x11-libs/pango-1"
DEPEND="${RDEPEND}
Expand Down Expand Up @@ -44,7 +48,10 @@ src_configure() {
filter-flags -fvisibility-inlines-hidden -fvisibility=hidden
econf $(use_with doc doxygen) \
--enable-ld-version-script \
$(usex gtk3 --with-gtk-version={3,2})
$(usex gtk3 --with-gtk-version={3,2}) \
--disable-qt3-immodule \
$(use_enable qt4 qt4-immodule) \
--with-qt4-moc="$(qt4_get_bindir)/moc"
}

src_compile() {
Expand Down
13 changes: 10 additions & 3 deletions app-i18n/scim/scim-1.4.18.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,7 @@

EAPI="6"

inherit eutils flag-o-matic multilib gnome2-utils autotools
inherit autotools flag-o-matic gnome2-utils qmake-utils

DESCRIPTION="Smart Common Input Method (SCIM) is an Input Method (IM) development platform"
HOMEPAGE="https://github.com/scim-im/scim"
Expand All @@ -12,12 +12,16 @@ SRC_URI="https://github.com/scim-im/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="doc gtk3"
IUSE="doc gtk3 qt4"

RDEPEND="x11-libs/libX11
dev-libs/glib:2
gtk3? ( x11-libs/gtk+:3 )
!gtk3? ( x11-libs/gtk+:2 )
qt4? (
dev-qt/qtcore:4
dev-qt/qtgui:4
)
>=dev-libs/atk-1
>=x11-libs/pango-1"
DEPEND="${RDEPEND}
Expand Down Expand Up @@ -45,7 +49,10 @@ src_configure() {
filter-flags -fvisibility-inlines-hidden -fvisibility=hidden
econf $(use_with doc doxygen) \
--enable-ld-version-script \
$(usex gtk3 --with-gtk-version={3,2})
$(usex gtk3 --with-gtk-version={3,2}) \
--disable-qt3-immodule \
$(use_enable qt4 qt4-immodule) \
--with-qt4-moc="$(qt4_get_bindir)/moc"
}

src_compile() {
Expand Down

0 comments on commit a680b7f

Please sign in to comment.