Skip to content

Commit

Permalink
dev-ruby/launchy: add ruby24
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.5, Repoman-2.3.1
  • Loading branch information
graaff committed Jun 16, 2017
1 parent ac7f422 commit a6b03d3
Showing 1 changed file with 36 additions and 0 deletions.
36 changes: 36 additions & 0 deletions dev-ruby/launchy/launchy-2.4.3-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5
USE_RUBY="ruby21 ruby22 ruby23 ruby24"

RUBY_FAKEGEM_EXTRADOC="README.md HISTORY.md"

inherit ruby-fakegem

DESCRIPTION="Helper class for launching cross-platform applications"
HOMEPAGE="https://github.com/copiousfreetime/launchy"

LICENSE="ISC"

SLOT="0"
KEYWORDS="~amd64"
IUSE=""

# File collision conflict with x11-misc/launchy, bug 545170
ruby_add_rdepend ">=dev-ruby/addressable-2.3 !!x11-misc/launchy"

ruby_add_bdepend "test? ( >=dev-ruby/minitest-5.0:5 )"

# This test is expected to fail on linux, drop it
RUBY_PATCHES=( "${FILESDIR}"/${PN}-2.4.2-drop-failing-test.patch )

all_ruby_prepare() {
sed -i -e "/[Ss]implecov/d" spec/spec_helper.rb || die

# Avoid tests depending on the current user's desktop environment.
sed -e '/returns NotFound if it cannot determine/askip "gentoo"' \
-i spec/detect/nix_desktop_environment_spec.rb || die
sed -e '/asssumes we open a local file if we have an exception/askip "gentoo"' \
-i spec/launchy_spec.rb || die
}

0 comments on commit a6b03d3

Please sign in to comment.