Skip to content

Commit

Permalink
dev-python/cloudpickle: Enable py3.13
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Jul 11, 2024
1 parent fc736f4 commit a6bd7d3
Show file tree
Hide file tree
Showing 2 changed files with 38 additions and 2 deletions.
8 changes: 6 additions & 2 deletions dev-python/cloudpickle/cloudpickle-3.0.0.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -4,8 +4,7 @@
EAPI=8

DISTUTILS_USE_PEP517=flit
# py3.13: https://github.com/cloudpipe/cloudpickle/issues/533
PYTHON_COMPAT=( pypy3 python3_{10..12} )
PYTHON_COMPAT=( pypy3 python3_{10..13} )

inherit distutils-r1

Expand All @@ -31,6 +30,11 @@ BDEPEND="

distutils_enable_tests pytest

PATCHES=(
# https://github.com/cloudpipe/cloudpickle/pull/534
"${FILESDIR}/${P}-py313.patch"
)

python_test() {
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
local -x PYTHONPATH=${PYTHONPATH}:tests/cloudpickle_testpkg
Expand Down
32 changes: 32 additions & 0 deletions dev-python/cloudpickle/files/cloudpickle-3.0.0-py313.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,32 @@
From 3dc53183e86bb9f0ee9d45ff9d4971036c61ecba Mon Sep 17 00:00:00 2001
From: Lumir Balhar <[email protected]>
Date: Wed, 15 May 2024 10:43:50 +0200
Subject: [PATCH] Fix test_extract_class_dict for Python 3.13 beta 1

Resolves: https://github.com/cloudpipe/cloudpickle/issues/533
Closes: https://github.com/cloudpipe/cloudpickle/pull/534
---
tests/cloudpickle_test.py | 7 ++++++-
1 file changed, 6 insertions(+), 1 deletion(-)

diff --git a/tests/cloudpickle_test.py b/tests/cloudpickle_test.py
index 4041bf7..6d0d915 100644
--- a/tests/cloudpickle_test.py
+++ b/tests/cloudpickle_test.py
@@ -108,7 +108,12 @@ def test_extract_class_dict():
return "c"

clsdict = _extract_class_dict(C)
- assert sorted(clsdict.keys()) == ["C_CONSTANT", "__doc__", "method_c"]
+ expected_keys = ["C_CONSTANT", "__doc__", "method_c"]
+ # New attribute in Python 3.13 beta 1
+ # https://github.com/python/cpython/pull/118475
+ if sys.version_info >= (3, 13):
+ expected_keys.insert(2, "__firstlineno__")
+ assert sorted(clsdict.keys()) == expected_keys
assert clsdict["C_CONSTANT"] == 43
assert clsdict["__doc__"] is None
assert clsdict["method_c"](C()) == C().method_c()
--
2.45.2

0 comments on commit a6bd7d3

Please sign in to comment.