Skip to content

Commit

Permalink
app-admin/ansible: 2.2.3.0 bup
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.5, Repoman-2.3.2
  • Loading branch information
prometheanfire committed May 9, 2017
1 parent deaac07 commit a6d931c
Show file tree
Hide file tree
Showing 2 changed files with 56 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/ansible/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST ansible-2.2.2.0.tar.gz 2510182 SHA256 efd9c574168ac1916dd57f7c88d4dd2e13ef816af0ee49a8d34c77567886e4c2 SHA512 e5d902e6c8d67c2b5e1e907dffab7a36505cc96a9748915dd8340f78b6bf5ced2efe2153f621ecceafc75750729d3e2e26c9c7c95b3a6d15838e6c36de8b8b60 WHIRLPOOL 2b57bf518de9adf339b3c2eb3dfb0e2962e084b69db1a10c1cdccc4caa13845f668191b12f66b3656675b2ac94bb671f329ab7ab843796480a963017cb762776
DIST ansible-2.2.3.0.tar.gz 2512540 SHA256 de18ab1cf0712252e928dd1226b2c058d5345ef7377a01e0601a268fcd512a90 SHA512 c3ba4e7d226831d039a52f93228818a1788811ad04d27e5ebc95f84ffb38a2c80af0cebe6fa577ba0c4748cd4078ef031041eb62319721705ce1092f311062ac WHIRLPOOL f3493dc112061dc65f4451260481f5aa7030ee968165790e1e427ad8fd555a2bf1fbd50d0b6a96c4e3306b79da0f6ca040b835a59cc04cb46aafbc5756c22cc1
DIST ansible-2.3.0.0.tar.gz 4251730 SHA256 299f3907cd566a20e163942fa82b6afc86ef89c2726ba503b90c1a651e82a458 SHA512 88ac28befefd7a70c36d8c33bc1aba1b0a5ffdea4bddd0b9e6c5488c70057662812208c221e47721c5a194fc30282a33490f196a719d9eb6d9b1e7dcfd1ff941 WHIRLPOOL a6a622f17476c07e3446a7b09631027797ade04f7d1571e0eafccc2736390deabfcdd36fa1e849d209eb7ab5f1e3e86f2b6e7dd3032db1743665165c1dc710ba
55 changes: 55 additions & 0 deletions app-admin/ansible/ansible-2.2.3.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,55 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python2_7 )

inherit distutils-r1 eutils versionator

DESCRIPTION="Model-driven deployment, config management, and command execution framework"
HOMEPAGE="http://ansible.com/"
SRC_URI="http://releases.ansible.com/${PN}/${P}.tar.gz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~x64-macos"
IUSE="test"

RDEPEND="
dev-python/paramiko[${PYTHON_USEDEP}]
dev-python/jinja[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/pycrypto-2.6[${PYTHON_USEDEP}]
dev-python/httplib2[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
net-misc/sshpass
virtual/ssh
"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/packaging-16.6[${PYTHON_USEDEP}]
test? (
${RDEPEND}
dev-python/nose[${PYTHON_USEDEP}]
>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
<dev-python/mock-1.1[${PYTHON_USEDEP}]
dev-python/passlib[${PYTHON_USEDEP}]
dev-python/coverage[${PYTHON_USEDEP}]
dev-python/unittest2[${PYTHON_USEDEP}]
dev-vcs/git
)"

# not included in release tarball
RESTRICT="test"

python_test() {
nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
}

python_install_all() {
distutils-r1_python_install_all

doman docs/man/man1/*.1
}

0 comments on commit a6d931c

Please sign in to comment.