Skip to content

Commit

Permalink
app-admin/mongo-tools: bump to 3.6.6
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.43, Repoman-2.3.10
  • Loading branch information
hydrapolic authored and ultrabug committed Aug 2, 2018
1 parent 5b72322 commit a6efaf4
Show file tree
Hide file tree
Showing 2 changed files with 62 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/mongo-tools/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -10,4 +10,5 @@ DIST mongo-tools-3.6.2.tar.gz 4693924 BLAKE2B 61c44d579f6eb4013ee6c0118ebe89a2d4
DIST mongo-tools-3.6.3.tar.gz 4693833 BLAKE2B fc7139984cf3dcb7b4ce6f6c2028296651aa59ac68d7068bdf748e28eeb65b1fd9b07580d0c93f3f41dbb01030a12433a07a04deadf28e0ff792387fa78ae4aa SHA512 7dba782c84a728aa9ceb28cbd9934f58b615dccfb238a9dbd63b18661ba4e74ddba21f93d9f12e6d80d293ebe42a82d31fa64448aacdba75bd07d964a5f631fc
DIST mongo-tools-3.6.4.tar.gz 4693872 BLAKE2B 5d72b32fa8ad7bc106c6ea3c09a27a093b9a1ae2392b4fa534042c5461fdc2b958dcbbf32e0ed596be234921e2ee21cc8f6132d57ae870a234abfc7adbb3b2e9 SHA512 53d06fa4a1b58de8001d6bf6e85f7edc97ce2cfbbb69c1ab05219deaa05ad9dd77d93f98c5526b4f58644a766e1b0f123686358095f059c71a4277634603f23f
DIST mongo-tools-3.6.5.tar.gz 4720814 BLAKE2B 5dd064f70557ec1ab979d08523f3dd305fb310c533b69bc99be3ad3d006036354f62b9f3d61c242e1481a254bed538a5e1cf5662f0e35705f1c50a76f31fddbb SHA512 dd2d7cc64043b42a70b5de0ea493f94722a4476248bfd77d6892861e4be6ab20175992367965dfd687bf8b7ebece6113b7f7a3e59256497e3ecd7e2678875965
DIST mongo-tools-3.6.6.tar.gz 4723751 BLAKE2B 876d46c47190398d1218a760bdeb8167c9224ef000a96b5f6080d6dcd44fe8187fdfbc38b1a61dbf437132e16e053212cf122daec3915647448d114983e51fc3 SHA512 b8cc02626accb90d8dacf50ea851619885a01503e28b17ed6a12cc9ccec2680a8cd12a566b32187d472f74c9625bf013afcdebed1a42d78ff613c49d3fc838b2
DIST mongo-tools-4.0.0.tar.gz 10872217 BLAKE2B 84e92178c0e4827926de525a70d6124635d59e270a3d37e23ec8653cc64d99bb7489fa6266917437ca45aa3ca5e00bc59b81e65c5b72e717db2701c6f7327bec SHA512 d67c4aca9b41266109adc39bb1a642206738fda393e1f9f05570c02a00a02e29ec71c71e67ad232c72d66543ae7e7bfe07fbcf26958d48ed0e631da452c1904d
61 changes: 61 additions & 0 deletions app-admin/mongo-tools/mongo-tools-3.6.6.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,61 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

MY_PV=${PV/_rc/-rc}
MY_P=${PN}-r${MY_PV}

DESCRIPTION="A high-performance, open source, schema-free document-oriented database"
HOMEPAGE="https://www.mongodb.com"
SRC_URI="https://github.com/mongodb/mongo-tools/archive/r${MY_PV}.tar.gz -> mongo-tools-${MY_PV}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"
IUSE="sasl ssl"

RDEPEND="!<dev-db/mongodb-3.0.0"
DEPEND="${RDEPEND}
dev-lang/go:=
net-libs/libpcap
sasl? ( dev-libs/cyrus-sasl )
ssl? ( dev-libs/openssl:0= )"

S=${WORKDIR}/${MY_P}

src_prepare() {
default

# do not substitute version because it uses git
sed -i '/^sed/,+3d' build.sh || die
sed -i '/^stty/d' build.sh || die
sed -i '/^mv/d' build.sh || die

# build pie to avoid text relocations wrt #582854
# skip on ppc64 wrt #610984
if ! use ppc64; then
sed -i 's/\(go build\)/\1 -buildmode=pie/g' build.sh || die
fi

# ensure we use bash wrt #582906
sed -i 's@/bin/sh@/bin/bash@g' build.sh || die
}

src_compile() {
local myconf=()

if use sasl; then
myconf+=(sasl)
fi

if use ssl; then
myconf+=(ssl)
fi

./build.sh ${myconf[@]} || die "build failed"
}

src_install() {
dobin bin/*
}

0 comments on commit a6efaf4

Please sign in to comment.