Skip to content

Commit

Permalink
gui-libs/wlroots: 0.10.0 bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Matthew Thode <[email protected]>
  • Loading branch information
prometheanfire committed Jan 22, 2020
1 parent 0f551c4 commit a6f0ce7
Show file tree
Hide file tree
Showing 2 changed files with 76 additions and 0 deletions.
1 change: 1 addition & 0 deletions gui-libs/wlroots/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST wlroots-0.10.0.tar.gz 454540 BLAKE2B 0d2326a62267019001be5f0d79c7b5c937ed20b952c92f0dd8cb04c3a0c06f3ef58723f552b1da1b947ea50ad91df46a543ec9705dad588db800bfa944743d11 SHA512 0e8e0c37f1afb1d99f0ecb3c2282992ffd06381aaa396c7234ead9f3ff2d5c599e766b677680ebaecf68e792054c3e42657d24f32d08bc8bcf35f9eb4bdaa876
DIST wlroots-0.6.0.tar.gz 497934 BLAKE2B a0b631831752e533f83ed62e402ef69b0994df050fd643cf2ef89556face4a822b3936bc758b70ab160eedda8ced16c0992dc209600914095784bba97bd26ee2 SHA512 c205d4303a381e11ef2f4db2faac1ddf9ad85c675824aae9cfe62d9f8bd313f1568d4810db1d006416783b50c8364198648a46d1ba453a0d8f659d6920618286
DIST wlroots-0.8.1.tar.gz 451814 BLAKE2B 85f221ba9068839f326e09df616f6182f518b9a129730dda794103305e3c0786d609a7cc6cb60a90c9d51cb77e3dbbc5993901271dcf1bd656c7744260561b06 SHA512 da41513de48e00303b31fde620463389103215011c6cc49b9a2420a1529889722aa54f26a211179c528709edb6b90ba2efdae5e4bcef18147d9516f3a94e365a
DIST wlroots-0.9.1.tar.gz 464941 BLAKE2B 89598d14d401965d52ee7a6e717f0d574c0b8922bf9441843137baacfaae1928c987543d3c5123fe6612b45e5047a88ec2b099b22e92e747e6431f8375348bd1 SHA512 d43a1ad0441579a7a7ffe28a17546ba851f06aed66b1f8324e69934b4f0f8cc08ae0038a609a51cdcf283e3b0628ec6a29d3f903265f9f3a5cd3d66981cb04c8
75 changes: 75 additions & 0 deletions gui-libs/wlroots/wlroots-0.10.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,75 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit fcaps meson

DESCRIPTION="Pluggable, composable, unopinionated modules for building a Wayland compositor"
HOMEPAGE="https://github.com/swaywm/wlroots"

if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
inherit git-r3
else
SRC_URI="https://github.com/swaywm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm64 ~x86"
fi

LICENSE="MIT"
SLOT="0/10"
IUSE="elogind icccm systemd x11-backend X"
REQUIRED_USE="?? ( elogind systemd )"

DEPEND="
>=dev-libs/libinput-1.9.0:0=
>=dev-libs/wayland-1.17.0
media-libs/mesa[egl,gles2,gbm]
virtual/libudev
x11-libs/libdrm
x11-libs/libxkbcommon
x11-libs/pixman
elogind? ( >=sys-auth/elogind-237 )
icccm? ( x11-libs/xcb-util-wm )
systemd? ( >=sys-apps/systemd-237 )
x11-backend? ( x11-libs/libxcb:0= )
X? (
x11-base/xorg-server[wayland]
x11-libs/libxcb:0=
x11-libs/xcb-util-image
)
"
RDEPEND="
${DEPEND}
"
BDEPEND="
>=dev-libs/wayland-protocols-1.17
virtual/pkgconfig
"

src_configure() {
# xcb-util-errors is not on Gentoo Repository (and upstream seems inactive?)
local emesonargs=(
"-Dxcb-errors=disabled"
-Dlibcap=$(usex filecaps enabled disabled)
-Dxcb-icccm=$(usex icccm enabled disabled)
-Dxwayland=$(usex X enabled disabled)
-Dx11-backend=$(usex x11-backend enabled disabled)
"-Dexamples=false"
"-Dwerror=false"
)
if use systemd; then
emesonargs+=("-Dlogind=enabled" "-Dlogind-provider=systemd")
elif use elogind; then
emesonargs+=("-Dlogind=enabled" "-Dlogind-provider=elogind")
else
emesonargs+=("-Dlogind=disabled")
fi

meson_src_configure
}

pkg_postinst() {
elog "You must be in the input group to allow your compositor"
elog "to access input devices via libinput."
}

0 comments on commit a6f0ce7

Please sign in to comment.