Skip to content

Commit

Permalink
app-arch/xar: fix arm and ppc64, bug #650024
Browse files Browse the repository at this point in the history
Due to a different signedness of char type on arm and ppc, xar wouldn't
start at all on these platforms.  A weird (compiler?) bug caused a
completely random offset to be taken obviously failing any checksums.

Fixes: https://bugs.gentoo.org/650024
Closes: https://bugs.gentoo.org/650024
Package-Manager: Portage-2.3.19, Repoman-2.3.6
  • Loading branch information
grobian committed Mar 11, 2018
1 parent 7cf89b6 commit a770236
Show file tree
Hide file tree
Showing 2 changed files with 70 additions and 0 deletions.
23 changes: 23 additions & 0 deletions app-arch/xar/files/xar-1.8-arm-ppc.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,23 @@
--- a/lib/archive.c
+++ b/lib/archive.c
@@ -387,7 +387,8 @@
return NULL;
}

- XAR(ret)->heap_offset = xar_get_heap_offset(ret) + offset;
+ XAR(ret)->heap_offset =
+ XAR(ret)->toc_count + sizeof(xar_header_t) + offset;
if( lseek(XAR(ret)->fd, XAR(ret)->heap_offset, SEEK_SET) == -1 ) {
xar_close(ret);
return NULL;
--- a/src/xar.c
+++ a/src/xar.c
@@ -783,7 +783,7 @@
int main(int argc, char *argv[]) {
int ret;
char *filename = NULL;
- char command = 0, c;
+ signed char command = 0, c;
char **args;
const char *tocfile = NULL;
int arglen, i, err;
47 changes: 47 additions & 0 deletions app-arch/xar/xar-1.8-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,47 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit flag-o-matic multilib-minimal ltprune

APPLE_PV=400
DESCRIPTION="An easily extensible archive format"
HOMEPAGE="https://opensource.apple.com/source/xar/"
SRC_URI="https://opensource.apple.com/tarballs/xar/xar-${APPLE_PV}.tar.gz"

LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="libressl kernel_Darwin"

DEPEND="
!kernel_Darwin? (
virtual/acl
!libressl? ( dev-libs/openssl:0=[${MULTILIB_USEDEP}] )
libressl? ( dev-libs/libressl:0=[${MULTILIB_USEDEP}] )
)
app-arch/bzip2[${MULTILIB_USEDEP}]
sys-libs/zlib[${MULTILIB_USEDEP}]
dev-libs/libxml2[${MULTILIB_USEDEP}]
"
RDEPEND="${DEPEND}"

PATCHES=(
"${FILESDIR}"/${PN}-1.6.1-ext2.patch
"${FILESDIR}"/${PN}-1.8-safe_dirname.patch
"${FILESDIR}"/${PN}-1.8-arm-ppc.patch
)

S=${WORKDIR}/${PN}-${APPLE_PV}/${PN}

multilib_src_configure() {
use kernel_Darwin || append-libs $(pkg-config --libs openssl)
ECONF_SOURCE=${S} \
econf \
--disable-static
}

multilib_src_install() {
default
prune_libtool_files
}

0 comments on commit a770236

Please sign in to comment.