Skip to content

Commit

Permalink
gui-apps/grim: move wayland-protocols to DEPEND
Browse files Browse the repository at this point in the history
Signed-off-by: Aisha Tammy <[email protected]>
Signed-off-by: Arthur Zamarin <[email protected]>
  • Loading branch information
epsilon-0 authored and arthurzam committed Feb 25, 2023
1 parent c4a2334 commit a78433c
Show file tree
Hide file tree
Showing 2 changed files with 55 additions and 4 deletions.
50 changes: 50 additions & 0 deletions gui-apps/grim/grim-1.4.0-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,50 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit bash-completion-r1 meson

DESCRIPTION="Grab images from a Wayland compositor"
HOMEPAGE="https://github.com/emersion/grim"

if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
else
SRC_URI="https://github.com/emersion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
fi

LICENSE="MIT"
SLOT="0"
IUSE="+man jpeg"

RDEPEND="
dev-libs/wayland
media-libs/libpng
x11-libs/pixman
jpeg? ( media-libs/libjpeg-turbo )
"
DEPEND="${RDEPEND}
>=dev-libs/wayland-protocols-1.14
"
BDEPEND="man? ( app-text/scdoc )"

src_configure() {
local emesonargs=(
$(meson_feature jpeg)
$(meson_feature man man-pages)
"-Dbash-completions=false"
"-Dfish-completions=false"
)
meson_src_configure
}

src_install() {
meson_src_install

newbashcomp contrib/completions/bash/grim.bash grim
insinto /usr/share/fish/vendor_completions.d/
doins contrib/completions/grim.fish
}
9 changes: 5 additions & 4 deletions gui-apps/grim/grim-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2022 Gentoo Authors
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
Expand All @@ -20,14 +20,15 @@ LICENSE="MIT"
SLOT="0"
IUSE="+man jpeg"

DEPEND="
RDEPEND="
dev-libs/wayland
>=dev-libs/wayland-protocols-1.14
media-libs/libpng
x11-libs/pixman
jpeg? ( media-libs/libjpeg-turbo )
"
RDEPEND="${DEPEND}"
DEPEND="${RDEPEND}
>=dev-libs/wayland-protocols-1.14
"
BDEPEND="man? ( app-text/scdoc )"

src_configure() {
Expand Down

0 comments on commit a78433c

Please sign in to comment.