Skip to content

Commit

Permalink
dev-libs/protobuf: fix Objective-C compiler selection
Browse files Browse the repository at this point in the history
During the protobuf configure phase, autotools gives priority
to GCC if $OBJC is unset, thus leading to cases where GCC is
used for Objective-C even though Clang is used for the rest
of the build, so we set OBJC to correctly picks up CC values.

Closes: https://bugs.gentoo.org/830584
Signed-off-by: Adrian Ratiu <[email protected]>
Closes: gentoo#23197
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
10ne1 authored and thesamesam committed Jan 4, 2022
1 parent f973fa5 commit a792e45
Show file tree
Hide file tree
Showing 7 changed files with 14 additions and 7 deletions.
3 changes: 2 additions & 1 deletion dev-libs/protobuf/protobuf-3.16.0.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 2008-2021 Gentoo Authors
# Copyright 2008-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"
Expand Down Expand Up @@ -74,6 +74,7 @@ src_configure() {

multilib_src_configure() {
local options=(
OBJC="$(tc-getBUILD_CC)"
$(use_enable static-libs static)
$(use_with zlib)
)
Expand Down
3 changes: 2 additions & 1 deletion dev-libs/protobuf/protobuf-3.17.0.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 2008-2021 Gentoo Authors
# Copyright 2008-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"
Expand Down Expand Up @@ -74,6 +74,7 @@ src_configure() {

multilib_src_configure() {
local options=(
OBJC="$(tc-getBUILD_CC)"
$(use_enable static-libs static)
$(use_with zlib)
)
Expand Down
3 changes: 2 additions & 1 deletion dev-libs/protobuf/protobuf-3.17.1.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 2008-2021 Gentoo Authors
# Copyright 2008-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"
Expand Down Expand Up @@ -74,6 +74,7 @@ src_configure() {

multilib_src_configure() {
local options=(
OBJC="$(tc-getBUILD_CC)"
$(use_enable static-libs static)
$(use_with zlib)
)
Expand Down
3 changes: 2 additions & 1 deletion dev-libs/protobuf/protobuf-3.17.2.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 2008-2021 Gentoo Authors
# Copyright 2008-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"
Expand Down Expand Up @@ -74,6 +74,7 @@ src_configure() {

multilib_src_configure() {
local options=(
OBJC="$(tc-getBUILD_CC)"
$(use_enable static-libs static)
$(use_with zlib)
)
Expand Down
3 changes: 2 additions & 1 deletion dev-libs/protobuf/protobuf-3.17.3.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 2008-2021 Gentoo Authors
# Copyright 2008-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"
Expand Down Expand Up @@ -74,6 +74,7 @@ src_configure() {

multilib_src_configure() {
local options=(
OBJC="$(tc-getBUILD_CC)"
$(use_enable static-libs static)
$(use_with zlib)
)
Expand Down
3 changes: 2 additions & 1 deletion dev-libs/protobuf/protobuf-3.19.1.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 2008-2021 Gentoo Authors
# Copyright 2008-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
Expand Down Expand Up @@ -71,6 +71,7 @@ src_configure() {

multilib_src_configure() {
local options=(
OBJC="$(tc-getBUILD_CC)"
$(use_enable static-libs static)
$(use_with zlib)
)
Expand Down
3 changes: 2 additions & 1 deletion dev-libs/protobuf/protobuf-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 2008-2021 Gentoo Authors
# Copyright 2008-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"
Expand Down Expand Up @@ -52,6 +52,7 @@ src_configure() {

multilib_src_configure() {
local options=(
OBJC="$(tc-getBUILD_CC)"
$(use_enable static-libs static)
$(use_with zlib)
)
Expand Down

0 comments on commit a792e45

Please sign in to comment.