Skip to content

Commit

Permalink
dev-python/arpeggio: Version bump to 1.9.0
Browse files Browse the repository at this point in the history
Updating the package to the latest available version and introducing support for
Python 3.7.

See: gentoo#10198
Package-Manager: Portage-2.3.51, Repoman-2.3.11
Signed-off-by: Oleksandr Trotsenko <[email protected]>
Signed-off-by: Zac Medico <[email protected]>
  • Loading branch information
bucefal91 authored and zmedico committed Nov 1, 2018
1 parent be901b2 commit a7a3953
Show file tree
Hide file tree
Showing 2 changed files with 35 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/arpeggio/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST Arpeggio-1.5.tar.gz 18856 BLAKE2B 5ceb26d034622c448ea29adc70f6934dc2de8335c526f02d91bc4bccaf435d462516830fa6b124638fdcb0b4aadc859d602e1ec59469077d796b7534fa28f7aa SHA512 533c59635556a3446c04c8b14f53e8ad6a7a39869f39d958bdd52b5a55ad43c533bc42a41999cc149015b34470d8ff0eca295ff1942c75b33a58a403a604c449
DIST arpeggio-1.9.0.tar.gz 757412 BLAKE2B f89850a16b2ac1a87cbac3ae0f10d4c04af6097bfb9292abec24c8b938bdf3b837c4d292650b2e335ee5b4b03cd149e1722e35ceabf1b59fd4577ba7e62a8e44 SHA512 179ec76813476823f316471e1b313f377064a75879c52060e547fd755ae72947594dc4d6e58a798150620e82c8b123fbd88484881c12ccb311c47bc93a45a0cd
34 changes: 34 additions & 0 deletions dev-python/arpeggio/arpeggio-1.9.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )

inherit distutils-r1

MY_PN=Arpeggio
MY_P=${MY_PN}-${PV}
DESCRIPTION="Parser interpreter based on PEG grammars"
HOMEPAGE="https://pypi.org/project/Arpeggio/ https://github.com/igordejanovic/Arpeggio"
SRC_URI="https://github.com/igordejanovic/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
RESTRICT="!test? ( test )"

RDEPEND=""
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/memory_profiler[${PYTHON_USEDEP}]
)
"
S=${WORKDIR}/${MY_P}

python_test() {
pytest -vv || die "Testing failed"
}

0 comments on commit a7a3953

Please sign in to comment.