Skip to content

Commit

Permalink
dev-perl/DBD-mysql: Version bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.20.1
  • Loading branch information
Zlogene committed Sep 27, 2015
1 parent 5fdef2d commit a7fd0d3
Show file tree
Hide file tree
Showing 2 changed files with 53 additions and 0 deletions.
52 changes: 52 additions & 0 deletions dev-perl/DBD-mysql/DBD-mysql-4.32.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,52 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

MODULE_AUTHOR=CAPTTOFU
MODULE_VERSION=4.032
inherit eutils perl-module

DESCRIPTION="The Perl DBD:mysql Module"

SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
IUSE="embedded test"

RDEPEND="dev-perl/DBI
dev-perl/Test-Deep
virtual/mysql[embedded?]"
DEPEND="${RDEPEND}"

if use test; then
SRC_TEST="do"
else
SRC_TEST="skip"
fi

src_configure() {
if use test; then
myconf="${myconf} --testdb=test \
--testhost=localhost \
--testuser=test \
--testpassword=test"
fi
use embedded && myconf="${myconf} --force-embedded --embedded=mysql_config"
perl-module_src_configure
}

src_test() {
if use test; then
einfo
einfo "If tests fail, you have to configure your MySQL instance to create"
einfo "and grant some privileges to the test user."
einfo "You can run the following commands at the MySQL prompt: "
einfo "> CREATE USER 'test'@'localhost' IDENTIFIED BY 'test';"
einfo "> CREATE DATABASE test;"
einfo "> GRANT ALL PRIVILEGES ON test.* TO 'test'@'localhost';"
einfo
sleep 5
perl-module_src_test
fi
}
1 change: 1 addition & 0 deletions dev-perl/DBD-mysql/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST DBD-mysql-4.020.tar.gz 137736 SHA256 9299f39f3903d3e0afa6440401f88329a057834817684aa699a507dad6a993e7 SHA512 4f1b788ec7490e585b5d31e719dfa1418fee210705781e05f19fee5da386fc87d7c56a348e508448f6d83148367fbc41e1f4673f2ccb52f16a62938b40c1d600 WHIRLPOOL 65bf1f3abec057cf77cb2a96195d0193bfdc1f7b7fde7914dc141fc897f0a1a16931fb0b30a644604f5fe409deeee4d552ba88e22282c83f10a9fc99210d672f
DIST DBD-mysql-4.031.tar.gz 145217 SHA256 ae2ee4339fb13429922d76d37e25ce838f98baa011f691a6bbec8513ddb4cfd2 SHA512 b7cdd80e340ecd5d2d9ab59fde73824dc1334afc9ccc3e851e1c5bbf39b95f2a82181d0a78785b8c9543bf4ae6d3115809da186a7778320adeaecdf318876f95 WHIRLPOOL f10f002796c723a4095055e8bbbcb3a585c59f6d2ca1b2937d3a1d5b24d91221ad6d474b403d26fffc34059e13097194933dfca8771a46ce0668485aafc6b782
DIST DBD-mysql-4.032.tar.gz 146476 SHA256 b8e681e719d8f2d1cecb9e8603e13483b09b56508629b079022778e7dfd7bfb6 SHA512 7e7ebaed07f0540079854294cc3ab4a4554fd0f850dd0927b2485cc985c2c9f5b70a650d971027c883cc4d8450020245656f6ff1f792a56d1a2d4b45402d73d0 WHIRLPOOL 79b94c7c85406e0f3a0469c8017594f81f6151eab3059d483c50326222fdb920d12db04a5382dbdc2862cf853e1c421fe0d7acc4a35b131a0f9d39c2d79f5d0b

0 comments on commit a7fd0d3

Please sign in to comment.