Skip to content

Commit

Permalink
games-engines/openmw: Bump to 0.45.0, EAPI 7, fix dependencies
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.69, Repoman-2.3.13
Signed-off-by: James Le Cuirot <[email protected]>
  • Loading branch information
chewi committed Jul 28, 2019
1 parent 80565dd commit a824605
Show file tree
Hide file tree
Showing 2 changed files with 130 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-engines/openmw/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST openmw-0.44.0.tar.gz 4976422 BLAKE2B 9dec8412aa68ac35ba51926c7e5c5a64ce717ea6677162e0b35439a59c482375b7729bd462fa6e8da2e9b463c1121cdca0a5b42f553095da82a83cefb11986ce SHA512 1b178891274361b7821ac1d3d66976ed5d443545531499d98f7ed30823f3891172cc5dcb3f7382ba0f561774a92b9ad8805e0c9582b78d2f010e4ed661219017
DIST openmw-0.45.0.tar.gz 4711103 BLAKE2B 85676294b07170dd6845892e9e7b354c5767428584c76ea2e1a64e9f9c72c46c279fdf5043058d37b927cb55e6cf2e2222833129d64954cdcdb3af4eb4b84dc3 SHA512 b968426659457cf486f6756f7ab82cc4cb34a92923c433dd86f711e5d7097f75441ed17daa50d21f15f1847f5aed1f4c3a094a06cfd3f2e9b90aa182742c596f
129 changes: 129 additions & 0 deletions games-engines/openmw/openmw-0.45.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,129 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit cmake-utils xdg-utils readme.gentoo-r1

DESCRIPTION="Open source reimplementation of TES III: Morrowind"
HOMEPAGE="https://openmw.org/"
SRC_URI="https://github.com/OpenMW/openmw/archive/${P}.tar.gz"

LICENSE="GPL-3 MIT BitstreamVera ZLIB"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc devtools +qt5"

# FIXME: Unbundle dev-games/openscenegraph-qt in extern/osgQt directory,
# used when BUILD_OPENCS flag is enabled. See bug #676266.

RDEPEND="
dev-games/mygui
>=dev-games/openscenegraph-3.5.5:=[ffmpeg,jpeg,png,sdl,svg,truetype,zlib]
dev-libs/boost:=[threads]
dev-libs/tinyxml[stl]
media-libs/libsdl2[joystick,opengl,video]
media-libs/openal
media-video/ffmpeg:=
>=sci-physics/bullet-2.86:=
virtual/opengl
qt5? (
app-arch/unshield
dev-qt/qtcore:5=
dev-qt/qtgui:5=
dev-qt/qtnetwork:5=
dev-qt/qtopengl:5=
dev-qt/qtwidgets:5=
)
"

DEPEND="${RDEPEND}"

BDEPEND="
virtual/pkgconfig
doc? (
app-doc/doxygen[doc]
dev-python/sphinx
)
"

S="${WORKDIR}/${PN}-${P}"

src_prepare() {
cmake-utils_src_prepare

# We don't install license files
sed -i '/LICDIR/d' CMakeLists.txt || die

# Use the system tinyxml headers
rm -v extern/oics/tiny{str,xml}* || die
}

src_configure() {
use devtools && ! use qt5 && \
elog "'qt5' USE flag is disabled, 'openmw-cs' will not be installed"

local mycmakeargs=(
-DBUILD_BSATOOL=$(usex devtools)
-DBUILD_DOCS=$(usex doc)
-DBUILD_ESMTOOL=$(usex devtools)
-DBUILD_LAUNCHER=$(usex qt5)
-DBUILD_NIFTEST=$(usex devtools)
-DBUILD_OPENCS=$(usex devtools $(usex qt5))
-DBUILD_WIZARD=$(usex qt5)
-DBUILD_UNITTESTS=OFF
-DGLOBAL_DATA_PATH=/usr/share
-DICONDIR="/usr/share/icons/hicolor/256x256/apps"
-DMORROWIND_DATA_FILES="/usr/share/morrowind-data"
-DUSE_SYSTEM_TINYXML=ON
-DDESIRED_QT_VERSION=5
)

cmake-utils_src_configure
}

src_compile() {
cmake-utils_src_compile

if use doc ; then
cmake-utils_src_compile doc
find "${CMAKE_BUILD_DIR}"/docs/Doxygen/html \
-name '*.md5' -type f -delete || die
HTML_DOCS=( "${CMAKE_BUILD_DIR}"/docs/Doxygen/html/. )
fi
}

src_install() {
cmake-utils_src_install

local DOC_CONTENTS="
You need the original Morrowind data files. If you haven't
installed them yet, you can install them straight via the
installation wizard which is the officially supported method
(either by using the launcher or by calling 'openmw-wizard'
directly).\n"

if ! use qt5; then
local DOC_CONTENTS+="\n\n
USE flag 'qt5' is disabled, 'openmw-launcher' and
'openmw-wizard' are not available. You are on your own for
making the Morrowind data files available and pointing
openmw at them.\n\n
Additionally; you must import the Morrowind.ini file before
running openmw with the Morrowind data files for the first
time. Typically this can be done like so:\n\n
\t mkdir -p ~/.config/openmw\n
\t openmw-iniimporter /path/to/Morrowind.ini ~/.config/openmw/openmw.cfg"
fi

readme.gentoo_create_doc
}

pkg_postinst() {
xdg_icon_cache_update
readme.gentoo_print_elog
}

pkg_postrm() {
xdg_icon_cache_update
}

0 comments on commit a824605

Please sign in to comment.